Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: can't initialize to MBR!

02 Sep 2010   #91
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64
 
 

Did you delete the entry for XP and then see a new one replace it in EasyBCD? When setting up dual boots here and having any problems loading any second even third installation the firrst set of entries would be wiped seeing a fresh entry even for the host OS.

Since you verfied all necessary boot files were present the refresh on them can sometime be all it takes to get a stubborn OS moving. For XP boot problems of all types there's a roubdup of all types with various other solutions. Boot Dual Missing Ntldr Vista Xp

(Note 7 still uses same type boot loader as Vista)


My System SpecsSystem Spec
.
02 Sep 2010   #92
Alsenor

 
 

Yes, I entered both drives new in EasyBCD.
I also just found out in the NeoSmart forum that I have to let EasyBCD add the drive "automatically", otherwise it will not work right! See "NST/ntldr" - The NeoSmart Forums, where I am advised to: Read the last two lines of my previous post, and stop changing the disk assignment.
That's why it's
auto configure, to stop people pointing it to the wrong place.
I made a new clean install of XP tonight, and it booted fine, but W7 did not boot until I changed the BIOS back to default (RAID).
Then XP doesn't boot, neither in "normal" nor in "last good config".
My System SpecsSystem Spec
02 Sep 2010   #93
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64
 
 

I saw the thread you started over there while looking for some additional references and the reply as well about not all of the older wikis catching with the latest changes seen in the 2.0.2 release. "typical"!

As far as the drive mode that's been the main obstacle for XP all along and why I suggested finding someone running the 32bit flavor to see if the game would run on that. The 32bit 7 has quite a bit more backward compatibility to more then seen with the previous version it has been found.

In fact I slapped a fast install lately on an old XP clunker where every XP driver worked on 7! onboard sound, old video card, main chipset drivers, the works! But since that was to donated for student use the drive was wiped and I spent a good night downloading and installing the 100+ updates found for XP with SP3 already installed!
(Try 5am closing time for that one! sssslowww with repeat trips to the Windows update site)

If it runs on the 32bit the problem with drive modes would be solved for you rather then fussing with constant trips into the bios since XP isn't actually supported on that model to begin with. It would save all the headaches you've been running into.

At least you now know why the entry in the latest version of EasyBCD wasn't working for you. But the best idea is still considering a try of the game on the 32bit 7 especially since MS plans to repeat their reduced prices for the Home Premium edition this fall a year after 7's release.
My System SpecsSystem Spec
.

03 Sep 2010   #94
Alsenor

 
 

It's not just for the game I want to get XP working on the second drive. Now that I have an actual dual boot screen popping up it seems a shame we can't overcome the last hurdle of XP actually booting up! It booted fine as long as I had the BIOS set to IDE, but that didn't work for W7, so I had to reset it to default.
My System SpecsSystem Spec
03 Sep 2010   #95
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64
 
 

Have you gone to the Windows update site since you got XP running again? You might just run into some optional hardware updates for the sata/Raid controllers there as well as anything else not seen at the HP support site. You'll need them!
My System SpecsSystem Spec
03 Sep 2010   #96
Alsenor

 
 

Quote   Quote: Originally Posted by Night Hawk View Post
Have you gone to the Windows update site since you got XP running again? You might just run into some optional hardware updates for the sata/Raid controllers there as well as anything else not seen at the HP support site. You'll need them!
I tried while I was in XP, but couldn't get the Internet connection going. The TCP setting is not found.
My System SpecsSystem Spec
03 Sep 2010   #97
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64
 
 

That's always fun! What type of connection are you running there?

I know when swapping cases back and forth while working on a new build that will be seeing the 64bit Home Premium and reconnecting the main case later I had some fun getting back on with cable here.

The modem was turned off, unplugged, replugged, powered up again due to the other build grabbing it's own cofiguration. Looking under network adapters in the device manager is the first place to see is listed there. If you see more then one item the default you use is left enabled while anything else has to be disabled if not uninstalled.
My System SpecsSystem Spec
03 Sep 2010   #98
Alsenor

 
 

Quote   Quote: Originally Posted by Night Hawk View Post
That's always fun! What type of connection are you running there?
I have a cable modem going to a wireless router. Using a cable connector from router to PC.
My System SpecsSystem Spec
04 Sep 2010   #99
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64
 
 

At first you may have to follow similar footsteps by looking over the ISP's own FFAQs. Adding a router in at first was a pain here for sure! That was solved however with a fast trip through the ISP's support pages.

I can't say this method would work well for you however depending on if you plugging into the router by usb or by a nic card installed in a pci slot to be hardwired out to the router. This would be a quick set of steps to take.
1) Review support for router as well as installation of software/drivers on XP
2) Review the Device Manager>network adapter sub section to if the adapter item is working properly with a right click for the properties screen and not seeing any yellow or red marked item(s).

Now depending on your ISP if you have an assigned user name/password you would then set up a new account in Outlook Express using that information to get mail going while if nothing is yellow marked in the network adapter sub.

3) Look at the "Network Connections" in the CP being XP there. It wouldn't be any good showing screens from the XP Mode for sure since that uses NAT virtual networking.

Your interest would be looking at the Local Area Connection Status to see if XP is all set as far as the router is concerned. Most likely XP is already synced with the router but may still need to get past that.

Have you connected with the same connection with XP previously with the router inline? If you start recycling power on both router and modem and synce the modem with the ISP while everything is shutdown you could lose the connection for 7.

The methods can be different at times between the two versions. Here while the router was inline it was still hardwired by the RJ-45 cables for both pc and modem.
My System SpecsSystem Spec
04 Sep 2010   #100
Alsenor

 
 

I have a cable connection that is "always on", and usually gets picked up by any system without entering user/pass, which I don't have anyway.
My System SpecsSystem Spec
Reply

 can't initialize to MBR!




Thread Tools




Similar help and support threads
Thread Forum
WD 320 GB that can't initialize
I have a similar problem that can't solve. I have a WD 320 GB that can't initialize. It all started when I disconnected it without using the notifications icon on the right below (in windows 7). Immediately after that I tried to connect it to another computer, but couldn't open the drive,...
Hardware & Devices
Cannot Initialize Harddrive
Hey, I boot into windows and my Raid0 disks are gone, Disk Management shows the disk as Unallocated. Unable to initialize the disk even, just gives an error "Windows cannot find the file specified" the first time after i launch windows, after that it greys out and im unable to use that option. ...
Hardware & Devices
How to add 3Tb drv for music: initialize as MBR or GPT?
I want to add this 3tb drive as a digital music repository, from which I will play my ripped CDs. It is installed and the PC (Win7 Prof) asked if I wanted to initialize as MBR or GPT? I have the OS on a SSD, have a 500GB HDD installed for games etc. Well gurus, which option do I...
Hardware & Devices
Can't initialize drive
Just built new pc. My os is on an ssd. Win 7 home. I also have a 1 tb mech drive. When initializing the mech drive I canceled the process. Dummy. Now I am unable to initialize. The drive is listed in the device mgr. It is shown under manage drives but nothing telling me that the drive needs to be...
Hardware & Devices
Cannot Initialize HDD
Hey there, I'm having trouble getting my new Seagate Barracuda 1.5TB HDD to initialize. It Shows up under devices, and I'm able to see it's properties etc... When I locate it with the device manager, and right click it, I'm only given the options to Uninstall, Update the Drives, Disable, Scan...
Hardware & Devices
XP Can't Initialize
I installed everything ok. I have an e8300 which is listed in the supported CPU's list. When I go to run it for the first time, I get this error http://www.badongo.com/t/800/6096768.jpg It then proceeds with the setup until it reaches the end and gives me the "can't initialize" error, or...
Virtualization


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:00.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App