Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Weird issue with monitor...

21 Aug 2010   #1
Punkster

Windows 7 Ultimate SP1 (64-bit)
 
 
Weird issue with monitor...

Hi Forum, i'm running Windows 7 Home Premium 32-bit and this is my issue..

I have a 19" LG Monitor.. no problems whatsoever, but...

Windows shows that there are 2 monitors.. W1943 (the LG) and a Non-PnP Generic monitor, thing is.. i only have the LG...

I don't know if this is a Nvidia issue or a monitor issue, because my cousin and i built the EXACT same PC (different video cards, though) same mobo, same rams, same processor, same case, etc. and his PC shows only 1 monitor, W1943.

Here's a screenshot (I'm venezuelan so the windows is in spanish language)



Any inputs? Maybe a faulty video card? another weird thing... the card says it's 5.1 on WEI for games, but only 3.5 for Aero, is this normal?? here's a SS



Thanks in advanced...

Cheers


My System SpecsSystem Spec
.
21 Aug 2010   #2
Petey7

Windows 7 Professional SP1 64-bit
 
 

It's hard to say about the WEI score. My score for both graphics test differ, but not so drastically. They are also lower, so that might be related (exponents anyone?).

I'm not 100% sure yet, but it looks like your video card supports two monitors for the one card. This may be the cause of the second monitor appearing in that area.
My System SpecsSystem Spec
21 Aug 2010   #3
Lemur

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer
 
 

Did you get the latest drivers for your bios and video card?
My System SpecsSystem Spec
.

21 Aug 2010   #4
Punkster

Windows 7 Ultimate SP1 (64-bit)
 
 

Quote   Quote: Originally Posted by Lemur View Post
Did you get the latest drivers for your bios and video card?
Yep, current BIOS on the mobo, current drivers on the video card.

Can't figure out why.. it's not bugging me, but its just weird.. i bet is the card.. i plugged my cousin's monitor on my pc, same thing... plugged mine on his pc.. only 1 monitor shows up..
My System SpecsSystem Spec
21 Aug 2010   #5
DocBrown

Win7 Enterprise, Win7 x86 (Ult 7600), Win7 x64 Ult 7600, TechNet RTM on AMD x64 (2.8Ghz)
 
 

Are you connecting the monitor with only one cable ? VGA, DVI, HDMI ?
My System SpecsSystem Spec
22 Aug 2010   #6
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

Quote   Quote: Originally Posted by Punkster View Post
Hi Forum, i'm running Windows 7 Home Premium 32-bit and this is my issue..

I have a 19" LG Monitor.. no problems whatsoever, but...

Windows shows that there are 2 monitors.. W1943 (the LG) and a Non-PnP Generic monitor, thing is.. i only have the LG...

I don't know if this is a Nvidia issue or a monitor issue, because my cousin and i built the EXACT same PC (different video cards, though) same mobo, same rams, same processor, same case, etc. and his PC shows only 1 monitor, W1943.

Here's a screenshot (I'm venezuelan so the windows is in spanish language)



Any inputs? Maybe a faulty video card? another weird thing... the card says it's 5.1 on WEI for games, but only 3.5 for Aero, is this normal?? here's a SS



Thanks in advanced...

Cheers
For the double monitor problem, Windows may be reading the monitor's EDID and showing you that the monitor is available to be used in both modes. When most monitors are detected by Windows, the display characteristics are read from the monitor, and Windows makes sure that it is talking to the right monitor, or if it isn't, it tries to decide if it needs to change the resolution, etc.

The PnP monitor might show up in Device Manager as well. Basically, it isn't a problem, other than the fact that it is a bit strange. I wouldn't worry too much about it, since Windows is using the correct monitor parameters to display, right?

About the WEI. Depending on the graphics card, you will sometimes get a different score for Aero than for games. My old Radeon 3450 gave me 5.1 for games, and 3.5 for Aero, but when I upgraded to a 4670, my score became 6.7 for both. I think Windows rates Aero as more demanding or something, and a lower end card will have a lower score for it than for games. Your card is still more than capable of using Aero, and it will be good for plenty of games, so no worries there, either.
My System SpecsSystem Spec
22 Aug 2010   #7
Punkster

Windows 7 Ultimate SP1 (64-bit)
 
 

Quote   Quote: Originally Posted by DocBrown View Post
Are you connecting the monitor with only one cable ? VGA, DVI, HDMI ?
Yes.. i'm connecting the monitor via VGA cable.. there's no DVI on this one...

The monitor actually works just fine... 1360 x 768 @ 60Hz as advertised... but having 2 monitors listed on windows is weird...

Here's another SS for you guys to see, i can even see the 2 monitors.. duplicate the screens, extend them.. etc. weird thing, let me tell you.



I think i'm going to hook it up to the Integrated VGA Port on the MoBo and see if windows still shows 2 monitors... that way i'll discard the video card from being the guilty or not...

SS later.. probably in a day, i had a really bad cut in my finger today.. it took 2 stitches.. kinda sucks...
My System SpecsSystem Spec
Reply

 Weird issue with monitor...




Thread Tools




Similar help and support threads
Thread Forum
Weird glitch on monitor!!!
ok this is what i have tried so far: 1. New monitor - no fix 2. Different video card - no fix 3. changed drivers on video card - no fix 4. changed direct x - no fix 5. Reinstalled win 7 - no fix 6. changed frequency and resolution properties multiple times - no fix So...
BSOD Help and Support
Weird Monitor Refresh Problem
So my problem is that my computer for some reason causes the picture on my monitor (LG Flatron W2453V) to be interrupted and goes black for 2-3 seconds then it comes back again. This is a very sporadic instance, sometimes it will do it 3 times in a row or not for 3 hours sometimes it will do it...
Graphic Cards
Weird issue with multiple monitor set-up
Hi, I wasn't sure where the best place for this was so took a guess. I recently made the leap to having two monitors rather than one. I started with a Samsung syncmaster T200, and purchased two LG W2246's. My PC has a Radeon 6850. My issue is that for some reason, having the Samsung and one...
Hardware & Devices
Weird issue?
Hey guys, I just recently reformatted my computer. For some reason the load ups performance of it is ridiculously slow. And I mean SERIOUSLY slow. My specs are: i7 910 processor 6 gb ddr3 ram 2 500 7400 rpm hard drives. gtx 460 graphic card
Performance & Maintenance
Dual monitor issue, secondary monitor is undetectable
I have just did a clean install of Windows 7 ultimate from XP and I am unable to get my dual monitors to work like they did in XP. I have a DVI Radeon graphics card plugged into the agp slot, and a Nvidia geforce vga adapter plugged into a pci slot of my dell optiplex 755. When I am in the...
Graphic Cards
Dual Monitor Issue-Can't drag MedPlay to Second Monitor
Here is my problem. I have a primary monitor and then I run S-Video out to the TV so I can watch video clips. With Vista, I had no trouble starting a video clip in media player on the primary screen and then dragging it over to the second monitor (TV) for actual viewing. However, I tried to do...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:59.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App