Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: SD Card semaphore Timeout?

13 Sep 2010   #1

SD Card semaphore Timeout?

Tried to load my 16GB SD card (which usually always worked before on this laptop with Windows 7 64 bit) but now get the error shown in screenshot.


Transcent SD HC 16GB
Windows 7 64 bit
Sony Vaio laptop

Attached Images
SD Card semaphore Timeout?-1.png 
My System SpecsSystem Spec
13 Sep 2010   #2

7 Home Premium (64bit)

Never had the issue myself, but found this in Google.

Error 0x80070079: The semaphore timeout period has expired
My System SpecsSystem Spec
14 Sep 2010   #3


the only time i had that error was when i had an external usb hard drive with faulty sectors, it seems to be a timeout error. Is the SD card definately ok?
My System SpecsSystem Spec

14 Sep 2010   #4

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86

1. It may be a problem with the connection. Try hooking up the card some other way say through an external card reader.

2. Does the card read right on another machine?

3. Does this error occur while copying files? That can happen with too long filenames or paths that are too long. Try renaming the file or folder and/or moving it up a directory or two before copying it.
My System SpecsSystem Spec
13 Nov 2011   #5

Windows 7 Ultimate 64-Bit

Thread necromancy doesn't make for a wonderful first post I admit. But this is the first google result, nobody on the entire internet has solved this problem, and I found out something new about it.

First: The fix I used. Mount the SD cards under any linux distribution (i used a kanotix livecd). That's it. Then they'll work under Windows again. This worked for one of my cards and made it usable again, but not the other. It's strange.

Second: What a semaphore is. from Essentially a semaphore timeout means the multitasking is being pre-empted by something else on a fairly low level.

The fact that this is a card-by-card error, and the fact that chkdsk reports the filesystem as raw (my error was only upon file access, not entire disk access, but other than that the symptoms are identical), makes me believe a faulty SD reader driver is altering something on the card itself, which when read back, causes some driver process to to hang. This was later fixed upon mounting and dismounting it under Linux. Now, with both of my cards, my mp3 player (and Linux on the same machine) were still perfectly able to make use of them with no timeout issues whatsoever so this is very exclusively a windows driver error.

To clarify: After mounting it and dismounting it under linux, one card returned to a normal usable state, the other did not. Both were able to function under Linux, where I obviously backed up the data on each. I then backed up the data AGAIN under windows to make sure the timeout error was gone (it was occurring on SPECIFIC files, so being able to do a full backup under windows with one card indicated the error was gone).

This is with a Thinkpad T510 which uses the Ricoh 4-in-1 card reader, which I believe is the same one Sony uses in their Vaio line.
My System SpecsSystem Spec
08 May 2013   #6

Win7 Pro SP1 64-bit

I'm having the same error, with some SD cards and not others, using a Lenovo T510 laptop with a Ricoh card reader. Win7 Pro SP1 32-bit. The Win7 provided SD card reader driver, as well as the Ricoh SD card reader driver, issue the same semaphore timeout error for the cards that can't be read.

ALL cards I've tried to date are read and written correctly from my camera, my EeePC's card reader [not a Ricoh] and using a cheap four year old USB multi-card reader plugged in to any machine including the Lenovo T510 laptop.

The suggestion to mount and read using kanotix livecd hasn't helped yet (darn!) -- I'll keep trying. But I must concur the error lies with the Ricoh hardware and/or drivers, not the cards.
My System SpecsSystem Spec

 SD Card semaphore Timeout?

Thread Tools

Similar help and support threads
Thread Forum
error 0x80070079: The semaphore timeout period has expired
hello all, suddenly i am getting the following error message: error 0x80070079: The semaphore timeout period has expired. this happens when trying to copy a 4gb file from my c: drive to my d: drive. i had been able to copy the folder (my thunderbird profile) with no problems at all....
BSOD Help and Support
Error 0x80070079 SD card semaphore period timeout
So I did a search and found nothing definitive regarding this particular error in my application. I have a Dell laptop with an i7 processor, an SSD drive and 8g of ram, running Win7 Pro 64 bit. I put a 128G micro sd card into the sd card adapter and slapped into the slot. When I try to move...
General Discussion
Connection timeout
Hello: I see in a few places that the connection timeout time for FIrefox 4 cannot be changed in Firefox itself, but in Windows 7 (64-bit) registry. If that is correct, could anyone know where and how? I also wonder if there are anywhere in Win7 to set the number of connection tries before...
Network & Sharing
shutdown timeout?
Hy everybody Does anybody know if win 7 allows you to change the shutdown timeout from the registry editor, like the old xp did (I succeeded to shut down xp in about 9-10 sec, but I don't know how to do the same in win7).Thank you all, best wishes.
Performance & Maintenance
Timeout in Thunderbird
I have Windows 7 64 bit, HP laptop, with an internal modem(I'm on dialup). Thunderbird shows that everything was setup successfully, but when I try to get mail, I get the message: "Connection to server "--------" timed out. Things I've tried were going into config editor and changing values in...
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:27.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App