Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB Device already in use - but nothing plugged in?!

18 Sep 2010   #11

Windows 7 Home Premuim 64bit

Thanks for the response Aphelion.

It's possible that it has been plugged in to multiple usb ports, since I had this laptop I've only used it a few times so I probably forget which port I plug it in to. I have had one or two other controllers too (not anymore though) which might be adding to the confusion. I only have this one now so all the rest can be deleted from the registry if that is possible.

I tried your suggestion of uninstalling it and turning off etc but it hasn't helped unfortunately.

I'm concerned about this 'usb composite device' that runs with nothing plugged in, it seems strange to me.

I've run full scans and nothing was found.

My System SpecsSystem Spec
18 Sep 2010   #12

Windows 7 Home Premium

Quote   Quote: Originally Posted by sitarra View Post
Thanks for the response Aphelion.

I tried your suggestion of uninstalling it and turning off etc but it hasn't helped unfortunately.

I'm concerned about this 'usb composite device' that runs with nothing plugged in, it seems strange to me.

Have you edited a registry before?

I can post the information you need to most likely correct the problem but it might seem a daunting task if you've never edited the registry before.

The USB Ports information is found here:

HKEY_LOCAL_MACHINE / SYSTEM / CurrentControlSet / Enum / USB

You should be able to find all of the port listings + USB Audio Devices and Composite Devices there.

First I would search out all instances of the MIDI IN & OUT ports related to your keyboard and delete those, I would also search out the keyboard by name MPD32
and delete any related keys... being careful not to delete root keys unless they directly mention the MIDI IN/OUT ports or MPD32.

Then take a look at the USB ports.

If you just want to try deleting the ports, go to Device Manager... then to the USB section, take a look there and delete the composite and audio devices.

Disclaimer.. you can seriously foul up your machine editing the registry, it can render the OS unusable or unbootable.

+++Back the system up before jumping in.+++

On the plus side, you're not in areas that are likely the mess things up too badly.

My System SpecsSystem Spec
18 Sep 2010   #13

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

Make a system restore point, first, too.
My System SpecsSystem Spec

19 Sep 2010   #14

Windows 7 Home Premuim 64bit

Thanks for posting that. I have done a little reg editing before but not a great deal.

I deleted all the MPD32, USB Audio even the Composite Devices but it doesn't seem to have solved the problem. After doing this and plugging the MPD32 back in the Composite Device and MPD32 reinstall themselves but everything is the same as before.

I tried disabling the Composite Device in Device Manager while the MPD32 was plugged in and that stopped the MPD from being recognised by any programs so I assume it's something related to the MPD.

I'm getting so fed of this issue, I'm quite tempted to just reinstall Windows but that's a real pain in the *** to have to do that and reinstall everything else. This is what drives me mad about making music on computers, sometimes it seems you spend more time being technician than musician.
My System SpecsSystem Spec
22 Mar 2011   #15

win 7 64 bit


I have the exact same problem with my akai mpk49... did you find a solution? where you able to get your mpd32 working again? if yes, how?
My System SpecsSystem Spec
22 Mar 2011   #16

Windows 7

Look for a program called USBdeview, I've only used it once for a USB problem like yours but it worked a treat. You can see everything USB that's ever been used, you can uninstall all the USB devices you know won't ever be needed including the problematical one (and any duplicates) you want to work properly, and then let Windows re-discover it again as if it's a new system.
My System SpecsSystem Spec
23 Mar 2011   #17

Windows 7 Home Premuim 64bit


I did try the program that sbrads mentions (or one like it, I don't remember the name) but it didn't solve the problem for me. I did find a solution however.

Unfortunately it was to reinstall windows but only in the way that it keeps everything on your computer (sorry I don't know what this is called, Upgrade install I think - Repair Install).

Bit of a hassle but everything was left intact and I was able to use MPD afterwards.
My System SpecsSystem Spec

 USB Device already in use - but nothing plugged in?!

Thread Tools

Similar help and support threads
Thread Forum
Device is not plugged in.
Hi, I've had a Sony Vaio SVE14AA11M and it has been giving me a multitude of problems. I'll be creating other threads on other forums for the other problems, but this one regards a problem I'm having with the sound card. The issue I'm having is that the pc does not recognize the sound driver....
Sound & Audio
XP vm freezes when USB device is plugged in.
I have an XITEL HiFi-Link For PC and Mac: Electronics It's a USB sound card. I have used it on an XP machine, and a Win7 machine without issues. If I try to connect to to my Win7 machine, giving my XP machine exclusive use of the USB device, XP locks up! Any guess as to what...
BSOD when plugged in usb device
including mouse, adapter, pendrive.. this happen frequently
BSOD Help and Support
Why I don't have pop up when device plugged in?
Ever since I bought my new rig I've been wondering why I don't have pop up window when I plug in something. Screenshot in attachment shows what I mean. Its marked to do so, but no pop up ever appears. Any ideas, fixes anything would be helpful.
Sound & Audio
computer not responding when USB device is plugged in.
Hi All, my first post... I have a HP Tx2z, with Windows 7 RC1 x64. The only problem I'm having is when I insert a USB device, can be a wireless mouse, USB flash drive, USB hardrive, phone, usb keyboard (appears to be anything), sometimes my computer locks up COMPLETELY, and needs the power...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:49.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App