Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Installation ram issue

23 Sep 2010   #1

Windows 7 32-bit
Installation ram issue

Just interested if anyone else has seen the following problem with Win 7 installation.
BTW this is a GB p55-ud3r board with 4 gig ram, core i5 not overclocked.

I decided to upgrade to 64 bit after using 32 bit since it came out last year. Back then I remember having no issues with the 32-bit install, and the comp is the same config as it was then, except for BIOS version. So to make things easier I purchased a new 500 gig drive. Tried installing x64 version and it would complete but upon the first reboot where it updates the registry settings it would restart and show the "Windows failed to start" screen. And would just remain in this reboot loop.

So I tried installing the 32 bit using the same legit copy that I used last year, and it did the same thing. OK, the hd is DOA then. So I tried installing 32 bit on my old drive and it still did the same reboot loop! I checked ram with memtest+ - all good. New HD checked out fine too.

Anyway, after flashing to the newest BIOS etc and trying just one stick of ram at a time this problem remained. Then after 2 days of hair-pulling I decided to put the single stick of ram in slot #3 (slots #1 & #3 are on different channels), thinking maybe slot #1 is fried. And ta-da, Win 7 booted.

After the successful boot I put the stick back in slot #1 and it still booted successfully. Ran the "Memory Diagnostic Tool" at startup and it found no problems. Put the other stick in as well and still no problems. It's been running like a dream since.

So any ideas why this happened - why win 7 won't install with ram in the first slot? Since the only thing that has changed with the pc config is bios updates, I'm thinking Gigabyte has screwed something there. But it doesn't explain why everything is working fine with all sticks used and windows is up and running.

My System SpecsSystem Spec
24 Sep 2010   #2

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

Hello jabbado. Welcome to the forum.

The first idea that came to mind was that there was an error in the memory controller. This gets complicated because the Intel Core i series motherboards have moved the memory controller from the (now extinct) Northbridge controller to the processor itself.

We used to routinely do a procedure called a "CPU Parameter Recall". This was (and I think still is) important to do when updating a bios or particularly when upgrading a CPU. Here it is:
  • Record all your preferred BIOS settings (so you can set them back later easily).
  • Enter the BIOS and Restore Bios Defaults. Save & Exit to reboot.
  • Enter the BIOS again. Then shut down the computer.
  • Disconnect the power from the system and wait at least 2 minutes (This performs the CPU Parameter Recall).
  • Reconnect the power, boot, Enter the BIOS, and Restore BIOS defaults again, Save & Exit to reboot.
  • Enter the BIOS again. Now restore all your preferred settings. Exit and Save. Let it boot into Windows.

When you update a BIOS it is important to Restore BIOS defaults before flashing the BIOS and after. If you did not do this when you upgraded your BIOS that may explain what happened.

Hope that helps.
My System SpecsSystem Spec
24 Sep 2010   #3

Windows 7 32-bit

TVeblen, thanks for your input.

Yeah I know about the integrated memory controller with the new cpu's. That's what had me worried at first.

I did a search about CPR and it seems to be a feature of Asus boards only?? Anyway, yes I always load defaults before and after flashing. But on this build I've been running it stock since I haven't got round to buying a decent HSF yet. So it wasn't a problem with any oc setting or anything like that.

It's still puzzling me why this happened. The system has been running perfectly stable for the past couple of days though, knock on wood. :)
My System SpecsSystem Spec


 Installation ram issue

Thread Tools

Similar help and support threads
Thread Forum
Installation Issue with IE9, Etc.
I'm having two issues which may or may not be related. A day or two ago I noticed that my IE9 was no longer working. When I go to click the IE9, nothing happens. I decided to just uninstall it, but IE9 isn't even listed anywhere on the uninstall list. I try to download it off Windows Update,...
Windows Updates & Activation
Installation issue
Hello, I recently tried to reinstall windows 7, I booted using the windows dvd, started the custom installation option and when my hard disks screen came up i deleted all the existing partitions so the windows could create a new one. the problem is that windows wont create a partition, for reasons...
Installation & Setup
Odd Re-Installation Issue
Hiya. Brand new laptop, with Windows 7 installed already. Plugged in a USB device which somehow corrupted my USB drivers. Cue much faffing around, then decide to re-install Windows 7 from the CD provided. (Attempting a repair with the drivers CD did nothing.) Re-installation complete but I...
Installation & Setup
dvd installation issue
i am able to get windows 7 to boot and start the installation but before i get to select the partition i get a message saying; A required CD/DVD drive device driver is missing. If you have a driver floppy disk, CD, DVD, or USB flash drive, please insert it now. i am trying to install to a...
Installation & Setup
Installation Issue
I know the answer is don't upgrade a Windows 7 install however I am putting Win 7 on my son's system. In the upgrade process it tells me to close "PC Cillin Network service" but I have never had PC Cillin on that system. Anyone have any ideas how I might fix this issue? Otherwise I will just...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:37.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App