Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: TSSTcorp TS-L632HH device problem

23 Sep 2010   #1

Windows 7 Ultimate x32
TSSTcorp TS-L632HH device problem


I have searched this forum in hope to find a solution to my problem, but non worked.
I have windows 7 ultimate x32, my laptop is ASUS F3JC.

What my problem is:
My device TSSTcorp TS-L632HH does not show in my computer or device manager until i insert a cd/dvd and go on "scan for new hardware", then it shows and reads normally, for a period of time, and disappears again when cd/dvd is removed.

There is a AZYRI device constantly showing up, but i have no such device. I have cdburnerxp (CDBurnerXP: Introduction and News) and deamontools lite installed.
Yfrog Image :

What i have tried to solve the problem:
-Unistalled device ,restarted PC
-Tried with "Mats_Run.dvd.exe" (it lists only the AZYRI drive)
Yfrog Image :
-Downloaded a winaspi32.dll and placed it in my system32 folder ( in it was no such file, so no replacement occured)

I have no intention of reinstalling windows 7 and i can't do a system restore(have that option turned off).

Hoping to hear suggestions of what could be the problem, and a possible solution.

Ty in advance.

My System SpecsSystem Spec
23 Sep 2010   #2

Windows 7 Ultimate x64

The AZYRI device is the name given to the virtual drive installed by Daemon Tools.

Concerning the TSST drive, when you go to the System Tray and click the Safely Remove Hardware and Eject Media icon, does that drive show up?
My System SpecsSystem Spec
24 Sep 2010   #3

Windows 7 Ultimate x32

Hi mpcrsc562. Thank you for your reply.

I have no such icon in system tray. If you mean when i insert a USB , then it shows up. Screenshot is below:
Yfrog Image :

As you can see my drive is not listed there. Only when i insert a disk in it, and go to device manager - scan for changes, which makes no sense to me...
My System SpecsSystem Spec


 TSSTcorp TS-L632HH device problem

Thread Tools

Similar help and support threads
Thread Forum
NAS device shown as UPnP Media Device not Storge Device in Explorer
I have three NAS units on my home network - WD My Cloud 6TB, WD My Book Live Duo 8TB and Seagate GoFlex Home 4TB. The two WD units show up as storage devices but the Seagate shows up as a UPnP AV device. This means I cannot see or access any of the folders. I can only get to it thru Window Media...
Network & Sharing
TSSTCorp CDDVD SH222BB not ripping cds properly
Apologies if this is the wrong sub forum. I have the TSSTCorp CDDVD SH222BB and quite a few rips to FLAC via dbpoweramp result in a file filled with distortion and noise, yet others rip perfectly. I've been trying to find a firmware update for the drive, but I'm stumped. I'm running a fully...
Hardware & Devices
DVD TSSTcorp Cannot be Accessed in Windows
I have suddenly lost the ability to access my TSSTcorp DVD in Windows . This is showing a yellow exclamation mark next to it in DM with an associated error message quoting Error 19. PC boots OK from bootable DVD disks when inserted in this drive but the drive is invisible in Windows Explorer. ...
Problem with W7 Pro and USB device ?
Hope this is the proper forum...maybe a BB user out there...?....Have Windows 7 Pro PC and BB 8330 (Device Manager time I click the W7 USB removal/disconnect/eject icon I get the following error: "The 'Rim Blackberry SD USB Device' device is not removable and cannot be...
Hardware & Devices
7077 causes HD LED "tick" if TSSTcorp burner enabled
On Windows 7 32 bit build 7077 the HD LED "ticks" once per second. I googled and found related issues with CDROM drives and AutoPlay. The fix for XP was to set AutoPlay to 0 in the registry for the CDROM device. I have AutoPlay set to 0 running Windows 7. If I disable the CDROM device in...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:19.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App