Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Wacom Tablet, ring round pen cursor

17 Aug 2009   #11

windows 7

There is one small problem with that. I need the pen mode for my work. Try writing your name in mouse mode!

I have another update. I received an evaluation copy of the Wacom tablet. Very briefly the splashes came back... until I re enabled tablet mode. Ctrlpanel->Add/remove windows components-->Tablet PC components.

So now i have this situation
A) When Tablet PC components are installed
Adesso tablet experiences splash marks...
Wacom tablet does not...
B) When Tablet PC components are not installed
Wacom tablet experiences splash marks...
Adesso tablet does not...

Color that bizarre.

My System SpecsSystem Spec
18 Aug 2009   #12


That sucks, I haven't really used my tablet for writing purposes so I never noticed, heh.
My System SpecsSystem Spec
18 Aug 2009   #13


Can you give some more sample question and answers. How great your info is! It really useful for me. Thanks.

calcul pret assurance simulation taux emprunt immobilier - Taux emprunt immobilier. Comparez les offres d’emprunt immobilier, simulation emprunt immobilier, taux emprunt immobiliercalcul pret assurance simulation taux emprunt immobilier
My System SpecsSystem Spec

05 Oct 2009   #14

Win7 Enterprise Trial (x64)

I found the registry locations responsible for these animations, which in previous versions were referred to as "Dynamic Pen Feedback." It's all controlled by WISP, the Windows Inking Services Platform, and there is a section which enumerates WISP settings which is mirrored in these three locations across the registry:

If you're new to working with the registry, and you don't know what that means, let me know and I'll make a deployable reg patch you can just double-click. No time tonight though. Anyway:

Concerning this topic, I think the only values that control the splash and other animations are Splash and UIFeedbackMode, which you should set to (decimal) 0. If you have UAC on it's going to give you fits, as usual, and likely one of those branches is going to tell you you don't have permission in any case, so you'll need to give yourself permission for that key.

Also interesting is how many other awful things the default WISP settings impart to pen functionality. I went through and set almost everything in those keys to 0, because on the desktop I never use handwriting input or Flicks and I sure don't need these settings confounding the rather delicate setup I impart through the Wacom driver and some applications like Painter which add yet another level of fine tweaking to the whole process.
Take a look at the (mostly) self-explanatory value names under those keys and you might notice that things like WaitTime and HoldMode may also be impacting the responsiveness of your tablet pen in various applications.
Also, I've noticed that by default (under \Wisp\MultiTouch) Win7 just assumes that you're using multitouch capabilities when you enable tablet functionality, which could cock things up royally for multiple-tool users.
My System SpecsSystem Spec
06 Oct 2009   #15

windows 7

Great. I'll dig through keys when I have the time.
My System SpecsSystem Spec
06 Oct 2009   #16

windows 7

You know what, this just hit the top of my todo list. So I make screen captures for a living. I ended up getting rid of hte problem awhile back by clean installing windows. Just today the splash marks came back when I opened the input panel for the first time. I can't get rid of them. I need the inking tools so I can mark up word. But the cursor splashing is unacceptable for making screen recordings.

I tried going through and modifying the registry and did indeed hit a wall with UAC. I am the administrator/owner of this machine and i still can't figure out how to get around this nonsense. I can't earn money until this gets cleared up. Any help would be very much appreciated.

My System SpecsSystem Spec
12 Oct 2009   #17

Win7 Enterprise Trial (x64)

Well, unfortunately I disable UAC as about the first step after an install, so I'm not sure exactly where UAC will be interfering, but I can walk you through taking permissions manually for the reg branch you'll be modifying. It's really simple: you right-click on the key (the folder on the left pane containing the values on the right) and select Permissions, then click the Advanced button, go to the Ownership tab (I'm writing this from memory on an XP machine, so forgive me if my labels aren't accurate), and change the owner to your user account name. OK out of that, go back and grant full permissions to yourself, OK out of the window. You can then modify all the values; after you've done that close regedit, log off and log back in, all the changes shuld stick.

If that doesn't work, let me know, I'll hop on the Win7 machine and give precise instructions.
My System SpecsSystem Spec
12 Oct 2009   #18

Win7 Enterprise Trial (x64)

Oh yeah, one other update, for those who, like me, set almost everything to zero and also use the Mouse Gestures add-on in IE8 - there may be some compatibility issues here as IE8 accesses those keys and if you use rocker gestures the rightclick menu gets triggered on a rocker gesture, which is annoying. I solved this (stopgap) by uninstalling Win7's Tablet PC components (again, I don't use the handwriting input on that machine), and all seems to be well, but until I have the time to go through and determine precisely what each value translates to, this is a pretty rare issue for a major fix so I'm not going to worry much about it.
My System SpecsSystem Spec
13 Oct 2009   #19

windows 7

Thanks on the instructions for the permissions!

I went through and changed all the keys using the find and find next functions.

First I tried just the "Splash" and "UIFeedbackMode" keys. Setting all of those equal to 0, I rebooted, to no effect. The splash marks are still there.

Then I tried setting additional keys equal to 0. I haven't gotten through them all yet, but I still haven't managed to find the proper key. You sure it wasn't another key?
My System SpecsSystem Spec
29 Oct 2009   #20

Windows 7

  1. Open Local Group Policy Editor:Run... gpedit.msc
  2. Navigate to User Configuration - Administrative Templates - Windows Components - Tablet PC - Cursors
  3. Enable the Turn off pen feedback setting.
My System SpecsSystem Spec

 Wacom Tablet, ring round pen cursor

Thread Tools

Similar help and support threads
Thread Forum
Win7/Wacom tablet lost driver, cursor rings, slow pen action
Many people have problems with wacom tablets and Win 7, l had. (Win 7-64 bit/ Wacom Intous 3) (Problem 1) I've lost the driver after restart, (Problem 2) got really annoyed with the cursor rings (Problem 3) and experienced slow pen action. Working for severeral days with these issues,...
Wacom Tablet- Blinking Cursor Problem
I have a tablet which I love to use for Photoshop work.. It works great except that some one at Windows decided that it would be a good idea to have animated cursors. A ripple effect occurs everytime I click and animated circle show up everytime I right click or hold down the cursor. Working...
Hardware & Devices
wacom tablet not working =x
It works on my admin account, but not on this one...I'm guessing the driver can't start up on this standard account? Is there a way to change this?
Hardware & Devices
How to turn off tablet PC and click ring?
Hello, I've only recently bought a computer with Windows 7, so I'm new to it. I installed my Intuos4 graphics tablet on it, and whenever I use the pen (I often use it for navigating my computer as opposed to the mouse) a little handwriting box for writing notes pops up -- I think it's called the...
Hardware & Devices
Another Wacom tablet issue
or is it a Kaspersky issue? Sorry if this is in the wrong forum! My Wacom Intuos 2 tablet works fine, unless I try and use it with Kaspersky antivirus. The pen will not control the cursor within a Kaspersky box! I can move the cursor anywhere I like on the screen but as soon as it gets to the...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 19:23.
Twitter Facebook