Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: SanDisk Cruzer Flash Drive-AUTOPLAY problem

05 Oct 2010   #21
Hopalong X

Windows7 Pro 64bit SP-1; Windows XP Pro 32bit

Put the top one back to disabled. Leave others at default. Otherwise Autoplay may not work for your CD player.

I noticed my light didn't go off either just now. As long as it tells you it is safe.
My Memorex light goes off so I thought they all did.

Sorry it isn't working right on the Autorun.
I'm out of options.
Maybe someone else will come up with something.
Check back later on this thread.


My System SpecsSystem Spec
05 Oct 2010   #22

Microsoft Community Contributor Award Recipient

Windows 7 Ult x64 - SP1/ Windows 8 Pro x64

Looks like it might be a PlugnPlay issue, since it thinks it's a CD player might be a IDE/AHCI issue.

What is the BIOS setting for SATA?

It seems to be acting like an external HDD, if in IDE mode will only see the memory stick when it's plugged in before booting. It won't like it if you disconnect it while the computer is still running. You might get errors if you unplug it without shutting down the computer.

If your SATA setting is IDE and you want to change it to AHCI this tutorial will show you how to do this without re-installing your OS.

Another way to get around this is the handy HotSwap app.
You can try the Hot Swap app, it might work for you in IDE mode, haven't tried it myself as I found it after I changed to AHCI mode.

Hot Swap

It does the same thing as you can remove device from Device Manager but it provides much friendly user interface as you remove the removable device from the "Safely Remove Hardware" icon in the notification area.
I've used this for a couple of years, it will stay in the same place as the MS 'Safely Remove Hardware' does, actually looks and acts just like it but, will let you select any device in your system including your main HDD.

It will not load/install on your computer as a running program, you can open it when needed or set it as a startup task, then it will run after login.

A BIOS update on my laptop enabled the built in plugnPlay to work correctly, so didn't need HotSwap on it any more but, still use it on two desktops.

Let us know if this helps.
My System SpecsSystem Spec
06 Oct 2010   #23

98SE/XP/windows7 ultimate 32bit

hi dave,
i use AHCI
the utility is nice thanks, but does not help me.

1-did you update or something on your sandisk drivers /U3 ?
2-under HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
*i have default value for NoDriveTypeAutoRun is 0x91 (145) is it the same for you?
*DO you have another key there "NoDriveAutoRun "(i do not have just read a tweak about it)

I tried to reinstall sandisk drivers but no good.
cant get autoplay menu for the sandisk...
My System SpecsSystem Spec

06 Oct 2010   #24

98SE/XP/windows7 ultimate 32bit

Problem solved
after some reading in sandisk forums i found out some gadgets can cause this problem.the fault gadget belongs
to cyberlink power2go express. after remove it from MSCONFIG- sandisk autoplay menus are open!
thank all the friends trying to help me through (Dear Mike)

Attached Images
SanDisk Cruzer Flash Drive-AUTOPLAY problem-untitled.jpg 
My System SpecsSystem Spec
06 Oct 2010   #25

Microsoft Windows 7 Home Premium 64-bit 7600

thats an interesting soloution, thanks for posting results i have power2go on this laptop,so any issues i shall know why .although i have a sandisk cruzer slice flash and it shows autoplay fine.
My System SpecsSystem Spec
06 Oct 2010   #26

98SE/XP/windows7 ultimate 32bit

that's how the fault gadget looks like on the desktop

Attached Images
SanDisk Cruzer Flash Drive-AUTOPLAY problem-untitled.jpg 
My System SpecsSystem Spec
06 Oct 2010   #27
Hopalong X

Windows7 Pro 64bit SP-1; Windows XP Pro 32bit

Your welcome.
Though I didn't get it working.

You now know where all the Windows Autorun buttons, check boxes and default settings are!!!

Take care.
My System SpecsSystem Spec

 SanDisk Cruzer Flash Drive-AUTOPLAY problem

Thread Tools

Similar help and support threads
Thread Forum
Error with nearly-new 32Gb Sandisk Cruzer Glide
It now reports itself as a Sandisk Firebird with 64Mb total and it is reported by Win7 Home Premium x64 as of type RAW, when I know it should be either VFAT or FAT32. Have scanned drive with Easeus Partition Manager (nada, except same report) and Minitool Partition Wizard Home Edition (also, same...
sandisk cruzer edge flash drive 32GB will not recognise to read files
Hi, I am an oap with little pc knowledge. My friend has kindly downloaded some small video clips from my phone onto a SanDisk Cruzer Edge 32GB memory stick. He put a note with it to open with quicktime player. When I load the stick it goes straight to windows options for opening which of course...
Hardware & Devices
16 GB SanDisk Cruzer suddenly becomes write protected!
Got a 16 GB SanDisk Cruizer flash drive and it did well - until I swapped my hard drive for an SSD. Since the SSD conversion, the ReadyBoost file on it does not work - Windows won't use it because I have an SSD - that' fine. The real problem is the SanDisk became write protected - can't format,...
Hardware & Devices
Sandisk U3 Cruzer Micro won't load U3 software
I've updated my U3 drive to the newest version. When I plug in it occupies J: (the "CD Drive") and K:. When I try to run the U3 launcher it tells me Windows has mounted it on a drive that was already occupied and that I can't start it. Disk management won't let me change the drive letter of...
Hardware & Devices
Backing up to a sandisk 8 gb cruzer
I have been writing before in a different forum that had kind of died out. I just bought a Cruzer Blade USB flash drive, 8 gb, to back up my computer - windows 7. It still doesn't like it. I cannot get an external hard drive and this wasn't that expensive. It says to please insert a d/dvd/or...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:29.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App