Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Vizo XWR100 and other routers have USELESS USB!

08 Oct 2010   #1

Windows 7 64-bit Home Premium
Vizo XWR100 and other routers have USELESS USB!

Below outlines the problem that I am having, and it seems to be universal - all these new wireless routers, like mine - Vizio XWR100 "CLAIM" this wonderful USB port allows shared use - BUT there is one MAJOR catch - the manufacturers of the routers have NOT worked out a way to WRITE TO THE HARD DRIVE THAT YOU CONNECT TO THE USB PORT - THUS MAKING THE USB PORT VIRTUALLY USELESS! That's right, you can only READ from the USB HD that is connected! Is that crap or what???

If we have to PRE-COPY (copy ahead-of-time) any files to the USB *before* we can share them, THAT IS CRAP! What that means is we have to DISCONNECT the USB HD from the Wireless router, AND THEN copy movies or pictures onto it; and THEN *RE-CONNECT* the USB HD to the router - before being able to use/see anything - bottom line, these ports are virtually useless, because they are

If I cannot WRITE to the USB HD, from EVERY COMPUTER IN MY HOUSE, over the wireless network, then it is USELESS! *NO* it is NOT a firewall issue! It is "access denied" when trying to 'write' to the USB drive, even when I took the USB drive to the PC and formatted it NTFS and set EVERYONE FULL + ANONYMOUS FULL + NETWORK FULL + NETWORK DEVICE FULL access ! USELESS!

I have been through EVERY SINGLE ROUTER SETTING [*AND* have been through their platry help PDF document], and the only setting (via the GUI - there's no access to full root-level command-line) - the only setting is to "browse" (READ) the shared folder, which shows up as a shared named: \\\Default0 (aka \\vizio.home\Default0) - When you look at permissions, it shows (vizio\root) as owning it, so obviously the Vizio XWR100 is Linux-based, and is possibly sharing the USB drive via Samba-based sharing and/or NFS-based sharing, but in READ-ONLY MODE! What a CROCK! And there is ZERO information in their documentation about any method for WRITING to the drive - they just intentionally leave that out, because they KNOW IT DOES *NOT* WORK!

Oh, and YES, I tried EXPLICIT CREDENTIALS - I changed the password for the router, and then Mapped - like net use * \\\Default0 /user:vizio pwd
(where pwd is the password I set) - and it MADE NO DIFFERENCE!

Now, I am guessing their is a "maintenance/admin" mode of some kind, where you can use some specific port and login, via putty or some method, to a Linux shell and then change this as needed; or alternatively, they could provide a firmware upgrade that fixes this - but I doubt that will happen, unless we bombard them!

Now, same question goes for the Cisco/Linksys E3000 router - it has a USB, does anybody know if it allows WRITING to the USB HD??? Again, this is a HUGE OVERSIGHT - A HUGE ISSUE THAT MAKES THE USB PORT VIRTUALLY USELESS ON THE VIZIO XWR100!!! +other routers - see below (User in Vista forum same issue):

I am having a problem accessing folders that I made on a newly
purchased external HD set up on my home network via a wireless router.
I set up the HD (a 500GB drive in an USB enclosure) and formatted it
using the Computer Management tools in Vista. It has 1 primary, active
NTFS partition. With the drive plugged directly into my PC by USB, I
was able to format the drive and create two folders at it's root;
'Archive' and 'Restore'. I want to use these folders to hold copies of
my files and back ups of my laptops drive using the Vista Back Up and
Restore tools. I have the HD connected by USB into my ASUS WL-500W
wireless router. I can see the drive (named 'Portable') and the
folders in the Network view of Windows Explorer. However, when I try
and create or copy folders on the HD over the network I get errors
such as "you need permission to perform this action". When I check the
Properties/Security tab of the folders the 'Everyone' user doesn't
have the proper permissions, so I assume this is the problem, but I'm
not sure how to set this. Everything works fine when connected
directly to my PC by USB, but not over the network and I would like to
be able to leave the drive connected to the network so that it's
easier to schedule back ups and gather/deposit/share files with other
users on the network.

[SO, THIS GUY ABOVE (from Vista Forum) HAS THE SAME ISSUE back in 2008!]

Thanks for any advice, hacks, help, etc. I do NOT want to use modified firmware on this XWR100 at this time, but I don't mind if someone can find a HACK to allow this USB DEVICE SHARING to be fixed, and made USEFUL!

My System SpecsSystem Spec
09 Jul 2012   #2

Windows 7 64 Home Premium

In order to have a USB drive attached to a Vizio router to be read/write it has to be formatted FAT or FAT32. NTFS drives will be set to read-only
My System SpecsSystem Spec

 Vizo XWR100 and other routers have USELESS USB!

Thread Tools

Similar help and support threads
Thread Forum
The Useless Web
The Useless Web I liked and Staggering Beauty (move your cursor around. Now move it real fast).
Chillout Room
42" Vizo TV, My computer and LG DVD Player with Nero Mediahome4
I have the above equipment to stream video from my computer to the TV. The DVD Player output is to the TV via a hdmi cable to an alternate input. The DVD Player receives the video wirelessly from the computer. I am having trouble getting the video from the computer to the TV. Information on this...
Music, Pictures & Video
Is there any way to get rid of this useless bar?
Outlined in red:
Is it me or are all HP printers useless?
Have any of you bought a new HP printer in the last few years. Their continuously difficult to connect to the computer. They take forever to warm up and they always have problems not to mention drinks ink like its water...It's me isn't it! Is it?
Chillout Room
Useless files?
Hi everyone! I am currently using Windows 7 Build 7264 (x86). My C:\ partition has a total of 29 GB, and my D:\ partition has a total of 157 GB. My C:\ parition (Windows, Program Files... system things) is only 11.8 GB free at the moment, so, in order to upgrade to 7600, I need 16 GB. I have...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:23.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App