Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sound stopped working

19 Oct 2010   #11
SailingNut

Windows 7 Ultimate x64
 
 

HannibalUK,

I did look at the link you gave me but could not find any information that appeared to be relevant. It was talking about Windows 98 SE.

Did I completely miss something?


My System SpecsSystem Spec
.
19 Oct 2010   #12
HannibalUK

WINDOWS 7 ULTIMATE X64
 
 

Quote   Quote: Originally Posted by SailingNut View Post
Quote   Quote: Originally Posted by HannibalUK View Post
Quote   Quote: Originally Posted by SailingNut View Post
The problem is that it's NOT an NVIDIA chipset.

It's a realtek chip for audio. Somehow Windows thought it was an NVIDIA chip.

Realtek

Thanks for the link! I really should have tried that first, but I just couldn't get past the fact that it stopped working throught a reboot and I hadn't changed anything related to sound.

Unfortunately, that did not solve my problem. BUT, it did get me to look into it a bit deeper and the "problem" with the device is "Windows cannot verify the digital signature for the drivers ... Code 52".

I also see another driver with the same problem that I think should definately NOT have this problem. Under "System Devices" the "Plug and Play Software Device Enumerator" driver also has the "code 52" error.

Any ideas what might have gone wrong to cause this and how I might fix it?

A to Z of error codes;

System Error Codes (0-499) (Windows)
My System SpecsSystem Spec
19 Oct 2010   #13
karlsnooks

MS Windows 7 Ultimate SP1 64-bit
 
 

Suggestions:
1. Do you have a system restore point to a point before this problem appeared?

System Restore - How to use

2. Since the problem is unusual, try system file checker.
Oh yes, please read this tutorial from start to finish.
System File Checker - SFC /SCANNOW Command

3. Go into device manager, disable and Delete the driver. Shutdown. Power On.

4. Let's let Microsoft try:
MS Fix it Center Online
MS - Windows 7 Solution Center
No sound in Windows

5. Did you maybe, very recently, install some new software?
My System SpecsSystem Spec
.

19 Oct 2010   #14
SailingNut

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by karlsnooks View Post

Suggestions:
1. Do you have a system restore point to a point before this problem appeared?

System Restore - How to use

2. Since the problem is unusual, try system file checker.
Oh yes, please read this tutorial from start to finish.
System File Checker - SFC /SCANNOW Command

3. Go into device manager, disable and Delete the driver. Shutdown. Power On.

4. Let's let Microsoft try:
MS Fix it Center Online
MS - Windows 7 Solution Center
No sound in Windows

5. Did you maybe, very recently, install some new software?
Thanks, I tried all of the methods you recommended (except the restore point because I don't have any recent ones. I know BAD computer owner!) and unfortunately none of them worked.

The root of the problem seems to be that Windows cannot verify the digital signature of the driver files. When I ran the Fix it troubleshooter for audio, it didn't detect that I did not have sound drivers installed. It seemed to think that everything should be working just fine. So, it seems that the signature problem is preventing Windows from loading the driver.

The only thing I did recently was to install 2 Windows updates. Neither of the updates required a reboot and the sound worked just fine after installing the updates. I just decided to reboot afterward to "be safe." That didn't go so well!
My System SpecsSystem Spec
19 Oct 2010   #15
karlsnooks

MS Windows 7 Ultimate SP1 64-bit
 
 

Next step:
Repair Install
My System SpecsSystem Spec
20 Oct 2010   #16
SailingNut

Windows 7 Ultimate x64
 
 

Thanks to all for the input!

The repair install seems to have worked and resolved a few other issues I was having.
My System SpecsSystem Spec
20 Oct 2010   #17
karlsnooks

MS Windows 7 Ultimate SP1 64-bit
 
 

Great! Glad to hear that all is well and that we could be of assistance.
My System SpecsSystem Spec
20 Oct 2010   #18
LiquidSnak

W7 Professional x64
 
 

I had this issue come up when I installed my GeForce drivers. It gave the option to install "Nvidia High Definition Audio" Since the card has HDMI, I figured it was for that, but it replaced my realtek drivers with Nvidia ones.
My System SpecsSystem Spec
Reply

 Sound stopped working




Thread Tools




Similar help and support threads
Thread Forum
Sound stopped working
Sound stopped working..tried to do system recovery still the same..Nothing in device manager 'Sound video and game controllers is marked with x.IDk what is the problem help pelase:cry::cry::cry::cry:
Sound & Audio
Sound suddenly stopped working
I've had WMC up and running for about a year now, no problems. Tonight we decided to watch a movie that I have as an *.mkv file - we do this all the time, at least once a week if not more. I shut down WMC and played the movie in VLC Media player. When I went to start WMC again, the sound was gone. ...
Media Center
Sound stopped working ?!
Hi, my Win7 64 was working fine but out of nothing my sound stopped working. When I plug in my headphones, the Asus software says "back pannel jack plugged in" as it used to say before but I just have no sound. The Windows volume control is moving and it's not muted. I tried the troubleshooting...
Sound & Audio
Sound Suddenly Stopped Working
Onboard Realtek HD audio on the Asus P6T board. I noticed last night when I tried to play something the sound wasn't working anymore. It hadn't been restarted in a week, so I'm not sure what could have caused that. I have ensured playback devices are enabled and I have set both the 5.1...
Sound & Audio
The sound has mysteriously stopped working on my pc
Windows 7 Professional x32 Soundmax integrated HD audio card (Supremefx II) (pci) Asus Striker II NSE The other day, the sound stoped working on my computer. All I did was hit the mute button on my keyboard a few time and for some reason (possibly coincidentaly) the sound came back. Today I...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:21.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App