Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB 3.0 Ports Not Working

29 May 2012   #31
lordvader

Windows 7 Ultimate
 
 

Quote   Quote: Originally Posted by Commodore Pet View Post
Here is the link to get the latest driver for your machine. This assumes you are using Windows 7 64 bit version.

ASUS - Notebooks- ASUS G53Jw
thank you sooo much
Rep +


My System SpecsSystem Spec
.
18 Jul 2012   #32
Simpuhl

Windows 7 64bit
 
 
:(

So I don't know what exactly happened... but out of nowhere all 4 of my usb 3.0 devices stopped working. I think it might have to do with some driver updater tool I downloaded... it updated a couple drivers but not sure if that is what caused it. I did uninstall it though. I also scanned for spyware and viruses and nada.

If I plug in a usb 2.0 device they are detected, but no USB devices are.

This is the motherboard I have

ASUS - Motherboards- ASUS P6X58D Premium


I have uninstalled all the drivers and reinstalled them from my disk and the site... and nothing helps.
My System SpecsSystem Spec
19 Jul 2012   #33
Commodore Pet

Windows 7 Home Premium 64 bit SP1
 
 

Quote   Quote: Originally Posted by Simpuhl View Post
So I don't know what exactly happened... but out of nowhere all 4 of my usb 3.0 devices stopped working. I think it might have to do with some driver updater tool I downloaded... it updated a couple drivers but not sure if that is what caused it. I did uninstall it though. I also scanned for spyware and viruses and nada.

If I plug in a usb 2.0 device they are detected, but no USB devices are.

This is the motherboard I have

ASUS - Motherboards- ASUS P6X58D Premium


I have uninstalled all the drivers and reinstalled them from my disk and the site... and nothing helps.
The drivers on the link you gave are quite old and had problems. Make sure you have uninstalled your USB 3.0 drivers then try this link to get new ones. This is where I get my USB 3.0 drivers from. Let me know how you make out.


RENESAS/NEC Drivers & Firmwares
My System SpecsSystem Spec
.

25 Jul 2012   #34
Simpuhl

Windows 7 64bit
 
 

What I did was install the older drives but when it was checking for updated ones at windows.com I clicked skip and then it worked.
My System SpecsSystem Spec
11 Aug 2013   #35
luiscbc

Windows 7 Ultimate x64
 
 
I'm Having this Issue

Hello Everybody,
This happened suddenly, my USB 3.0 ports were working fine, I Use an external USB 3.0 Seagate Drive and I had no Issues before.

Suddenly it is just not working, I connect my drive to my usb 3.0 ports and nothing happens, the small led on the drive turns on, I connect an USB Mouse to the usb 3.0 ports and it doesnt works, but the laser flickers and it doesn't works as well.

I can use all of my other usb 2.0 ports, with my external drive and my mouse but just can't use my usb 3.0 ports now on.

I've reinstalled the drivers a couple of times, the ones that I've found on Gigabyte site and the ones that I found at Etron site as well, nothing works for me.

I've entered on my bios and checked if usb 3.0 was on and it is.

Thank you for your help.
My System SpecsSystem Spec
06 Apr 2016   #36
bnevins

windows 7 professional, 32 bit
 
 
USB ports not working in MSI MS7817

I just bought a custom build win 7 pro, 32 bit, based on MSI motherboard MS-7817 (H81M-E34). At first only the two usb ports near the ethernet jack worked. I used the MSI driver download utility, rebooted, windows update, and that got the two front panel USB ports working.

However, the 4 usb3.0 ports on the back, near the top, were still not working. I went to the MSI support site for this motherboard,
downloaded the Via usb 3.0 driver.exe, that got the remaining usb ports working.


Attached Files
File Type: docx device_manager.docx (51.7 KB, 1 views)
My System SpecsSystem Spec
Reply

 USB 3.0 Ports Not Working




Thread Tools




Similar help and support threads
Thread Forum
USB Ports Not Working
Last night I was transferring some files from my laptop to my external hard drive and everything was working fine but then a couple hours later, I went to plug in some rechargeable USB batteries that I have and noticed that they weren't lighting up. I then tried plugging in several of my other USB...
Hardware & Devices
Front USB ports not working, but rear USB ports work…
This is a brand new custom built PC for web browsing for a motel lobby. Win7 Home Premium AMD A4-3300 Llano MSI A55M-P33 FM1 Rosewill FBM-02 MicroATX Mini Tower Running latest BIOS and latest drivers downloaded directly from manufacturer's website. I tried switching between all 3...
Hardware & Devices
Two USB ports not working
Hello! I have a bit of a problem. I have an Acer Aspire 5733Z-4633 and upon receiving it, I reinstalled Windows 7 to get rid of all the bloatware and useless things that were taking up space on the hard drive. Upon doing this, two out of three of my USB ports stopped working for some reason. When I...
Hardware & Devices
2 usb ports are not working??
:mad: 2 OF MY 3 USB PORTS ARE NOT WORKING I JUST INSTALLED THE DRIVERS MAYBE I INSTALLED THE WRONG ONES HELP!!!! SPECS: PAVILLION DM43099SE ENTERTAINMENT PC :cool:
Drivers
Not all USB ports are working
Hello guys, I have just got my motherboard replaced by a PC World Techguy and I got it back last week. Because the BIOS on the new motherboard has not be altered to the same has the old one. The front 2 usb ports are not being recongized, but the one that my usb hub is plugged into is working...
Hardware & Devices
none of my USB ports are working
none of my USB ports are working, can some one please help me????????????
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:05.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App