Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Sandisk U3 Cruzer Micro won't load U3 software

08 Jun 2009   #11

Windows 7 Home Premium x64

Running 64-bit Win 7, 32-bit XP Pro.

I successfully updated the drive, THAT'S NOT THE ISSUE. Win 7 will NOT allow me to run the U3 launchpad. It tells me that a drive letter was already assigned. I'll try to take a screenshot and post it for you, when I get home from work...

For the record, this appears to be a 64-bit compatibility issue. I have a W7 RC 32-bit machine at work, the U3 drive works fine on that machine.

My System SpecsSystem Spec
08 Jun 2009   #12
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64

I was asking for that reason. Some of this stuff either will not run period or you need to run in the XP SP2 or Vista compatibility mode as well as the "run as administrator" to get it to go on. In the 7 right click menu you now see the troublecompatibility tool there being a new support tool.
My System SpecsSystem Spec
11 Jun 2011   #13

Windows 7 Ultimate 64bit
A possible fix for Windows has allocated a drive letter to the U3 dri

I downloaded and ran as administrator a free utility call "usbdeview". It allow me to see all of my usb device. I used it to uninstall all devices that were not currently connected to my computer. I also uninstall some of the generic usb hubs it was showing. After rescanning for hardware change and after unplugging and replugging my usb keyboard back in I was able to get the U3 launcher on my cruzer to work correctly.
Now I don't know if that will work for everyone but it did for me.
My System SpecsSystem Spec

20 Jun 2011   #14

Windows 7 Ultimate 64bit
2nd fix

Ok so if the first fix I tried does not work for you, try the following.
I copied the file into another directory on the computer and ran the LaunchU3.exe from there. Initially I received the same error about Windows has allocated a drive letter to the U3 drive that is already taken by another drive on your machine or there are no more drive letters available on this machine. Try disconnecting any network drives that you have connected to your computer and restart U3 by double-clicking LaunchU3.exe or the U3 System CD-ROM icon. Once the U3 Launchpad is running, you can reconnect the network drives. Even though the message came up the u3 launcher did start. After ejecting the U3 and rebooting the computer I have been able to launch the U3 software every time without the error showing up.

As far as using the compatibility mode, I am NOT. It has continued to work even when the system has been shut down and rebooted with the key still attached.
My System SpecsSystem Spec

 Sandisk U3 Cruzer Micro won't load U3 software

Thread Tools

Similar help and support threads
Thread Forum
Sandisk cruzer blade 64GB not detected in my computer
Hello everyone! :) I just bought a new sandisk cruzer blade 64bit, it worked fine and the win 7 detected it, and I wanted to format it to NTFS, but I couldn't, so I formated it into Fat32, because it was on exFat, and then I converted from Fat32 to NTFS by using "Mini partition wizard" .. and I...
Hardware & Devices
Error with nearly-new 32Gb Sandisk Cruzer Glide
It now reports itself as a Sandisk Firebird with 64Mb total and it is reported by Win7 Home Premium x64 as of type RAW, when I know it should be either VFAT or FAT32. Have scanned drive with Easeus Partition Manager (nada, except same report) and Minitool Partition Wizard Home Edition (also, same...
16 GB SanDisk Cruzer suddenly becomes write protected!
Got a 16 GB SanDisk Cruizer flash drive and it did well - until I swapped my hard drive for an SSD. Since the SSD conversion, the ReadyBoost file on it does not work - Windows won't use it because I have an SSD - that' fine. The real problem is the SanDisk became write protected - can't format,...
Hardware & Devices
Backing up to a sandisk 8 gb cruzer
I have been writing before in a different forum that had kind of died out. I just bought a Cruzer Blade USB flash drive, 8 gb, to back up my computer - windows 7. It still doesn't like it. I cannot get an external hard drive and this wasn't that expensive. It says to please insert a d/dvd/or...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:01.
Twitter Facebook Google+