Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: bootmgr is missing...

08 Jun 2009   #1

bootmgr is missing...

About 2 weeks ago, I had this problem upon restarting my gateway laptop, saying "BOOTMGR is ctrl alt dlt to restart". So when I do ctrl alt dlt, it just keeps saying the same thing over and over again.

I have removed things plugged into my laptop and trying it again, such as mouses etc, and I still get the same response.

Today I went on a search engine and found that this was a common problem. I found many solutions to this problem, but non of them worked for me.

I tried Startup Repair and it says "Startup Repair cannot repair this computer automatically"

I have tried System Restore and it says "to perform an offline System Restore, you must specify which Windows installation you would like to restore.
For examle, if the installation located in "C:\Windows" should be restored, enter the following command:
rstrui.exe /OFFLINE:C:\Windows"
I tried that and nothing happened.

I have tried Windows Complete PC Restore and it says:

"No valid backup locations could be found.
Windows cannot find a backup on the hard disks or DVDs on this computer. Attach the correct hard disk or insert the last backup DVD and then start the restore process again.

I have tried Windows Memory Diagnostic Tool and when I do that it just does something then restarts, then takes me back to the "bootmgr is missing.." screen.

I have tried putting in my recovery cd and reinstalling vista and it didn't work.

If you need anything else to help me solve this let me know.

Please help me solve this as it is very frustrating and I do not want to buy a new laptop.

right now I am at a point where all it says is

(Windows failed to start. a recent hardware or software change might be the cause. to fix the problem:

1. insert windows installation disc and restart computer
2. choose language settings and click next
3. click repair your computer

if you do not have this disc, constant your system administator or computer manufacturer for assistance

file: \boot\bcd

status: 0xc00000098

info: the windows boot config. data file does not constain a valid os entry.)

so the bootmgr is missing part dosent show up anymore

darknovagundam tried to help but couldn't solve my problem

i have tried just about every possible cmd in command prompt too

My System SpecsSystem Spec
08 Jun 2009   #2
Dark Nova Gamer

Windows 7 Ultimate, OS X 10.7, Ubuntu 11.04

Can only imagine who this is.
My System SpecsSystem Spec
08 Jun 2009   #3

7600.20510 x86

pjvex386, Dark? hrrrmmmm lol not this again
My System SpecsSystem Spec

08 Jun 2009   #4
Dark Nova Gamer

Windows 7 Ultimate, OS X 10.7, Ubuntu 11.04

Lol, Hola. I tried helping him with simple command prompts via Windows Vista Install DVD's Command Prompt such as;

Bootrec.exe /fixmbr
Bootrec.exe /fixboot
Bootrec.exe /scanos
Bootrec.exe /rebuildbcd
My System SpecsSystem Spec
08 Jun 2009   #5


someone helpppppp
My System SpecsSystem Spec
08 Jun 2009   #6
Dark Nova Gamer

Windows 7 Ultimate, OS X 10.7, Ubuntu 11.04

Be paitent, like I said to you earlier, someone will help. I always get my help here and rarely am let down.
My System SpecsSystem Spec
08 Jun 2009   #7
Dark Nova Gamer

Windows 7 Ultimate, OS X 10.7, Ubuntu 11.04


I found this post on another thread;

Quote   Quote: Originally Posted by raj1402 View Post
Try this method:

you can rebuild the BCD store by using the Bootrec.exe tool in the Windows Recovery Environment. To do this, follow these steps: - Get your Windows 7 installation DVD and pop it into your drive.
- Then restart your computer.
- Press a key when you are prompted.
- Select a language, a time, a currency, and a keyboard or another input method, and then click Next
- Click Repair your computer
- Click the operating system that you want to repair, and then click Next
- In the System Recovery Options dialog box, click Command Prompt
- Type bootrec /rebuildbcd and then press ENTER

• If Bootrec runs successfully, it will present you with the installation path of a Windows directory. To add the entry to the BCD store, type Yes . A confirmation message appears that indicates the entry was added successfully.

• If Bootrec cannot locate any missing Windows installations, you must remove the BCD store, and then you must re-create it. To do this, type the following commands in the order shown below: (Remember to press ENTER after each command)

bcdedit /export C:\BCD_Backup

ren c:\boot\bcd bcd.old

bootrec /rebuildbcd

- Restart the computer.

Try that! =)

I'm assuming it should work the same with a Vista Install DVD. =P
My System SpecsSystem Spec
08 Jun 2009   #8


didnt work
My System SpecsSystem Spec
08 Jun 2009   #9
Dark Nova Gamer

Windows 7 Ultimate, OS X 10.7, Ubuntu 11.04

well I'm going to sleep so goodnight.
My System SpecsSystem Spec
27 Sep 2009   #10


helpp, i just ran into the same problem as you. When i first installed 7, it was on my second HDD with XP on the first. When i finally made the switch to 7, i tried my hand at OSX, and accidentally overwrote my boot sector.

I've been scouring these forums, and it wasnt until just now that i figured it out.

FIRST, windows startup repair couldn't detect my installation. i used a Ubuntu 9.04 Live cd and i used the build in partition editor to change the flags on my 7 drive. there were no flags so i added the boot flag and restarted.

SECOND, i booted into the 7 install cd, and i hit repair, then went to command prompt
bootrec /FixMbr
bootrec /FixBoot
bootrec /ScanOs
bootrec /RebuildBcd

THIRD, still not working. I booted into the 7 cd again, and did the automated startup repair.

WORKING! finally.

Best of luck, hope this helps
My System SpecsSystem Spec

 bootmgr is missing...

Thread Tools

Similar help and support threads
Thread Forum
Bootmgr.exe missing... mpio.sys missing or corrupted. Unable to boot
I just got a computer for free, a Dell Studio 1555. When I got it, it would try to boot, then come to a screen that said that bootmgr.exe was missing. Sometimes I got a message that said something like mpio.sys was corrupted or missing. I have a Win 7 disk, so I put it in and tried to repair the...
General Discussion
missing of bootmgr
hello i upgraded windows 7 home to windows 7 ultimate and laptop restarted then i found error message "BOOTMGR is missing, Alt+Ctrl+Delete to restart" how i can solve this problem
Installation & Setup
bootmgr missing error, became bootmgr MISSING.
I compressed my entire C drive. When I rebooted I got the error "Bootmgr is compressed" I don't have a optical drive, so I made a bootable USB drive using YUMI 0.2.3 and added the windows 7 recovery ISO. The USB drive boots and I can enter the recovery console, etc. It couldn't auto-repair...
General Discussion
Running windows7 home and bought windows 7 professional disk and installed it and it said that the file windows/system32/winload.exe is either missing or corrupt. How do I fix?u
Installation & Setup
bootmgr is missing.. tried everything..
hi guys. first of all. im beginner who trying to learn about computer. my son(at korea now) build a computer about 1 month ago. everything was so fine untill this msg came up "bootmgr is missing, press ctrl+alt+del" my son told me to put a win7 install cd to drive, and reboot...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:34.
Twitter Facebook