Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No audio in any browsers in Win7

24 Nov 2010   #11
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Uhg. iTunes. The attack of the blue meanies.

Most likely, hopefully, iTunes has commandeered all of your file associations. You can manually go through the list of associations and change them back to the desired programs, but it involves a lot of guesswork.

Hopefully a system restore to before iTunes was installed will work. In the future, when installing iTunes, RealPlayer, Quicktime, or any other "multimedia" application say NO to any window or checkbox that asks to change associations.

If you are not fortunate, you may need to go deeper. Take a look at these links, if you have not seen them already, and see if anything mentioned there will work for you:

No sound from web browser [Solved]
No Sound on internet [Solved]

The only caveat being that these are solutions for Vista. They should still apply to W7, but YMMV.


My System SpecsSystem Spec
.
24 Nov 2010   #12
Hopalong X

Windows7 Pro 64bit SP-1; Windows XP Pro 32bit
 
 

Okay. People miss that a lot of times. I wanted to be sure.


TVeblen

No restore points old enough.
My System SpecsSystem Spec
24 Nov 2010   #13
lindar37

Windows 7 Home Premium, 64-bit
 
 

Quote   Quote: Originally Posted by TVeblen View Post
Uhg. iTunes. The attack of the blue meanies.

Most likely, hopefully, iTunes has commandeered all of your file associations. You can manually go through the list of associations and change them back to the desired programs, but it involves a lot of guesswork.

Hopefully a system restore to before iTunes was installed will work. In the future, when installing iTunes, RealPlayer, Quicktime, or any other "multimedia" application say NO to any window or checkbox that asks to change associations.

If you are not fortunate, you may need to go deeper. Take a look at these links, if you have not seen them already, and see if anything mentioned there will work for you:

No Sound on internet [Solved]

The only caveat being that these are solutions for Vista. They should still apply to W7, but YMMV.
This link is the one I want to try, however it says to paste it to notepad, save it as missing.reg and import. The problem is that a notepad doc is a txt fiile. Does anyone know how I can save it as a .reg file, so I can import it? No Sound on internet [Solved]
My System SpecsSystem Spec
.

24 Nov 2010   #14
Hopalong X

Windows7 Pro 64bit SP-1; Windows XP Pro 32bit
 
 

I'll find someone who does.

Hang in there for a couple.
Mike
My System SpecsSystem Spec
24 Nov 2010   #15
Kari

 

In Notepad's Save As dialog, choose Save As Type All Files. This way the txt-extension is left out and you can decide which extension to use.

No audio in any browsers in Win7-notepad_all_files.png


My System SpecsSystem Spec
24 Nov 2010   #16
lindar37

Windows 7 Home Premium, 64-bit
 
 

Tried it and it didn't work... grrr. I am not sure what to do now. That made perfect sense. I had trouble doing it, so a tech friend of mine used TeamViewer and did it. He ended up copying and pasting it into win/system32. Guess I'll keep looking....
My System SpecsSystem Spec
24 Nov 2010   #17
candela

Win7 Home Premium x64
 
 

Quote   Quote: Originally Posted by lindar37 View Post
Tried it and it didn't work... grrr. I am not sure what to do now. That made perfect sense. I had trouble doing it, so a tech friend of mine used TeamViewer and did it. He ended up copying and pasting it into win/system32. Guess I'll keep looking....
Hello,

I have saved it in a .reg file. Please try it and report back. It should work though.


Attached Files
File Type: reg missing.reg (1.7 KB, 51 views)
My System SpecsSystem Spec
24 Nov 2010   #18
lindar37

Windows 7 Home Premium, 64-bit
 
 

Good news bad news. The file worked perfectly and was applied, however, the problem still exists. I checked the mixer and still no browsers show, only the speaker (device) and the system sounds (application). This is very frustrating! Thanks so much for the file though, I'm glad to see it could work.
My System SpecsSystem Spec
25 Nov 2010   #19
lindar37

Windows 7 Home Premium, 64-bit
 
 



Attached Thumbnails
No audio in any browsers in Win7-fixit-audio-1.jpg   No audio in any browsers in Win7-fixit-2-audio.jpg  
My System SpecsSystem Spec
25 Nov 2010   #20
lindar37

Windows 7 Home Premium, 64-bit
 
 

Ok, I've been doing some research on my own. I'm not very savvy but here goes:

1) I went to MS Fixit and ran the program (Microsoft Fix it Solution Center: troubleshooting software issues) and got the following error report:
See jpgs

2) I looked up the errors and found "Wiindows Audio Endpoint Builder aren't running." I edited the registry per a forum suggestion: Windows Audio Endpoint Builder error

Quote:
I had a similar issue where all of a sudden my audio stopped working and the Windows Audio service wouldn't run. Couldn't find anythinig on google about how to fix it but after a few hours with a microsoft support representative he fixed it.

Try going into regedit, HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/Audiosrv
and in the DependOnService remove all entries except RpcSs and then restart your computer
Seems a little bit like a cheat to me heheh but it fixed my sound so it's worth a shot if you can't get yours to work.. if it doesn't fix your problem just add the other 2 dependencies back in or something.. might not be a bad idea to back up your registry before you make any changes.. can't hurt
I checked to see if everything was ok and no audio device is showing as installed, but the Device Manager showed one installed, so i thought I'd see if the driver was need. According to specs, I needed the Realtek updated one, so I installed it. I now have an operating Sound Manager, BUT it's not seeing the device plugged in.

I click on the sound icon and playback and it shows no audio devices. How to I get that to show up? I have unplugged and replugged, rebooted,... you name it. I think i've come really far and so close to the finish. Does anyone know how to show me the rest please? I'm really hoping that something here makes some kind of sense.


Attached Thumbnails
No audio in any browsers in Win7-fixit-audio-1.jpg   No audio in any browsers in Win7-fixit-2-audio.jpg  
My System SpecsSystem Spec
Reply

 No audio in any browsers in Win7




Thread Tools




Similar help and support threads
Thread Forum
Eliminate all Browsers that are 'default browsers'
I do not like having any browser as my default browser. I use Firefox, Opera, and Chrome and sometimes have 2 browsers loaded concomitantly. I mistakenly made Chrome my default browser, how do I reverse this process. I removed Chrome via the control panel but when I reinstalled it it was still set...
Browsers & Mail
restart problem BSOD glitchy audio win7 ultimate w/ m audio 1010lt sou
m audio 1010lt sound card not sure why..usually when I shut down it restarts automatically..recently i was watching a movie and it restarted out of no where..any help appreciated.... windows ultimate 7 amd 6000 3.0 ghz processor 4 gb ram I did do some searching i do have m audio 1010lt and...
BSOD Help and Support
Browsers stop working after win7 restart
This is a really strange problem. My browsers will not connect but skype and aim work fine. This seems to happen on system startup and if the system goes into idle mode. Basically after shutdown, reset or the system goes into idle mode. I have to disable my Local connection then repair it...
Browsers & Mail
Win7 Audio Dampening
I have not been able to solve this issue. It works fine in XP and it seems to be across all hardware. While listening in MP3's in WMP or any other player, if I go and play a game (CSS) while firing in the game, there is a small split second where the in game sound dampens the MP3's. I...
Sound & Audio
Win7 browsers freeze
My browser experience these days is somewhat unnerving. When I start my PC and start browsing with IE8, it freezes and shuts down. Sometimes I get a message that reads more or less like: browser stopped working and shuts down. This, however, is not exclusive to IE, it also happens with Firefox and...
Browsers & Mail
Audio problems in web browsers
Does anyone else have distorted audio when in a web browser? For example, my systems sounds and mp3s work perfectly BUT once i get on Mozilla and try to view a video such as on youtube or a link on facebook the sound becomes distorted. some of the problems include the music may be really loud and...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:25.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App