Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Getting Code 43 but all Device's are working

06 Dec 2010   #1
Raner

windows 7 professional x 64
 
 
Getting Code 43 but all Device's are working

Hi
I am trying to figure out what I have to do to repair (code 43) , Every divice that is hooked up to a USB port is working perfect, but when I go to windows 7 Printer and devices I have this message on one device Port#0003Hub_#0006 Windows has stopped this Device because it has reported porblems, Code 43. What is getting me is that all the devices are that are attached to usb ports are working and showing up on the upper section of same screen, so is there a way to trace what device windows is seeing but that is not installed. This a new built PC,ASRock 890 Fx Deluxe 4 motherboard,AMD 6 core black Edition pcu, 8 gigs of ram,Two 2900 pros Crossfired, Windows 7 64 Bit. Thanks Raner.


My System SpecsSystem Spec
.
06 Dec 2010   #2
Hopalong X

Windows7 Pro 64bit SP-1; Windows XP Pro 32bit
 
 

Are you trying to hook up a printer?

If so what brand and model number.

Mike
My System SpecsSystem Spec
06 Dec 2010   #3
Raner

windows 7 professional x 64
 
 

hey Hopalong X (Mike)
I have and HP printer hooked up and its working fine,It shows up in the devices that are hooked up to USB ports, I am at work and can't get the printer model at this time. Thanks Raner
My System SpecsSystem Spec
.

06 Dec 2010   #4
Hopalong X

Windows7 Pro 64bit SP-1; Windows XP Pro 32bit
 
 

Well if it is working it probably isn't the problem. Maybe open the page showing this error when your home and use the Snip tool and post a picture later.

Might give some additional clues to work from.
Mike
My System SpecsSystem Spec
06 Dec 2010   #5
Raner

windows 7 professional x 64
 
 

Will do Mike when I get home thanks for the comeback. Raner
My System SpecsSystem Spec
07 Dec 2010   #6
Raner

windows 7 professional x 64
 
 

here is what I'm getting, can supply more info as needed thanks raner
Note: the items on the top section on first snapshot is everything that I have hocked up to USB Ports, the item on the lower section on first snapshot I have no Idea what it is.


Attached Thumbnails
Getting Code 43 but all Device's are working-usb-code-43-1.png  
Attached Images
Getting Code 43 but all Device's are working-usb-code-43-4.png Getting Code 43 but all Device's are working-usb-coed-43-2.png Getting Code 43 but all Device's are working-use-code-43-3.png 
My System SpecsSystem Spec
07 Dec 2010   #7
geeve420

Windows 8, Ubuntu 12.04 64bit, Pear Linux Triple Boot
 
 

Have you tried making sure you have the latest drivers for your MB? They offer one on the site here

http://http://www.asrock.com/mb/down...luxe4&o=Win764

For the USB ports. Might be a bit out of date if you just insatlled from the cd it came with
My System SpecsSystem Spec
07 Dec 2010   #8
Raner

windows 7 professional x 64
 
 

Hey Geeve I got a 890fx deluxe it the newest ASrock availible but I check if there is any new bios or USB drivers for it.
My System SpecsSystem Spec
07 Dec 2010   #9
LiquidSnak

W7 Professional x64
 
 

Be sure to check for drivers for the onboard utilities as well as BIOS
My System SpecsSystem Spec
Reply

 Getting Code 43 but all Device's are working




Thread Tools




Similar help and support threads
Thread Forum
PCI Input Device - Code 28 in Device Manager
I've just upgraded my 6 year old computer from Win XP to Win 7. In Device Manager, there is an item with a yellow caution under Other Devices called "PCI Input Device". The Device Properties indicates Code 28. I searched both the Internet and the computer but couldn't find a driver. I ran...
Drivers
USB device not recognized, code 43. All usual fix methods not working.
This just randomly happened while I was on the internet, but my USB mouse stopped working. I didn't think it was a big deal so I just unplugged the mouse, and plugged it back into a different port. I got a pop up that said "device not recognized". So, I just rebooted the computer, and tried to plug...
Drivers
Device Manager Code 19 Error for HP CDDVDW TS-H653T ATA Device
I am having an issue where my DVD/CD RW has a code 19 error in device manager. The drive still works as I used it to boot a Windows CD and run a startup repair to see if that found anything. I tried uninstalling the drive and then scanning and it failed to install the drive. I also tried...
Drivers
Unknown device in device manager (code: 28)
I got a new hard drive for my HP Pavilion DV6T-6000. Installed windows 7 ultimate and a bunch of drivers from HP's drivers section for my computer and I still have this unkown device. It wasn't there on my old drive so something isn't right here. Location: on Microsoft ACPI-Compliant System ...
Drivers
Built-In Webcam Not Working - "Unknown Device" USB Code 43
Hello, I have looked over many, many other forums and threads regarding this issue, but to no avail, have not been able to solve my problem. I'm starting to think that some hardware that communicates with my Webcam could be damaged - but I have not given up hope that this could be solved...
Hardware & Devices
How do I get Stereo mix working when usb device is default device?
Hi guys, so I did some tweaking around in Sounds and Realtek HD Audio Manager, and I finally got stereo mix working. There's only one catch. It only picks it up if my default device is Reaktek HD Speakers. I tried setting my USB headset as the default device, since I never use my monitor's built in...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:43.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App