Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Hard Drive Enclosure not being seen by 7

12 Dec 2010   #1

Windows 7 64
Hard Drive Enclosure not being seen by 7

Please help!

I recently upgraded my operating system to Windows 7 64 bit. I have an Intel MB with an E4500 core 2 dou processor running with 4 gigs ram.

I have an old ide enclose that all of the sudden wont be seen by the new operating system. I have changed the jumper on the hard drive in every combination possible. In the past, I have found that different computers can be sensitive to jumper positions wven if its not logical, its just the way it is.

Anyway, its a WD1600JB hard drive. When I plug it into the USB port on my box, it makes that quick 2 tone sound through the speakers, but then nothing happens. So when I manually check under devices, sometimes it tells me the device is working properly and shows up as a USB mass storage device, and sometimes it tell me the drivers could not be found.

In either case, when you look under computer, it NEVER shows up as an accessible hard drive like it should.

The hard drive is spinning for sure, and I know it was working recently, so I doubt that it is broken, its more that the new operating system doesnt like it, plus again, it sometimes does show as a mass storage device that is working properly under devices although its never accessible.

I am wondering if I should try getting a new enclosure.

Any help will be greatly appreciated!

My System SpecsSystem Spec
12 Dec 2010   #2

Win7 Enterprise, Win7 x86 (Ult 7600), Win7 x64 Ult 7600, TechNet RTM on AMD x64 (2.8Ghz)

Welcome to SevenForums Michael

Try this:

Start Computer Management Disk Management

If the Ext HD shows up, see if you can right click on it & asign it a drive Letter
My System SpecsSystem Spec
12 Dec 2010   #3

Windows 7 64

When I have the jumper set as a slave which is what I think that it should be, the enclosure/hard drive is seen by the Devices and Printers tab on Windows 7. When I right click on properties, it says the device is a USB device, (which is how I have it connected to the computer) and says its working properly.

It also gives me the prt #

Yet, when I go under "Computer" tab, it doesnt show up with my other drives the way my USB back up memory would.

All of my other back up devices work properly when I use them on this machine by using the USB port which is 2.0.

Maybe the enclosure is a 1.0 and not backward compatible since its old? That doesnt sound right since the computer does see something under the devices tab.
My System SpecsSystem Spec

12 Dec 2010   #4

Win7 Enterprise, Win7 x86 (Ult 7600), Win7 x64 Ult 7600, TechNet RTM on AMD x64 (2.8Ghz)

All the ext USB adapters & enclosures I have used on IDE HD's require the drive (or jumper) be set as Master not slave.

Attached Thumbnails
Hard Drive Enclosure not being seen by 7-disk_management_sub_menu.jpg  
My System SpecsSystem Spec
13 Dec 2010   #5

Windows 7 64

Thanks for trying to help me. The enclosure, drive, or computer is simply plagued!

When I switch the jumper to Master, I get a yelow triangle over it in the "Device and Printers" field. When I right click on it and do a properties, I get a non working code and bad or outdated driver. I try to "get a driver" from an update, and I get a message telling me I have the lasteset driver.

When I set the jumper to Slave, I only get this error on my pc. The USB Mass Storage device is not in error and a right click tell me the device is working properly. Of course, its never avaialbe in my computer along side the other drives as all of my other enclure device are normally found.

My computer does stay in error though. When I click on the PC icon in the device window, I get the device tree. I see a yellow triangle with error on it in the USB column. It states there is an PCI error. It tells me that the driver for the PCI is not installed and when I try to fix it, I get the message that it cant be fixed and that I should try alternative methods.

I dont know if this is a factor, but it might be a fat 32 formatted hard drive. It might not be formatted at all, or it could even be NTFS. I am not not sure.

All I know is that periodically with the drives I have laying around, some work just fine, and others like this one are nightmares for no apparent reason.

But I would like to thank you for your time wither way, and I will just have to take this to a computer store and try a machine there, or submit the drive to service.

My System SpecsSystem Spec
13 Dec 2010   #6

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64, Windows 10 Pro x64

Try removing the jumper altogether since WD drives use that setting for single drives.
My System SpecsSystem Spec
16 Dec 2010   #7

Windows 7 64

Hello and thank for the suggestion.

I tired that and while the drive was powered here were the results:

1. Under devices, the drive showed up as a USB mass stoarge device. A right click revealed it was working properly, and is considered a USB device in the hardware section of the tab.

2. When I clicked on the PC icon with the yellow triangle and the exclamation point inside, the error message was that ""The driver for PCI Simple Communications controller is not installed. Install the latest driver for this device"" however, when I select "fix" after that, it doesnt work. It checks the net and says its getting a new driver but then gives an error and says it cant find one for the PCI Simple Communications Controller and show a red "x" inside a circle.

I believe I made this hard drive a back up a long time ago on a P3 computer and I also believe its a Fat 32 formatted drive.

However, I wouldnt understand why Windows 7 64 bit would be prejudiced to it.
I also tried to see this device using an old Mac G4. It didnt work either. I also tried to have a Windows 7 32 bit laptop take a look and it didnt see it either.

Normally, I would say the drive is bad, but I havent used it since I last backed up to it 2 years ago. It starts fine, and I know the drive is operational. I also know the enclosure works because I use it on other drives with my Mac.

I believe this is a good ole fashion Microsoft screwing! Thanks for your suggestion though!
My System SpecsSystem Spec
16 Dec 2010   #8

Windows 7 Ultimate x64

An obvious question: Is this an enclosure for a 3.5" drive? If so, have you hooked the enclosure to your pc and used external power as well? USB power alone may be enough to cause to drive to spin, but not provide enough power to sustain normal operation.
My System SpecsSystem Spec
16 Dec 2010   #9

Windows 7 64

Thanks for pointing this out. I forgot to mention:

1. It a 3.5 inch external ide enclosure
2. It has its own power cord and adapter which is plugged in.
3. It has usb or firewire 400 connectors and I have tried both.
4. The enclosure was purchased about 5 years ago. Its a Mad Dog mega vault. I bought it at comp usa, show you how old.

Sometimes, I use the enclosure with another ide drive I have and back up from my old Mac G4, so I know it works.

I am pretty confident if I had an older Intel p3 or p4 computer and stuck this drive in as a slave, it would be seen right away. The problem is that I dont. It was previously connected to a Gateway P3 when I backed up with it. Its even possible that it was my slave drive back then in that old machine. Would Gateway poison the drive in some way when they set it up for use as a slave?

Either way, I would think that it should still be seen when using the enclosure and connecting it to my PC now.

Thanks again for chipping away at this for me!
My System SpecsSystem Spec
16 Dec 2010   #10

Windows 7 Ultimate x64

A thought: You may have a conflict with drive letter assignment.

Connect the enclosure to another pc that you know it works with. Go into Computer Management and change the drive letter (something like M,N,O...etc). After changing the drive letter, reconnect it to the pc you are trying to use it with and see if that works.
My System SpecsSystem Spec

 Hard Drive Enclosure not being seen by 7

Thread Tools

Similar help and support threads
Thread Forum
Hard drive enclosure
What hard drive enclosure would i need for this? Hard drive: Imgur: The most awesome images on the Internet Will this work? DYNAMODE USB-HD2.5S-BN 2.5” SATA USB 2.0 Hard Drive Enclosure - Black Deals | PC World
Hardware & Devices
new hard drive enclosure, drive doesn't register
I'm having the same issues as this lady. I have two IDE hard drives from older computers that I want to try to recover data from. I got a new enclosure all set up, plugged the first drive in (Drive 5), and it doesn't register under My Computer. I right click My Computer, go to Manage, avoid...
Hardware & Devices
NAS VS External Hard Drive Enclosure
Hello I am looking between NAS system or External Hard Drive Enclosure the max i can spend is $550 at this moment i have 5 drives that i cant add to my pc as i am max out I would love to buy Synology DS1513+ Network Storage for $ 800 USD but i dont have the money for it and i cant...
General Discussion
IDE hard drive enclosure
I've pulled an old IDE hard drive from a xp computer. chuck it up in my IDE enclosure, plug it into my win7 pc, and nothing. not listed in dev man, computer, or disk manager, zip. i plug the same set up into another xp computer, no prob. i need my win7 pc to recognize it so i can save some info...
Hardware & Devices
Hard Drive Enclosure not being seen
I took one of my old drive from my old computer and installed in the Antec MX-1 Actively Cooled Hard Drive Enclosure. Then I plug the USB into my note book, the USB to SATA bridge works fine. However, I can not see the drive in "My Computer". I have checked a few posts and I looked into Disk...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:40.
Twitter Facebook Google+