Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: You Need To Format Disk Message

27 Dec 2010   #1

Windows 7 Home Premium 64bit
You Need To Format Disk Message

I just bought an Samsung G2 External HDD month ago. It worked well since the date I bought it. But yesterday, when I'm trying to plug in my external, windows give me some error message :

"You need to format the disk in drive G: before you can use it"

I dont want to format my external, because I had many important files in my external. If I had to format, how can I recover my files in the external ?

I think this problem was happened after I use a file lock software. I tried to lock some folder in my external HDD, and when the encrypt process begin, I cancel it. I think this would be the cause of my problem. Maybe some data corrupt in the external HDD. But I'm really not sure about this.

Could someone who expert about this can help me?

My System SpecsSystem Spec
28 Dec 2010   #2
mr pc

Windows 7

Well this is a windows message we never want to see nor is there a definitive cause for it. First - did you properly eject the USB device/drive?

I would suggest:

1) Try every USB port on the machine (and an alternate usb cable)
2) Boot the machine with the drive on and plugged into USB
3) Boot into safemode with the drive on/plugged

What happens if you hit cancel? Can you see the device in "My Computer", does the machine show a usb device attached? Is the file locking software on your pc hd or the external hd with the lockable folder?

You could check this out - it might be outdated, also see if the manufacturer has a knowledge base for this kind of error.

You receive a "Disk in drive <X> is not formatted" error message when you try to access an SD or MMC drive

Hopefully something helps - It sucks when these things crash.
My System SpecsSystem Spec
28 Dec 2010   #3

Windows 7 Home Premium 64bit

Thanks mr pc for those solution, but that do not change anything. I'd tried your suggestions, but it doesn't work..

If I hit cancel, I can see the device in My Computer. It showed Local Disk (G: ). But every time I tried to open it, the format message keeps showing.

About the locking software, I installed the software on my Local Disk (C: ), and I try to lock some folder in my external (G: ), but I canceled the process. And about the link, I don't get anything from that. I dont know what..

Sorry for troubling you, but this problem is really make me sick..
My System SpecsSystem Spec

28 Dec 2010   #4

Desk Top with Win 7 Home Premium 64 bit and Lap Top with Windows 8.1 Pro 64 bit

Ar you plugging your USB cable into a hub or directly into a USB port? If it's plugged into a hub, try connecting it directly into a port.
My System SpecsSystem Spec
07 Jul 2012   #5

Windows 7 Ultimate

i have the same problem with my external hard drive "western digital 320 GB" also i need the data on the hard its very important, can't know what can i do !!
My System SpecsSystem Spec
07 Jul 2012   #6

Windows 7 Home Premium 32 bit

Hi AhmedSaftawy,

For a moment jettison Windows :) , and check whether you can access your external HDDs with a Live Linux CD.

Lucid Puppy is lightweight and easy and here is the how-to. Lucid Puppy way to recover files from a non-bootable computer

If you can access thee drives with the bootable Lucid Puppy pendrive, copy all the data in the external HDD to another external drive or even the internal drive if space is available.

Once you have backed up all the data, you can format the external HDD.

Try and report.
My System SpecsSystem Spec
07 Jul 2012   #7

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

Quote   Quote: Originally Posted by AhmedSaftawy View Post
i have the same problem with my external hard drive "western digital 320 GB" also i need the data on the hard its very important, can't know what can i do !!
You might try Minitool Partition Wizard, and give its "partition recovery wizard" a shot. See what it can find and do for you.
My System SpecsSystem Spec
07 Jan 2013   #8

Windows 7 Ultimate x64

Minitool Partition Wizard was the solution for me! Thanks dsperber
My System SpecsSystem Spec

 You Need To Format Disk Message

Thread Tools

Similar help and support threads
Thread Forum
My disk won't format
So I've passed idk how many days looking up the errors I got all the times I tried to format my pc so I came to an end I got an error 0x80070057 which is solved by formatting the disk before you install the windows but when I hit the format after a bit it cannot be done for the exact same error...
Installation & Setup
Error Message: There is no disk in the drive. Please insert a disk in
Error: "There is no disk in the drive. Please insert a disk into drive \Device\Harddisk4\DR5" The situation is this. I have an old program that came entirely on CDs. You can load the program on your hard drive, but it's constantly asking you to insert CD's to read portions of the program. I...
General Discussion
You need to format the disk '?' before you can use it
So i've searched the forums, and have came to similar problems. The problem is as follows. Someone wanted me to back up their data from two computers, both with windows xp onto an external hdd. I plugged in a brand new external and both computers were able to read/ write to them without any...
Hardware & Devices
Not Able to Format free disk using Disk Management
Hi All I am try to create a new volume from a free space disk which was earlier have ubuntu installed in it. I delete the partition and then right click on it and select "New Simple Volume". I select drive "G" and select format as NTFS. When I click on finish, it give me error "Not enough...
Installation & Setup
Format disk
I am planning to sell my laptop so I need to clear any data remaining. One way is to format disk which uses dos but I can't get to C. I have c:\Users\ I've tried c:\ C\ c\cd etc but I can't get rid of Users and therefore I cannot use the F command. Now I am trying Darik's Boot ande Nute (dban)...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:23.
Twitter Facebook Google+