Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: How do you confirm USB3 is operational

03 Jan 2011   #21
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8

The Atto benchmarks show that the disk drives the speed, not the port.

My System SpecsSystem Spec
03 Jan 2011   #22
Mike Connor

Several, including Windows 7 x64 Ultimate

My System SpecsSystem Spec
04 Jan 2011   #23

Win7 64 bit Home Premium

You are going to forgive my lack of knowledge Ponmayilal, but does it mean if you have an entry under the heading of "UMBUS Root Bus Enumerator", for the drive in the Device Manager, that the drive is operating as a USB3 device?

When my WD Passport drive is plugged in, it showed up in the listing for hard drives - never noticed the other heading. I'll have to check it to see if it exists when the WD is plugged in.

BTW thanks for the info, it appears a USB2 device function slightly better on a USB3 port. But I'm not convinced that my USB3 drive is operating as a USB3 device. It would be nice to know where to look to confirm that yes the drive is connecting at USB3 standards. I'd then be satisfied that either the drive isn't performing at my expectations as a USB 3 device, or I could then investigate what needs to happen to get it to connect as a USB3 device.
My System SpecsSystem Spec

04 Jan 2011   #24

Win7 64 bit Home Premium

Okay I know some of you are going to think I'm a thick head, but when I just checked out the laptop to see if there was an entry under "UMBUS Enumerator" and there isn't. But I checked the disk drive section again and checked the driver details for the WD Passport USB3 drive.

While it doesn't state that the USB driver is USB3 it does provide a date, which is 2006!!! So I think I can confidently say that the drive is connecting as a USB2 device.

So the 6 million dollar question is, what do you have to do to get it to update the driver to a USB3 version. I've tried the option Update Driver but it tells me that the latest driver is installed. So some how I've got to it it to recognise the WD drive as a USB3 device, then we might be in business - but for me, easier said than done!
My System SpecsSystem Spec
04 Jan 2011   #25
Mike Connor

Several, including Windows 7 x64 Ultimate

All you can do right now is to contact the maker and ask for a USB.3.0 driver for the device you own. This is then installed as usual for any device driver.

The device must actually be a USB 3.0 Device , and you must have the proper cables etc.

Windows does not yet support USB 3.0 with "generic" drivers.

There are quite a few places which also have driver downloads for various devices. Like this one;

USB 3.0 driver download for Windows XP, Windows 7, Windows Vista running on Asus motherboards with NEC USB 3.0 controller chip

If you google your device you may be able to find a driver on-line for it.

Some "Passport" drivers here;

Regards....Mike Connor
My System SpecsSystem Spec
04 Jan 2011   #26

Windows 10 Pro/ Windows 10 Pro Insider

In Device manager under USB Controllers there should be an entry for usb 3.0 host controller and another entry for USB 3.0 root hub controller. If USB is integrated in your Motherboard, you should find the latest driver on the MB site.
My System SpecsSystem Spec
04 Jan 2011   #27

Windows 7 Ultimate 32bit

^ Yes, and that is what I have highligted in the first screen shot in my previous post.

And @ Reggie49, a pendrive will appear as shown in my second screenshot.

A USB HDD plugged into a USB3 port will appear like this

How do you confirm USB3 is operational-04-01-2011-16-10-43.jpg

Since I only have the USB2 cable/adapter, I can expect only a marginally improved performance as in the screenshot 3 (USB2 into USB3) in my previous post.

But if and when I buy the USB3 cable and adapter from Seagate and use it to connect to my USB3 port I will without doubt get a vastly improved performance again as indicated in screenshot 3 (USB3).

If your WD USB device is truly a USB3 HDD that came with an USB 3 cable ( sorry, I do not know) and your View by connection shows like above, then you need not have any doubts . It will give you the improved performance. Whether it is upto your expectations is different.

As regards the driver, you only have to look for the latest USB 3 Host controller driver. As I understand most ASUS and Gigabyte MBs use NEC/Renesas UPD 72200/72200A chip.

If you can find out whether the driver is listed like in the screenshot below (Control Panel> Programs and Features), you only have to uninstall it from here and install the new driver.

How do you confirm USB3 is operational-04-01-2011-16-20-08.jpg

You can download the latest driver from here. Gigabyte, ASUS NEC/RENESAS USB 3.0 Controller Driver WHQL Available - Free device drivers Download

E. & O. E. (Errors and Omissions Excepted)

My System SpecsSystem Spec
04 Jan 2011   #28

Windows 10 Pro/ Windows 10 Pro Insider

If you have the Renasis drivers, there should be an entry in start - all programs. Under that it will tell you which driver is installed. At least that is the way mine is.
My System SpecsSystem Spec
04 Jan 2011   #29

Windows 7 Ultimate 32bit

You are right. That is the USB 3 Host controller Utility for checking/unchecking the power management functions of the Controller (and not the driver itself)

Also see my posts in Transend USB 3.0 PCI Card where a screenshot of it can be seen.
My System SpecsSystem Spec
04 Jan 2011   #30

Win7 64 bit Home Premium

Ponmayilal, in the thought that I might have been on the right track over this USB3 driver I've posted two other threads regarding problems I've had trying to upgrade the driver. (Error:-1605 & Can't update to latest USB 3 Driver).

Following you last comment could it be that the reason for the Error 1605, is that you have to unistall the driver before you can install the new one? Mike (Hopalong X), suggested that I should do this but I was reluctant to do so, in case when I tried to reinstall the new driver the same error occurred and the original driver would now be removed!
My System SpecsSystem Spec

 How do you confirm USB3 is operational

Thread Tools

Similar help and support threads
Thread Forum
ASUS M4A89GTD Pro/USB3: USB3 driver issues
Hello and thanks for any help you can provide. I have been having issues with my ASUS motherbord, I recently cleaned and re-formatted my main HDD, after doing this i re installed windows and all my normal drivers, motherboard, cpu, gpu, etc. But for some reason every time I install my USB3...
Screen Saver no longer operational? - Win 7 64
My screen saver isn't coming on as normal... I've tried unplugging USB mouse in case the laser is keeping the screen awake but this makes no difference. I've had a look at task manager but can't see anything obvious that would be causing this kind of behaviour (video playback software, full...
Control Panel - Indexing options - button not operational
Dear Forum, I am in the process of checking that my devices and that when i go to my control panel - when i go to select - Indexing options - it will not let me. It will let me operate all the rest of the items - but just that button. I have operated SFC /SCANNOW Command - System File...
General Discussion
Server is not Operational?
Folk's the problem i am facing is quite weird. When i try to login from a client to server using administrator password i got login perfectly but when i try to change the user rights for some clients it gives me error that the server is not operational able. I got this error from 3 clients of my...
Network & Sharing
here is a printer operational problem challenge.........
I have a strange printer issue. I have a Synology NAS with an attached Konica-Minolta 2400w printer. 4 W7 x64 systems all networked to the printer with 64 bit driver. Everything appeared to work fine from any program on any computer. Today I tried to print a color document from Powerpoint. It...
Hardware & Devices
USB3 doesn't seem to be operational
My mobo specs are included in my profile. It's an Asus mobo. Just the other day I purchased a Seagate GoFlex Desk USB 3 External drive. I have checked my settings in Device manager and it appears that I only have "high speed" performance.I have the latest NEC drivers from Asus. If I try to...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:08.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App