Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB Storage device formatting problem

17 Jan 2011   #11

64-bit Windows 10 Pro

You're most welcome. I'm glad that we were able to help. :)

My System SpecsSystem Spec

 USB Storage device formatting problem

Thread Tools

Similar help and support threads
Thread Forum
Problem Ejecting USB Mass Storage Device
After attempting to 'Eject' my flash drive (all programs closed), I got this message. I've just transferred lots of data over to it using Synctoy, and do not want to risk pulling it and potentially damaging what's on there. In the past I've pulled these drives regardless of message, but ended up...
Hardware & Devices
Problem Ejecting USB Mass Storage Device
This to me is the most annoying feature in Windows. Why can't Windows tell me what programs or windows are using the device so I know what to close? Many times, I have tried closing all programs and windows that might be using the device. I even closed programs and windows that I was fairly certain...
Hardware & Devices
Problem installing USB mass storage device driver
I have an Acer R3610 (so everything is via USB). When I plug in an I/O Magic disk drive, I get an error "Device driver software was not successfully installed". I had earlier tried to fix this situation by going to Device Manager and deleting all drivers under USB controllers. When I rebooted...
Problem to remove usb storage device
When I click on the systray to remove the usb, there's no list of usb devices as there should be, but "..." instead. And together with this problem, when I click a folder to open, the window is small, it can't automatically maximize. What can be done about it? Any suggestion is appreciated.
Hardware & Devices
Problem Ejecting USB Mass Storage Device
I am having issues disconnecting / ejecting a Seagate portable expansion drive. I keep getting the following error message (see pic) .. I don't have any open programs.. Why am I getting this message? How do I fix it?
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:04.
Twitter Facebook Google+