Standard Enhanced Pci To Usb Host Controller not running

  1. Posts : 92
    Windows 7 x64

    Standard Enhanced Pci To Usb Host Controller not running


    I'm shortly after doing service pack 1 cleanup, having the following problem:

    USB devices are not recognized, are not working at full speed, or are being newly installed.
    Looking to devmgr I found there are many USB devices having the ! icon over it, moreover I believe that the culprit of all this mess is this driver

    Standard Enhanced Pci To Usb Host Controller

    not running at startup.
    Don't know why and how is that related to SP cleanup procedures, however after removing this device and several new hw rescans I get as this controller as other USB devices recognized and probably working properly.

    Any help how to force this controller be running at startup so that all USB devices are identified properly?

    Standard Enhanced Pci To Usb Host Controller
    Driver version: 6.1.7601.17514
    Driver timestamp: 21.6.2006

    I've made proof that if I restore drive to state before SP cleanup, all USB devices are started flawlessly.

    I think this is related record in event log for this problem:

    EventID: 219
    Source: Kernel-PnP
    Failed to load driver \Driver\usbehci for device PCI\VEN_10DE&DEV_0AA6&SUBSYS_1CF71043&REV_B1\3&267a616a&0&21.

    If I try to open this registry key
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\VEN_10DE&DEV_0AA6&SUBSYS_1CF71043&REV_B1\3&267a 616a&0&21\Properties

    I get error message: access denied

    Maybe the problem?

    Last edited by Anakunda; 21 Jan 2011 at 15:26.
      My Computer

  2. Posts : 2
    Windows 7 64bit

    I also have this problem - it occured after the Windows Update(s):
    • Update for Microsoft Windows (KB976902)*
    • Hotfix for Microsoft Windows (KB976422)
    *cannot be uninstalled

    I have tried various methods to solve this issue based on other searches, but nothing appears to be working. Any information regarding this issue would be much appreciated.
      My Computer

  3. Posts : 2,686
    Windows 8.1 Pro w/Media Center 64bit, Windows 7 HP 64bit

    Here is the drivers on my system. What does yours show and are these files still on your system and what version.

    Standard Enhanced Pci To Usb Host Controller not running-usb-driver.png

      My Computer

  4. Posts : 2
    Windows 7 64bit

    Here it is:

    • usbhub.sys & usbport.sys have the same details as yours
    • usbehci.sys is different
    • usbfilter.sys is there from AMD)
    Attached Thumbnails Attached Thumbnails Standard Enhanced Pci To Usb Host Controller not running-drivers.png  
      My Computer

  5. Posts : 1
    windows 7 home premium 64bit

    I had the same problem after SP1 was automatically installed... what I did was to go into Device Manager and uninstall the "Standard Enhanced PCI to USB Host Controller" that had the exclamation mark next to it, and then I rebooted the system.. Windows found the new hardware on the restart and installed the appropriate drivers for it.. all is working fine now..
      My Computer

  6. Posts : 92
    Windows 7 x64
    Thread Starter

    This is what I tried too. Uninstall all USB devs with ! icon over it. After new hw rescan it wound them and installed appropriate drivers and everything went fine until next boot when the problem was back. Now it looks like kinda system corruption as after clean Win7 resinstall with SP1 the issue isnt annoying anymore.
      My Computer

  7. Posts : 1
    Windows 7 Ultimate x64

    Solution that worked re standard enhanced pci to usb problem

    I experienced the same problem round about the time of an SP1 update: notifications when plugging in USB keys that the device could perform at a higher speed, yellow mark next to the standard enhanced pci to usb driver.

    Updating the usb drivers made no difference. Uninstalling them worked only until next reboot.

    Eventually I looked into the Event Viewer and saw that a LaCieUSBFilter.sys driver was repeatedly causing problems. I had installed a LaCie programme a few months before to try to resolve a LaCie storage drive issue (that was actually linked to a faulty PSU). Uninstalling the LaCie software solved the USB problem.

    It took weeks to resolve this as there were no solutions posted online (hence this post..), although it seems other users have found that USB-related software installations have been incompatible with Win7 and have caused USB 2.0 to be disabled.

    Hope this helps someone out there.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:34.
Find Us