Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Mousepad is not working properly-SONY VPCEA23EN

27 Jan 2011   #1

vindows 7
Mousepad is not working properly-SONY VPCEA23EN

I am using SONY VAIO VPCEA23EN model, with windows 7 Home Basic. 64 bit machine.
Till yesterday there was no problem with my machine, all of a sudden my mouse pad stopped working ( i am using SYNAPTIC pointing devise-default driver from sony)
I did some research and found out that when i use internet with the Ethernet cable, the mouse dosent work and when i use the wireless connectivity the mouse works just fine.

I also tried updating the driver software from synaptic 14 to synaptic 15.2.7, then also i faced the same problem ( with Ethernet cable connected,mouse dosent work).

I have updated all the drivers from sony also.

Please help me this and thanks in advance.


My System SpecsSystem Spec
27 Jan 2011   #2

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86

Does the mousepad work when you are totally disconnected from the internet i.e. neither ethernet nor wireless? Also, try reinstalling or changing the ethernet driver and look for updates on the card manufacture's website, not on Sony.
My System SpecsSystem Spec
27 Jan 2011   #3

vindows 7

yes dude, its working when the internet is completely shut off...
i am using belkin modem G wireless router.ill look into the drivers for it.
My System SpecsSystem Spec

27 Jan 2011   #4

vindows 7


i downloaded the ethernet driver from sony website. (MarvellEthernet driver )

then also its notworking. :-(
My System SpecsSystem Spec
27 Jan 2011   #5

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86

Go to device manager and uninstall the ethernet driver. Now, before you restart the computer, go to here:


Locate the folder/folders containing Marvell drivers/install information and delete them.

Now reboot. See if you can extract the driver you downloaded to a folder. Now update the driver by pointing to that folder in device manager.
My System SpecsSystem Spec
27 Jan 2011   #6

vindows 7

Hi Dude,

i did what you said to do.

i installed the downloaded Marvell Ethernet Driver but still it is not working.
When i plugged in the ethernet cable, for a second the mouse worked then it didnt work.
so i had to use the wireless so that the mouse pad works.

Please suggest me a solution for this.
My System SpecsSystem Spec

 Mousepad is not working properly-SONY VPCEA23EN

Thread Tools

Similar help and support threads
Thread Forum
Synaptix Mousepad Not working - Driver/Hardware Issue
Hi all, I have a Samsung RC520. SAMSUNG One day the mouse trackpad stopped working. Within the device manager, it doesn't appear to be installed, as only the USB mouse appears plugged in. I have tried re-installing drivers for the trackpad a number of times but to no avail. Any ideas?...
Hardware & Devices
Sony Vaio CS17G - Touch Pad not working Properly?
Hi, I am using Sony Vaio CS17G with W7 Pro x86. Mostly I use a USB Mouse with my notebook. Lately, I have observed that the notebook's touchpad has been behaving erratic. At times; 1) Right click menu is opened when clicking left buttons or tapping on the pad. 2) Sometimes, it keeps...
Latest Windows 7 Update on Sony Vaio - Now will not load properly
I updated to the latest Windows 7 service pack this morning, upon restarting I can log in however nothing loads up. My screen is black, I am able to move the cursor. When pressing CTRL + ALT + DELETE a error message comes up stating: "Failure to display security and shut down options. The logon...
Windows Updates & Activation
Sony Flash Disk not working for Sony LED TVs
I have 8gb Sony flash disk and I bought it for my Sony TV. I used to watch movies for a while but yesterday my TV couldn't recognize the flash disk. I tried everything but couldn't make it work. What is the problem? Can someone help me?
Hardware & Devices
Ripped movies not displaying properly on Sony Bravia XBR-55
My apologies in advance if I'm asking a question that's already been asked or if I'm not providing all the appropriate details...I'm new to this conference. I'm attempting to set up a Home Media System for my muli-handicapped son who's passion in life is movies. This approach should greatly...
Media Center

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:55.
Twitter Facebook Google+