Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Marvell Yukon 88E8056 PCI

31 Jan 2011   #1
babybearmike

Windows 7 home and Ubuntu
 
 
Marvell Yukon 88E8056 PCI

Hi Folks, I have a eathernet card as in the title, and it refuses to function with Windows 7 or Ubuntu 10.10, However the thing logs on to the internet just fine with an older Ubuntu 9.0 that I ran from a disk, and of course, it ran fine with the previous XP. I got the newest driver and installed it, no go. Tried drivers from the aftermaket, no go. Does anybody have an idea for me? Thanks very much. Mike


My System SpecsSystem Spec
.
31 Jan 2011   #2
Punkster

Windows 7 Ultimate SP1 (64-bit)
 
 

Hello there, i Google'd the name and i came up with the Marvell site.

According to this particular Ethernet Device, this is the driver that will work for you.

Marvell: Download Drivers

It's an All-In-One Installer with practically every single windows version out there (32/64-bits)

And it's the one you need (88E8056)

Try that and report back.
My System SpecsSystem Spec
Reply

 Marvell Yukon 88E8056 PCI




Thread Tools




Similar help and support threads
Thread Forum
Marvell Yukon 88E8059 - Can't register resources
Hey guys. I have a big problem with my LAN controller..for some reason the driver for it has randomly stopped working. I've tried to reinstall the setup from Marvell's website a number of times, rebooted etc but it just won't bring it back. It's an onboard Ethernet controller on an ASUS...
Network & Sharing
Marvell Yukon 88E8056 PCI-E Gigabit Ethernet - ONBOARD Asus P6X58D P
Hey guys! I'd like to thank you first for all the help with my other problems with this piece of crap computer. But now I want to solve, or at least find out why this problems occur. So I have a Asus P6X58D Premium motherboard which I guess has a "Marvell Yukon 88E8056 PCI-E Gigabit...
Hardware & Devices
Marvell Yukon Driver
Hi, Just wondering who else has a Marvell Yukon network controller and are you happy with the new driver changes? Thanks,
Drivers
Windows 7 & Marvell Yukon 88E8001
I am having a strange problem with the onboard Marvell Yukon 88E8001 network adapter running on Windows 7 64bit. For some reason it has suddenly stopped being able to connect to the routers DCHP and obtain an IP address, nothing has changed and it was working fine previous. When I type...
Network & Sharing
Marvell Yukon Controller cant connect
Hi, I just loaded Windows 7 Build 7600 and cant connect to network or internet through my on-board Marvell Yukon gigabit controller. I've updated my drivers to the latest i can find (v. 11.22.4.3) and still nothing. Occasionally it will show I'm connected, but when I launch IE it drops connection....
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 15:57.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App