Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Boot failure - Hangs at "Verifying DMI pool data"

02 Feb 2011   #1

Windows 7 Ultimate x64
Boot failure - Hangs at "Verifying DMI pool data"

Hello all, I'm new & having a spot of trouble so I decided to ask for some help here after seeing many other similar issues resolved :)

The current situation:
I have 1 partition containing my windows 7 install, but it won't even get to the stage where I can select (e.g.) safe mode because it hangs at "Verifying DMI pool data....." after the POST. The windows 7 partition is the active partition. Startup recovery via the windows 7 cd does not help, and bootrec commands give "element not found". I think it's because I deleted some crucial files off what was the boot partition (an XP partition), then deleted that partition.

The question:
How do I get my windows 7 install to boot?

The Full Story (aka the wall of text)

How it happened

When I set up the installs on my current system hard drive a year or two ago, I initially installed Windows XP Pro (x86) on a 100gb partition, then decided to install Windows 7 Ultimate x64 on the remaining 830gb or so. About a month later I realized I barely used the XP install but didn't want to reinstall everything, so from my 7 install I deleted all the directories except Windows and any directories marked as System, which were hidden (i.e. left all files in the root of the XP partition alone). I intended to resize the XP partition later & use the reclaimed space, but I ended up unmapping the drive letter from the XP drive & so forgot about it.

Fast forward to a few days ago. I was (ironically, when you consider later events) shuffling/organizing hard drive contents to allow for easier backups when I noticed the XP partition, & decided to delete everything on it (from the 7 partition). So now the XP partition has all the files and directories which don't have the system attribute set deleted. I didn't restart straight away, and got side tracked.

For the sake of completeness, I will mention that the reason I eventually rebooted was because I managed to infect my windows 7 install with a virus (I can't remember its name - it hijacked google search results to separate sites for the purpose of tracking my clicks). I cleaned the virus (or most of it) manually (it wasn't very persistent as far as I could tell - 2 processes and they didn't even restart each other), and restarted to check whether it was gone, but encountered the aforementioned "Verifying DMI pool data" and a distinct lack of any windows 7 boot screen

What I've tried:

I pulled out my trusty Windows 7 install disk, booted from it (so it got past "Verifying DMI pool data" to boot from it) & chose to repair my system. No installs of windows 7 were recognized, and the only thing I could do was the Startup Recovery (I didn't/don't have any backup images). I did that several times, restarting in between, but it didn't help. Each time it would tell me that the partition table is corrupt and that it had fixed it.

Further googling led me to bootrec, so I used the command prompt from my 7 disk to try that:
/scanos showed my 7 install
/fixmbr gave "operation completed successfully" or something like that
and the other 2 options gave "element not found" as their final message.

The /fixmbr did nothing helpful, so more googling of this error message led me to diskpart. I used diskpart to set the xp partition active, then tried to use bootrec on it, which gave "element not found" again, so I restarted to see if startup repair would work now (it didn't, it still hung at "Verifying DMI pool"). I tried the same sequence with the 7 partition (again, "element not found", and hung at "Verifying DMI pool").

I got back into the command prompt again & played with some more diskpart commands. Stupidly, that included running "diskpart clean" while my system drive was selected :/ After some extreme panicking (after all, my backups were out of date), googling, and a failed attempt at using EASEUS Partition Recovery, I managed to use testdisk to restore the partition table & get all my files back (I learned my lesson & promptly backed up the important stuff).

(For anyone else who finds this & is panicking, I took the drive out of my PC, and connected it to a second computer - windows XP, using a USB enclosure, but neither OS nor enclosure should matter - and with the help of the testdisk tutorial I did a deep search for partitions - you can cancel the quick search by pressing enter during the quick search - which took about an hour, then I saved those partitions & fixed the NTFS bootsector using the backup like they do in the tutorial.)

I was back to where I started, except far less panicky. Bootrec still gave "element not found". After trying startup recovery 4 times (with reboots in between) as recommended on another thread here (lost the link, sorry) without getting anywhere, I downloaded the Partition Wizard iso, burnt it, & booted from it. I deleted the XP partition, & resized the 7 partition to the left to take up all available space.

After that completed, I tried the startup recovery 4 times again (with reboots in between), which didn't get me anywhere. I was still getting the same results with bootrec, and I've tried marking the (now 930gb) 7 partition as the active partition. The expected files show up when I do "dir" after swapping to D:, so I know moving the partition hasn't completely busted it.

That's all I've done. If this were Windows XP, now would be the time where I'd do a repair install over the top, but 7 doesn't seem to have an equivalent (closest thing would be the startup repair from the disk, which doesn't help work).

My System SpecsSystem Spec
02 Feb 2011   #2

Windows 7 Ultimate x64

Solved it; my system hard drive was not the first hard drive in the BIOS boot priority list. Once I changed the priority to make that hard drive the first hard drive, it got past the Verifying DMI pool data" step after about 15 seconds of waiting, and gave me the "BOOTMGR is missing", "Press CTRL+ALT+DEL to restart" messages.

I went into the setup dvd, and this time it actually spent some time searching for windows installations. It found one and prompted me to fix it (separate from startup repair), I chose no and went into the command prompt and did bootrec /fixboot. I didn't get "element not found" this time!

Sadly after a restart I still couldn't boot into windows, so I fired up the setup CD and this time allowed the repair. After a reboot, it still didn't work, so I fired up the dvd again yet again and used the manual "Startup Repair" option from the list of about 5 options. This time the diagnostic information gave a different message, something like "the boot record is corrupt", and after clicking Finish, it restarted and windows booted :)
My System SpecsSystem Spec
25 Jun 2012   #3


I'm having the same problem. .
But the above trick doesn't help me to get out of it. . . .
Please help if somebody know how to fix this problem. . .
My System SpecsSystem Spec


 Boot failure - Hangs at "Verifying DMI pool data"

Thread Tools

Similar help and support threads
Thread Forum
Cannot boot Windows USB, stuck on "Verifying DMI Pool Data..."
I've created a bootable Windows 7 usb using Rufus. But when I go to boot it (by changing First Boot Device in BIOS to Removable), it just gets stuck at "Verifying DMI Pool Data...". What's wrong? I even checked the usb drive using MobaLiveCD, and it works fine.
Hardware & Devices
Trying to boot with new HD, stuck at "verifying dmi pool data"
This is my first time trying to fix a computer, so please forgive my ignorance. I recently changed the motherboard and hard drive on my hp computer. Before I did that, I was able to create a windows 7 recovery cd (before the old HD died entirely), and I also have a system image on an external...
Hardware & Devices
Pc hangs at 'verifying dmi pool data. . . '
Hello evgeryone. .! My p.c. Hangs up at verifying dmi pool data. . . . And not loading o.s.. . . About my p.c. Conf:- 1. I have window 7 ultimate installed in c: drive. . 2. I have zotac motherboard 3. I have 500gb hard disk. 4. Ram is 2gb. 5. There is no floppy drive in my p.c. 6. Hp...
General Discussion
Stuck on "verifying dmi data pool"
Hi everyone, i'm new to the pc world, so work with me. I'll do my best to explain and look forward to having someone help me I started my pc this morning and the screen is stuck on "verifying dmi pool data" My OS will not boot Recovery disc found no errors I replaced the battery, and...
BSOD Help and Support
Delay during "verifying DMI pool data
So i just updated my BIOS to the latest version out there because mine was really out dated. Now when ever the PC starts up it stays at Verifying DMI pool data for about 10-15sec, whilst with my old BIOS it stayed for about 5-8sec. Also with my new BIOS it doesnt say boot from CD/DVD after it...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:53.
Twitter Facebook Google+