Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Difficult problem with iaStore, yukonw7 and ICH9

02 Feb 2011   #1

Windows 7 Ultimate x64
Difficult problem with iaStore, yukonw7 and ICH9

Hi All,

I have been dealing with a problem for about 2 weeks now. I have an Asus P5K motherboard, and am running Windows 7 64-bit. I run RAID-0 for my C:. Basically ever since I moved to win7-64, I often get entries in my event viewer like this:
"The device, \Device\Ide\iaStor0, did not respond within the timeout period." (from iaStor).

In addition, the problem is made worse as it's often (as of late, especially when doing network intensive operations) followed/preceded by this:
"Driver status 1" (from yukonw7).

After much research, it seems that my Marvell Yukon 88E8056 ethernet (built in) does not play well with Intel's ICH9 controller. I have tried the following (from all my reading in other forums):
- Flashed my network EEPROM to REV_14. This was recommended by an MS MVP, but it did not solve it.
- Got the latest Yukon Marvell drivers and installed them.
- Upgraded Intel Matrix Storage to the latest (it was re-named to Intel Rapid Storage Technology in the latest revision, but nobody seems to ever mention this).
- Turned "IPv4 Checksum Offload" to "Disabled" for my Yukon card (this was recommended in a MS support forum).
- Modified regkey \HKLM\SYSTEM\CurrentControlSet\services\iaStor\Parameters\PortN\LPM to '0', as in older revisions of the driver, there was an issue with power saving.
- Stopped the hard drives from spinning down in power savings (this was my own finding, as I noticed if the D: drive ever spun up while a network request was waiting, there would be many errors).

All of this has helped somewhat (it occurs less often), but it still occurs. Most recenly, Starcraft2 has been causing it, and when it happens the HD light also stays on.

I have tested the RAM, CPU and HardDrives through various means and all are fine. I am 100% sure it's some sort of screwy interaction between the Yukon card and iaStore, and I'm hoping someone here knows how to get to the bottom of it, as I can't think of anything else to do.

Thanks for any responses.

My System SpecsSystem Spec
02 Feb 2011   #2

Windows 7 Professional SP1 - x64 [Non-UEFI Boot]

Welcome to Sevenforums,

You might need to go in your Bios settings to enable AHCI over the IDE...

Here: AHCI : Enable in Windows 7 / Vista

Uninstall from "program & features" the Intel Rapid Storage Technology or Intel Matrix Storage Manager, reboot (windows 7 will install some msahci.sys driver), delete the key in your regitry \HKLM\SYSTEM\CurrentControlSet\services\iaStor...

Reinstall your drivers. see if its help!
My System SpecsSystem Spec
11 Feb 2011   #3

Windows 7 Home Premium

I just noticed an update to the Intel RST drivers. You may want to update. I strongly doubt it will help, though.

I have had problems with a Marvell controller under Vista. I ultimately stopped using it altogether. Marvell and Intel RST just don't seem to play well together, as you suspected. Your cheapest solve may be an add-on SATA board with better compatibility.

I have lost the use of my WD Notebook backup drive due to incompatibility with IRST, which Intel does warn about indirectly if you read the fine print. Unfortunately I haven't found a compatibility list for the IRST drivers, which it seems Intel should be the ones to supply, you know, in a reasonably perfect world.
My System SpecsSystem Spec


 Difficult problem with iaStore, yukonw7 and ICH9

Thread Tools

Similar help and support threads
Thread Forum
Need expert for difficult computer problem - random crash/lockups
I've been building PCs for my personal use for almost 20 years, and my latest HTPC I built about 8 months ago. It's fairly basic, a Gigabyte motherboard with 8GB RAM (2 sticks), a Sandy Bridge i3, a BD drive, and a RAID card with 3 attached HDs in a case with an Antec Earthwatts 380W PSU. It ran...
BSOD Help and Support
When Win 8 is on within VMware,Win 7 is difficult to run
The title says it all. Win 7 ( the host OS ) is sluggish when Win 8 ( guest OS ) is running inside VMware. Seems like Win 8 is interferring ( my speculation only ). Is that normal or is there something can be done about it so that I can run Win 7 normally. t-4-2
Difficult Question
Hi, I've been searching for a software program that can view the data on my second (and encrypted) HD from outside of Windows (Boot CD, DOS, Linux, anything) or even while booted into Windows. The purpose for viewing the data is because I would like to see how well I have encrypted my second HD....
Help, Difficult Problem
This is a weird problem and I'm not sure I'm even in the right place. Basically, about a week ago I did the mandatory Windows 7 updates and now whenever I boot up my computer HP Wireless Assistant takes a good minute to load delaying my internet connection. Prior to this update my computer would...
General Discussion
Error yukonw7
Sometime in this last week, the system stopped and i must restart. After i see events and i found this: I don't change any hardware or install/upgrade i don't understand the cause...can you hel me ?? Thank Hispanico
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:35.
Twitter Facebook Google+