External HDD won't show up in Disk Management or Explorer


  1. Posts : 2
    windows 7 ultimate x32
       #1

    External HDD won't show up in Disk Management or Explorer


    My WD Passport 320gb external drive is not recognised. When I plug it in the light comes on and i can hear the disk fine as normal. But it won't show up in either My Computer or Disk Management.

    I've tried Re-Scanning is Disk Management, as well as every single USB port on my Toshiba Equiuim L40 laptop.

    I can't assign it a drive letter because literally nothing shows up.

    I was hoping to format this hard drive to FAT32 so I can backup my PS3 data before I upgrade it's hard drive. Any help much appreciated, and just to make it clear there is absolutely nothing on the drive I want to keep so it doesn't matter what is lost from it!

    Many thanks to anyone who can help!!!!!!

    )

    (By the way this is my first time ever posting in a forum so bear with me please!)
      My Computer


  2. Posts : 3,612
    Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)
       #2

    hi there fellow uk man :) try this microsoft fix it from there site
    Hardware devices are not working or are not detected in Windows go to link Hardware devices are not working or are not detected in Windows

    http://support.microsoft.com/fixit/


    What it fixes...

    When you install a hardware device, it is not detected
    Determine if your audio device is plugged in
    Driver updates aren't automatically installed by Windows Update
    You receive one of the following errors:
    Your <Device Name> is currently disabled or turned off in Windows
    Your <Device Name> has a driver problem and needs to be reinstalled
    Windows has detected a problem with your <Device Name>, it is not working properly
    There is no driver installed for your <Device Name>
    Attached Thumbnails Attached Thumbnails External HDD won't show up in Disk Management or Explorer-magical-snap-2011.02.03-13.37-001.png   External HDD won't show up in Disk Management or Explorer-magical-snap-2011.02.03-13.39-002.png  
    Last edited by brianzion; 03 Feb 2011 at 08:41.
      My Computer


  3. Posts : 11,408
    ME/XP/Vista/Win7
       #3

    Have tred pluging in to a mates PC?
      My Computer


  4. Posts : 2
    windows 7 ultimate x32
    Thread Starter
       #4

    I have tried the microsoft fixit that doesn't detect it, and i have also tried 3 other computers they don't show it either. The drive definately hasn't been dropped and the lead works... AGGGGHGHHHHHHHH!!!! :)

    Thanks for trying to help though guys... much appreciated
    [IMG]https://www.sevenforums.com/data:image/gif,GIF89a%12%00%12%00%B3%00%00%FF%FF%FF%F7%F7%EF%CC%CC%CC%BD%BE%BD%99%99%99ZYZRUR%00%00%00%FE%01%02 %00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%21%F9%04%04%14%00%FF%00%2C%00%00%00% 00%12%00%12%00%00%04X0%C8I%2B%1D8%EB%3D%E4%00%60%28%8A%85%17%0AG*%8C%40%19%7C%00J%08%C4%B1%92%26z%C7 6%FE%02%07%C2%89v%F0%7Dz%C3b%C8u%14%82V5%23o%A7%13%19L%BCY-%25%7D%A6l%DF%D0%F5%C7%02%85%5B%D82%90%CBT%87%D8i7%88Y%A8%DB%EFx%8B%DE%12%01%00%3B[/IMG]
      My Computer


  5. Posts : 3,612
    Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)
       #5

    i can understand your frustration i have had the same problem but with my main tower machine in the end i unplugged the motherboard connectors to the usb leads to the ports and that solved it windows booted and reinstalled all the usb drivers, guess that's a little of the rails for a lappy?
      My Computer


  6. Posts : 3,612
    Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)
       #6

    from op and just to make it clear there is absolutely nothing on the drive I want to keep so it doesn't matter what is lost from it!
    has the drive not been for-mated with anything? no file system on it? im sure that is why windows will not see it if so. in disk management is there no sign of a drive not assigned with a drive letter etc?

    at the bottom of the drive list in disc management they show up there.

    "USB Device not recognized: One of the devices attached to this computer has malfunctioned and windows does not recognize it." do you get this in a pop up?
      My Computer


  7. Posts : 9,607
    Win7 Enterprise, Win7 x86 (Ult 7600), Win7 x64 Ult 7600, TechNet RTM on AMD x64 (2.8Ghz)
       #7

    Welcome leeroy1978

    Is this a new WD external HD, or have you used it in the past? If used what was on it previously? & what file system was used?
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:41.
Find Us