Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: usbscan.sys and dot4usb.sys missing

05 Feb 2011   #1

Windows 7 Professional x64 DE
usbscan.sys and dot4usb.sys missing


for months i am trying to install my HP C3180 MFP printer on Win 7 Pro 64-Bit (german) without success.
The HP AIO driver installation program always failed with a fatal error - thats already posted on their forums without reply.

The device driver installation when plugging the printer fails. The corresponding info in the shows following error
inf: Opened INF: 'c:\windows\temp\dmiwu\{8e133662-0961-4108-b196-a1e3622d3f42}\hposcu01.inf' ([strings.0007])
inf: Opened INF: 'C:\Windows\inf\sti.inf' ([strings])
!!! sto: Driver package references a missing external file 'C:\Windows\system32\drivers\usbscan.sys'. Error = 0x00000002
!!! sto: Failed to retrieve driver package copy files. Error = 0x00000002
!!! sto: Failed to get list of driver package files. Error = 0x00000002, Filename = c:\windows\temp\dmiwu\{8e133662-0961-4108-b196-a1e3622d3f42}\hposcu01.inf
on the web i found some info about that usbscan.sys file but all related to WinXP and Vista. my old, still existing, WinXP installation contains this file, but its definitely not compatible - didnt even try, and dont want.

i wonder how to safely restore that in case it should be there.

when running the always failing HP installation the shows

inf: Opened INF: 'D:\Users\Lou\Downloads\Drucker\AIO_CDA_NonNet_Full_Win_WW_130_140\hprdv_vp.inf' ([strings])
inf: Opened INF: 'C:\Windows\inf\DOT4.INF' ([strings])
!!! sto: Driver package references a missing external file 'C:\Windows\System32\drivers\Dot4usb.sys'. Error = 0x00000002
!!! sto: Failed to retrieve driver package copy files. Error = 0x00000002
in this case its the dot4usb.sys file failing. similar problem, is that a system file and if, how to restore.

i am not sure if this is the reason for the failing installation but it looks so.

help is really appreciated


My System SpecsSystem Spec
05 Feb 2011   #2

Windows 7 Professional SP1 - x64 [Non-UEFI Boot]

First you should run a SFC /SCANNOW as the usbscan.sys is part of windows 7 driver:

SFC /SCANNOW Command - System File Checker


SFC /SCANNOW : Run in Command Prompt at Boot

This should repair that file.
My System SpecsSystem Spec
05 Feb 2011   #3

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86

Go through this thread carefully, hopefully you'll find a solution.

Drivers for HP photosmart C3180
My System SpecsSystem Spec

05 Feb 2011   #4

Windows 7 Professional x64 DE

using the SFC did not recognize any problems. nothing missing, no integrity problems and it did not recover any of the missing files.

found the usbscan.sys in C:\Windows\System32\DriverStore\FileRepository\sti.inf_amd64_neutral_9d9a7113099a28a2 and copied it to System32 but the next driver install failed with serscan.sys missing. thats also there, copied to System32, reinstall, failed again.

this time a bunch of other files like hpxxx.inf files missing.

probably a bad/corrupt/incomplete Win7 install. but cant remember anything suspucious during the installation.

decided to re-setup Win7 on the existing installation, checked the previously reported files and all there.

plugged in the printer to the USB port and now all worked.

it seems somehow the Win7 install was messed up. from experience with Win7 installs, messing that up is a feat.

however, finally made it work.
My System SpecsSystem Spec
05 Feb 2011   #5

Windows 7 Professional SP1 - x64 [Non-UEFI Boot]

Glad you sorted it out...yes, it was looking pretty messy.
My System SpecsSystem Spec

 usbscan.sys and dot4usb.sys missing

Thread Tools

Similar help and support threads
Thread Forum
Bootmgr.exe missing... mpio.sys missing or corrupted. Unable to boot
I just got a computer for free, a Dell Studio 1555. When I got it, it would try to boot, then come to a screen that said that bootmgr.exe was missing. Sometimes I got a message that said something like mpio.sys was corrupted or missing. I have a Win 7 disk, so I put it in and tried to repair the...
General Discussion
Missing MBR and missing OS after sleep problem
My setup had an MBR issue a few days ago after installing Skyrim. I was unable to repair it using the windows 7 instal disc. I tried the automatic fix as well as bootrec.exe. After giving up and reinstalling a fresh windows 7, my rig has not been starting up properly. It insists on waking up from...
BSOD Help and Support
Pictures missing suddenly and backgroung picture missing
i got on the pc this morning and noticed that where i have the picture saved on the desktop it was just black so i went into where my pictures are saved and there missing ?? but when i double click on one it will show any ideas please im lost on this ??
General Discussion
Win Explorer arrows missing, cursor spinning, libraries missing
New laptop (Lenovo W510), but I swapped boot disk for an SSD and reinstalled Win 7 64bit from recovery disks. I moved My Documents to D: and when I open Windows Explorer all looks fine. When I click on an arrow beside My Documents (or Music or anything), the arrow selected disappears, folder...
General Discussion
Missing boot menu and missing data partition
Hi there, I'm still very happy with my XP Pro, but I thought I'd set up a dual boot with Win7 ultima 64 and check it out. So I popped in another hdd that was sitting idly in a drawer and installed 7 on it. I fully expected that Win7 would be able to see there's an XP installation and create a...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:34.
Twitter Facebook Google+