Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Have to stop/start Print Spooler to get documents to print?

11 Feb 2011   #1

Windows 7 Home Premium 64bit
Have to stop/start Print Spooler to get documents to print?

(Windows 7 Home Premium 64-bit, HP LaserJet CP1215)

When printing from Word (or any other normal application) the documents just sit in the print queue with Status = "Error - Printing".

If I stop, then re-start the Print Spooler service, they then print.

Strangely enough, this does not happen if I print from the HP printer diagnostic utility.

I've done complete re-install of the entire printer driver suite and I'm pretty sure everything that end is OK. So what's happening with the spooler? The error message isn't exactly very revealing .

Any help gratefully accepted!

My System SpecsSystem Spec
11 Feb 2011   #2

Windows 7 ultimate 64 bit / XP Home sp3

My best advice would to contact HP with this problem. Maybe they might be able to help you.
My System SpecsSystem Spec
11 Feb 2011   #3

Windows 7 Home Premium 64bit

Thanks thefabe. I'm on the case there also, luckily 3 days until guarantee runs out (!)

But in case its not a HP thing, I've also seen the following suspicious symptom you might be able to help with ;-) When it fails to print, I see the following pop up in the Event Viewer:

"The print spooler failed to delete the file C:\Windows\system32\spool\PRINTERS\00003.SPL, error code 0x2. See the event user data for context information."

However, the file left behind in the spool/PRINTERS are called 00003.*

(Note the above is after having restarted the spooler, cleared the spool dir, etc)

So why the filename mismatch, and what is error code 0x2?
My System SpecsSystem Spec

17 Feb 2011   #4

Windows 7 Home Premium 64bit

Anyone got any ideas?

HP were very helpful but unfortunately ineffective... they reckon its a Windows 7 problem.

They did confirm that yes, the printer should work on this OS.

Any gurus able to decode the print spooler error messages?
My System SpecsSystem Spec
01 Apr 2011   #5

Windows 7 home 64

I am having the EXACT smae problem with an Asus laptop and a Canon MP830 printer...even down to the ability to print from the Canon diagnostic application.

Has anyone found any fixes?

For clarification, this is not an application specific problem, it occurs with all applications, everytime, except the printer specific diagnostic application. Also this is not a networked computer, the printer is plugged directly into a USB port. Lastly, the event ID is 372 and the error code from the print processor is 5, all of which means "Access Denied". Apparently, this could be caused by a number of issues, all of which I have tried, e.g. using different cable/port, reinstalling windows 7 drivers (several times), loading new firmware, etc. I'm pretty sure this is a Windows 7 issue.
My System SpecsSystem Spec
01 Apr 2011   #6


I'm not sure if this is exactly the same but I have narrowed down an issue here with Office 2010 and printing. Usually happens to laptops coming from offsite and then back onto our network. You will be able to print via any utility that is not related to Office. As stated a bounce of spooler or a full reboot will fix this for me. I was pointed in the direction of THIS article about Office disabling printers. I have not pursued this yet but figured I'd throw it out there as the behavior is very similar.

I should get a chance next week to look into this fully. If there is no luck here by then I'll be sure to post back my findings on this.
My System SpecsSystem Spec
02 Apr 2011   #7

Windows 7 Home Premium 64bit

linc22 you are in luck. I found a solution for the ASUS G73 printing problem: Install the latest Fresco USB3.0 driver.

just got my g73jw - any PRINTING errors???? - Page 5

I'm pretty sure I posted my solution here too. Wonder where it went?
My System SpecsSystem Spec
02 Apr 2011   #8

Windows 7 home 64

Holy smoke! That worked! Thanks a million Parrotx34! This problem has been haunting me for many many weeks now. Interestingly, I thought of this driver update as a possible solution several weeks prior, but everytime I tried to update the driver, it said it the old one 3.0.105.x was the most current. Again, thanks a billion!
My System SpecsSystem Spec
03 Apr 2011   #9

Windows 7 Home Premium 64bit

Glad to help. Took me ages to find the solution, easy though once I started searching for "asus printer problem" rather than all sorts of Windows / HP related stuff. HP even sent me a replacement printer. No-one at any point suggested looking at USB drivers. Even this guy:

Solving Windows 7 Print Spooler problems - check the comments!

On the plus side I now know more than I ever wanted to about print spoolers.
My System SpecsSystem Spec
27 May 2011   #10

Windows 7 x64

Thanks very much Parrotx34!! :)

Your info helped me resolve the same issue with an Asus N53J Notebook with HP printer.

I had spent around two hours struggling with this before I found your thread.

Who would have thought updating usb drivers would resolve it? Massive fail for Asus and the USB chipset manufacturer for having these flawed drivers out there....

Anyway great to have this sorted and thanks again!
My System SpecsSystem Spec

 Have to stop/start Print Spooler to get documents to print?

Thread Tools

Similar help and support threads
Thread Forum
Print spooler deletes documents in queue
Hullo there I'm sorry if this has been covered somewhere, I'm not very good at searches... I press "Print" & the document appears in the queue window for as long as it takes for "deleting" to also appear then it disappears. I've tried all the fixes I can find on the net, completely removed...
Hardware & Devices
print spooler does not always start
i`ve just purchased a hp deskjet 3055a wirelesss printer. its set up to a home network with 3 pc`s using it 1 is xp home, 2 is win 7 hp 32bit and my main machine is win 7 hp 64bit. the last machine is giving me a problem it does not always turn on the print spooler service if i try turning it on...
Hardware & Devices
Services>Error 1503: Cannot start Print Spooler and others
This just started happening this week out of nowhere. Print Spooler will not start. I cannot start it manually. Hamachi (specfically LogMeIn Hamachi Tunneling Engine) service gives the same error. I haven't had any problems with any other services. Upon trying to start the two manually, I get...
General Discussion
All Print Drivers Disappeared, Print Spooler Quits (7 Pro, 64-bit)
I've been using various print drivers for various locations with success for a month with my new laptop. Today, all drivers gone. Loading new ones doesn't work. Print spooler is not "started;" it starts successfully, then is not "started" next time I look. Other possibly relevant information: HP...
Print Spooler
I have installed a hp laserjet p1006, with windows 7 x64 drivers. Printer shows installed, says working, but when attempting to print, all it shows is that document is spooling, then nothing happens. Checked windows system 32 printer file, nothing there. Does anyone have any suggestions. I have...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:26.
Twitter Facebook Google+