Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: PC starts , but no screen.

07 Mar 2011   #1
Emforcer46

Windows 7 Ultimate 64x
 
 
PC starts , but no screen.

So since this forum helped me once i have trust it will do it again , now the serious part/
My pc starts but screen doesnt show , i checked power supply , it seems to be running. cpu and gpu both do , rams are running i hear the beep and rams have a light so i can see them.
what should i do ?


My System SpecsSystem Spec
.
07 Mar 2011   #2
baarod

El Capitan / Windows 10
 
 

Quote   Quote: Originally Posted by Emforcer46 View Post
So since this forum helped me once i have trust it will do it again , now the serious part/
My pc starts but screen doesnt show , i checked power supply , it seems to be running. cpu and gpu both do , rams are running i hear the beep and rams have a light so i can see them.
what should i do ?
1) Make sure monitor is plugged into power and signal and is switched on.
2) Plug monitor into different computer to make sure it's working.
3) Reseat GPU.
My System SpecsSystem Spec
07 Mar 2011   #3
Emforcer46

Windows 7 Ultimate 64x
 
 

Quote   Quote: Originally Posted by baarod View Post
Quote   Quote: Originally Posted by Emforcer46 View Post
So since this forum helped me once i have trust it will do it again , now the serious part/
My pc starts but screen doesnt show , i checked power supply , it seems to be running. cpu and gpu both do , rams are running i hear the beep and rams have a light so i can see them.
what should i do ?
1) Make sure monitor is plugged into power and signal and is switched on.
2) Plug monitor into different computer to make sure it's working.
3) Reseat GPU.
same
but pc suddenly stopped b4 this
My System SpecsSystem Spec
.

07 Mar 2011   #4
baarod

El Capitan / Windows 10
 
 

Quote   Quote: Originally Posted by Emforcer46 View Post
Quote   Quote: Originally Posted by baarod View Post
Quote   Quote: Originally Posted by Emforcer46 View Post
So since this forum helped me once i have trust it will do it again , now the serious part/
My pc starts but screen doesnt show , i checked power supply , it seems to be running. cpu and gpu both do , rams are running i hear the beep and rams have a light so i can see them.
what should i do ?
1) Make sure monitor is plugged into power and signal and is switched on.
2) Plug monitor into different computer to make sure it's working.
3) Reseat GPU.
same
but pc suddenly stopped b4 this
Explain? So computer starts but nothing displays on the monitor and the suddenly shuts down by itself? If so that's a power supply that's gone bad.
My System SpecsSystem Spec
07 Mar 2011   #5
Emforcer46

Windows 7 Ultimate 64x
 
 

Quote   Quote: Originally Posted by baarod View Post
Quote   Quote: Originally Posted by Emforcer46 View Post
Quote   Quote: Originally Posted by baarod View Post

1) Make sure monitor is plugged into power and signal and is switched on.
2) Plug monitor into different computer to make sure it's working.
3) Reseat GPU.
same
but pc suddenly stopped b4 this
Explain? So computer starts but nothing displays on the monitor and the suddenly shuts down by itself? If so that's a power supply that's gone bad.
you got it wrong . before this event with no screen . the PC used to stop by itself no warning , in this state it can run
edit; i got a gtx 280 . i think thats the problem my PS is 450w 80+ bronze. there was a light on my card that used to be green now its stopped , but the fan works
My System SpecsSystem Spec
07 Mar 2011   #6
baarod

El Capitan / Windows 10
 
 

Quote   Quote: Originally Posted by Emforcer46 View Post
Quote   Quote: Originally Posted by baarod View Post
Quote   Quote: Originally Posted by Emforcer46 View Post

same
but pc suddenly stopped b4 this
Explain? So computer starts but nothing displays on the monitor and the suddenly shuts down by itself? If so that's a power supply that's gone bad.
you got it wrong . before this event with no screen . the PC used to stop by itself no warning , in this state it can run
edit; i got a gtx 280 . i think thats the problem my PS is 450w 80+ bronze. there was a light on my card that used to be green now its stopped , but the fan works
Does the computer have on-board video you can try? If so pull the gtx280 and connect to the onboard. Also, if the fan is running on the gtx280 it could be the auxiliary power plug(s). Make sure those are firmly seated. If it still won't start, try using a different set of cables coming from the power supply to plug into the gtx280.
My System SpecsSystem Spec
07 Mar 2011   #7
Emforcer46

Windows 7 Ultimate 64x
 
 

Quote   Quote: Originally Posted by baarod View Post
Quote   Quote: Originally Posted by Emforcer46 View Post
Quote   Quote: Originally Posted by baarod View Post

Explain? So computer starts but nothing displays on the monitor and the suddenly shuts down by itself? If so that's a power supply that's gone bad.
you got it wrong . before this event with no screen . the PC used to stop by itself no warning , in this state it can run
edit; i got a gtx 280 . i think thats the problem my PS is 450w 80+ bronze. there was a light on my card that used to be green now its stopped , but the fan works
Does the computer have on-board video you can try? If so pull the gtx280 and connect to the onboard. Also, if the fan is running on the gtx280 it could be the auxiliary power plug(s). Make sure those are firmly seated. If it still won't start, try using a different set of cables coming from the power supply to plug into the gtx280.
No on board , its an M2N-e
gtx 280 is using a 6 and 8 pin cables , also that magic little light , was running all the time , so i think its my PSU , i had to order a 8 pin cable because my PSU only had 6 pin one , i to order 8 pin one , so i dont really have other cables ,i might arrange them dffenrent order
My System SpecsSystem Spec
07 Mar 2011   #8
diehrd

Ultimate 7
 
 

Does it display the bios as it boots ?
My System SpecsSystem Spec
07 Mar 2011   #9
Emforcer46

Windows 7 Ultimate 64x
 
 

Quote   Quote: Originally Posted by diehrd View Post
Does it display the bios as it boots ?
did you read the first post ?
screen doesnt show anything its black , once the yellow light which was supposed to be green
My System SpecsSystem Spec
07 Mar 2011   #10
diehrd

Ultimate 7
 
 

Your first post left enough out for me to ask what i asked.

Pull card and see if you get an error beep when you power up if you do , pull the power on every thing except 1 stick of ram , cpu and video card and see if that allows you to get a video signal
My System SpecsSystem Spec
Reply

 PC starts , but no screen.




Thread Tools




Similar help and support threads
Thread Forum
the laptop starts but ends with a blue screen
helo! The problem is that I can not get into the laptop. I have tried safe mode without any luck, I just cant get in. the same goes when I choose ''Start Repair'' a blue screen or with the repair menu stuck. I also tried with a windows 7 cd and comes to the point of asking me to choose...
BSOD Help and Support
Screen Saver never starts
I have a brand new computer. It is an HP Compaq Pro 6300. I run Windows 7 Pro. My screen saver and my power settings never kick in. I have searched the internet for answers. Nothing I tried has helped. I had a session with HP tech support, they couldn't figure it out. It is annoying to have...
General Discussion
Computer screen suddenly starts ghosting
Good day to you all and i thank you for taking time to look at my dilemma . I am not sure whether this qualifies as a crash problem as i have never encountered a BSOD but i suspect that it is the closet sign to it. Well i have an hp pavilion g7 1251si laptop with i5-2430M 4Gb RAM 64bit OS win 7...
BSOD Help and Support
Blank screen comes when starts for sometime
When I start my laptop,after welcome screen before opening the desktop screen there comes blank screen in black colour for about 30 seconds. What is the problem with it ? pls guide . However I have Dell n5110 core i7 4 gb ram 500 gb gard disk 1 gb nvidia graphic card
Performance & Maintenance
Windows 7 Installation, Starts then nothing but mouse & screen
Hi all I'm probably being thick and really would appreciate being pointed in the right direction. I currently have Windows XP SP3 installed on drive C Drive D is empty - Used to have Windows XP Drive E is my data drive. I put the Windows 7 64 Bit DVD in, it boots up and states loading...
Installation & Setup
Media Center starts on wrong screen
I have a dual screen setup (PC & TV) & just upgraded from mce2005. Whenever mce2005 started up, media center automatically displayed on my tv screen rather than my pc monitor. With Windows 7 it seems to display on my PC monitor at startup, even though I have dragged it onto the tv screen the...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:16.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App