Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Stumped - Add Device or Remove Device Not Working

12 Mar 2011   #1
Casperrr

7 Premium X64
 
 
Stumped - Add Device or Remove Device Not Working

HI

I have searched high and low for a resolution.

OK.
When I went to add a new Bluetooth keyboard (Control Panel>Add Devices).
When pressing Add Device, nothing happens.

I have two Bluetooth devices already installed, are listed under "Devices" are "found" and work fine.

Problem is that, I can not either add new devices or, remove any of my Bluetooth devices already installed.
Click Add Printer - fine, the wizard starts.
Add Device - nothing.

"Remove Device" - when a device is highlighted for removal, the system appears to be "working" for a moment, but then does not remove the device, it remains.


Have checked that Services related to Bluetooth have not been disabled but am wondering if anyone knows if there are any specific services that would be required for Add Devices or Removal of Devices to function? (HID Devices and Plug and Play are Started / Automatic)

Thanks for any help.


My System SpecsSystem Spec
.
12 Mar 2011   #2
Ponmayilal

Windows 7 Ultimate 32bit
 
 

Just a blind shot. Try MS Solution Center Microsoft Fix it Solution Center: troubleshooting software issues . In the "Select problem area" choose " Install or Upgrade Software or Hardware" and click on " Run Now - Hardware devices are not working or are not detected in Windows". Do report whether it resolved your problem or not.
My System SpecsSystem Spec
12 Mar 2011   #3
Casperrr

7 Premium X64
 
 

Thanks for the reply -
Will go and check now.

Forgot to add that, prior to the reported problem, I had installed a new hard drive using a complete image from another drive.
Dont see what that would change but worth adding.
My System SpecsSystem Spec
.

12 Mar 2011   #4
Casperrr

7 Premium X64
 
 

HI again.

When I got there and got to the
" fit it" .exe,I recognized it and have tried it.
I get an error, "The Command Line Argument is Invalid" when prog starts to run.



error code: 0x80004003

Looks like a reinstall of Windows is in my future.

What keeps puzzle'n me is that the problem appears isolated to only "Add Device or Remove Device" starting and that the currently installed devices are working fine and can be turned off and on..

Well, thanks for the lead.
Will update if solution is found.
My System SpecsSystem Spec
25 Mar 2012   #5
arvindgad

windows 7 home premium
 
 

I also have the same problem.Currently installed devices are working fine but not able to add any new bluetooth devices.Please let me know if you found any solutions.
My System SpecsSystem Spec
Reply

 Stumped - Add Device or Remove Device Not Working




Thread Tools




Similar help and support threads
Thread Forum
NAS device shown as UPnP Media Device not Storge Device in Explorer
I have three NAS units on my home network - WD My Cloud 6TB, WD My Book Live Duo 8TB and Seagate GoFlex Home 4TB. The two WD units show up as storage devices but the Seagate shows up as a UPnP AV device. This means I cannot see or access any of the folders. I can only get to it thru Window Media...
Network & Sharing
Forget/remove unpaired Bluetooth device WDM shows BT Peripheral Device
I paired Microsoft Designer Bluetooth Keyboard and Mouse to my Windows 7 Professional x64 HP ZBook 14 which is connected to my company's corporate domain. Everything worked beautifully until they had to re-image my PC to resolve a disk encryption issue. That issue is resolved, but I have had bad...
Hardware & Devices
"USB Device Not Recognized" but the device is working fine.
This has become a great annoyance to me. Whenever I have my keyboard and mouse plugged into my computer (the mouse uses a USB port on the KB (it's a G-15)) I keep getting messages of "USB Device Not Recognized", however, the mouse and keyboard work perfectly fine. It's not really a problem, it's...
Hardware & Devices
Device manager does not detect sound card. Experienced builder stumped
I recently reformatted my system, and ever since my computer refuses to recognize my sound card as installed. You can see my system specs in my profile, but it is a Soundblaster Xtreme-Music card. I've updated and double checked all of my mobo drivers and I still cannot for the life of me get this...
Hardware & Devices
How do I get Stereo mix working when usb device is default device?
Hi guys, so I did some tweaking around in Sounds and Realtek HD Audio Manager, and I finally got stereo mix working. There's only one catch. It only picks it up if my default device is Reaktek HD Speakers. I tried setting my USB headset as the default device, since I never use my monitor's built in...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:06.
Twitter Facebook Google+