Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: hard drive acting strange while copying

23 Mar 2011   #1

windows 7 ultimate x64
hard drive acting strange while copying

i tried to search for help but i cannot find an exact topic..

i bought a 2TB mybook, conneced through firewire 400.

i moved 100GB from this internal:
488GB Western Digital WDC WD5000AAKS-22TMA0 ATA Device (SATA)
to the mybook.
it moved the files quickly (30MB/sc.).

but from now on, when i try to copy files back to the WD500, it get's slow and almost stuck at a ridiculously slow speed.. (3 hours for 20GB ???)
it never done this before.
tried to restart, but it acts the same with no change.
cpu is free.
apart from that, the WD500 acts fine, i can play heavy video files etc..

what happened? (i listed my specs in profile)

* it seems to have this problem ONLY when copying files from the Mybook.
tried to copy from another internal and it copies fine (60MB/sc.)

how come i can transfer files FROM the WD500 to the Mybook, but not vice versa ?

thanks in advance.

My System SpecsSystem Spec
23 Mar 2011   #2


I had very similar issues with the MyBook that I purchased except it was with the esata connection. Sometimes I couldn't get the drive to recognize unless I rebooted with the drive plugged in. There were posts out there saying it was because of the esata cable and you should "trim" the cable shroud with a razor knife so that the connection made it all the way into the MyBook. Really WD? Sometimes the drive would even go into a sleep state right in the middle of a transfer causing delayed write failures. Transfer speed was NEVER consistent for me and often seemed way too slow to be "normal". WD support was no help. They tried selling me different esata cables and cards which was unacceptable to me. I knew my hardware worked just fine.

In the end I bought a $30 esata dock from NewEgg and carefully ripped my hard drive out of the MyBook. Put the drive in the newly purchased dock, it's been rock solid ever since, same esata controller, same esata cable. For me, the moral of my story was, the MyBook really was horrible all around to work with. I know people that have had these and never had an issue, guess I was not one of those people.
My System SpecsSystem Spec
23 Mar 2011   #3

windows 7 ultimate x64

oh no.. c'mon, i just bought it
and i thought Esata will even be faster!
why should there be any reading issues when copying? it acts perfectly normal when using it...

*the USB2 works fine... so why did i bother invest in a Esata compatible??
i thought it suppose to be a faster connection than USB2, better for editing HD, no?
it sure costs more money.
should i return it? will they accept it (reason: Esata connection faulty) ?
My System SpecsSystem Spec

23 Mar 2011   #4


My issues were over the span of about 8 - 10 months roughly so it's a bit different than yours. If you just bought it and are able to return it, personally I would. But again my experience was not the same as others, it's kind of your call. Perhaps some others here could share and offer some advice on this as well. There are some incredibly smart people on these forums. You may want to not be hasty and see what some others have to say/offer before you decide to take an action in a particular direction.

Good luck :)
My System SpecsSystem Spec
23 Mar 2011   #5

windows 7 ultimate x64

thanks for your reassuring words..

i just have to start editing this huge project and i'm a bit stressed.
and the Esata supposed to be faster than USB2, no?
so if it's plain rubbish so why did i waste the money?
My System SpecsSystem Spec
24 Mar 2011   #6

Windows 7 Ultimate (x64)

rozroz, eSATA is definitely faster than USB2, no doubt about that, faster than FireWire as well. However, when it comes to specific devices, things may or may not be properly implemented.

For example, I have an old Seagate external hard drive. When I connect it to my laptop's built-in eSATA port, the speeds are well into 100 MB/s (as reported by Windows). Now, my desktop does not have a built-in eSATA port, instead I have a PCI-e add-on card. Here I have some problems with drive recognition and the speeds vary between 20 and 50. On the other hand, USB2 is hardly ever faster than 20.

Recently, I was looking for a new external hard drive for myself and I would not buy a drive without eSATA connection. However, given the appearance of USB3, eSATA drives are relatively rare. I am starting to think that an eSATA enclosure, for example such as TCG was talking about, is the way to go. After all, any external hard drive is just a regular hard drive already packaged into a nice enclosure (personally I never use the software that comes with those drives).

Finally, for your specific issue, I am not sure what's causing it. If you bought the drive recently, I would definitely exchange it. If, however, the problem persists, I would examine your system (drivers, etc.) as I doubt you'd be so unlucky as to get more than one defective drive in a row.


What you're reporting as a slow speed comes up to roughly 1.9 MB/s. I've seen speeds like that with USB2. Try to check what your antivirus is doing during these transfers. Also, sometimes it's just Windows, maybe someone else will know more about what Windows is doing during the file copy process, but to be honest, I am rather unhappy with how copy is implemented in Windows 7.
My System SpecsSystem Spec
24 Mar 2011   #7

windows 7 ultimate x64

well i'm doing some tests:
it seems the firewire was the main problem. beware of firewire 400.
the usb2 is ok, but there were troubles disconnecting the HD. exporer has froze and had to shut down.
i'm trying the Esata with a fresh cable now. seems to work fine at the moment (100MB/sc.)

what the Esata connect regulations? do i only connect while computer is turned off?
or i can freely connect/disconnect all the time (as in USB)?
My System SpecsSystem Spec

 hard drive acting strange while copying

Thread Tools

Similar help and support threads
Thread Forum
Hard drive acting funny and will not defrag.
When I try using Auslogic Bootspeed defragmentation the following error occurs: "Your disk might contain errors. Run the check disk tool to check the volume for errors and fix them. However when I do it freezes up at stage for 62% I believe. I have also tried using sfc/scannow and it says...
Hardware & Devices
copying to external drive yields strange error
I am copying "stuff" to my new 4TB external HDD = F:\ >> from an internal drive Z:\ Things seem to go OK for a while, then I get this error message ========== Could not find this item This is no longer located in F:\Video. Verify the item's location and try again. ========== If I attempt...
General Discussion
Bluray drive acting like a hard drive?
This is a newer build with a Liteon Bluray burner. I don't know when this happened but when I clicked on "computer" the bluray drive name had changed from "BD-RE Drive (D)" to "BD-RE Drive (R) Audio CD" (The drive name change of D to R is my doing, I tried un/reinstalling the drive many times and...
Hardware & Devices
Internal Hard Drive acting like an External Hard Drive
Hi guys, I'm new on any sort of forums so go easy if it's a stupid question..but here goes. Me and my brother built me a new computer from scratch (he did the building - i did the watching). To cut a long story short - I purchased an internal hard drive from Overclockers UK. It's a Samsung...
Hardware & Devices
"0x80070057" Error copying files from hard drive to hard drive??
"0x80070057" error. I was simply trying to copy a folder or group of files to another hard drive. Hard drive to Hard drive, no SSD or External was involved. Any solutions to this issue? It literally refuses the copying to be performed ... I'm trying to copy folders/files from a Seagate...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:21.
Twitter Facebook Google+