Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Messed Up Partition Table -- HELP

05 Jul 2009   #1
crdnilfan

Windows 7 Build 7600.16834 x64
 
 
Messed Up Partition Table -- HELP

Currently I'm running off a live ubuntu CD, because something went horrible wrong...

I had 4 partitions, a 100GB windows 7 partition, a 10GB ubuntu, 20GB OSX, and 160GB for storage. I wanted to set up time machine, because it seemed I messed up my OSX drivers a lot, so I went into windows to shrink my storage driver by 5GB and then use that for a time machine backup drive. I shrunk the drive, and when i went to allocate the 5GB to a FAT32 partition, it told me it was change the partition from a basic to dynamic disk, and because I knew exactly what that meant, and had worked with it before a number of times (more than 4 partitions on a single physical drive) I clicked ok. It failed, both my ubuntu and OSX partitions were now in RAW format, although my storage and Windows 7 partitions were still left in NTFS. It was about 2AM at this point, so i shut down my system for the night, thinking I could handle it better thinking clearly in the morning.

Turn system on, Grub failed to load, Ugh, ok. Boot into ubuntu live CD to reinstall Ubuntu and Grub, parition editor shows that I have only 3 partitions now. 1 named Windows 7, 997 KB big in an unknown format, yes KB. a Ubuntu partition thats 100GB formatted NTFS, and a driver named Mac OSX 180GB big also in an unknown format.

But, I can mount my Windows 7 partition in Ubuntu, and when I mount it, and click properties, it tells me its and 100GB NTFS partition, but at the very same time, the partition editor tells me its an Unknown format 997KB partition. The parition editor doesn't ever say i have a storage driver, and yet I can mount my 160GB storage drive with all files intact.

How can I fix the, what i'm assuming the problem is, the partition table??


My System SpecsSystem Spec
.
05 Jul 2009   #2
Robert Cartman

Windows 7 RTM x64
 
 

I'm not sure that the partition table is bad, may be just the linux and the OSX can not recognize the 5th partition on one disk.
My System SpecsSystem Spec
05 Jul 2009   #3
crdnilfan

Windows 7 Build 7600.16834 x64
 
 

I've used Linux with 8 partitions before, so I know thats not the issue, and that still doesn't explain the conflicting reports on the driver size, Partition Editor says /dev/sda1 is 997 KB while Ubuntu's built in explorer says /dev/sda1 is 100GB.

As well as the inability to read the filesystem for certain partitions, even though they're clearly defined (and data can be read).
My System SpecsSystem Spec
.

Reply

 Messed Up Partition Table -- HELP




Thread Tools




Similar help and support threads
Thread Forum
The partition table does not have a valid system partition
Hi all after fitting a sata card my computer wouldn't reboot?, i'm running a dual boot system with easy bcd with win 7 ultimate as default and win 8.1 so i put in my win 7 installation disk and boot from that first time round i see win 7 in the box to select but didn't because a new window...
General Discussion
partition table issue - win7 hidden partition formatted
Hi friends. I just encountered a serious issue. I was about to reinstall Win 7. I used a tool in Hiren Boot CD and formatted c:, and then i accidentally formatted the 125MB partition created by win 7. my HDD was partitioned as C, D, E, F. now i can access only C and D, E is shown as RAW...
Installation & Setup
The partition table does not have a valid system partition. Pt2
Hi guys. I'm back breaking my pc again. Ok, so it looks like I'm running into a similar problem to what I had back in November. However this came about in a different way. This time I was attempting a bios update via asus update utility tool. The reason for the update was that I was looking to...
General Discussion
The partition table does not have a valid system partition
OK, one of two things has screwed up my pc. 1. I opened my pc to clean all the dust bunnies, which I do every 6 months (customer pc from 07). I installed two new 2 tb western digital caviar blacks I got from target via the essentials deal. 2. A few hours ago I extended the volume of my e:...
Installation & Setup
Partition Table doesn't have valid System Partition
Few days back did a Win 7 Pro OEM clean install on a home built PC. Looked great. Installed chipset drivers. Set up my drives and volumes using disk management. Shutdown and on a cold start next AM Win 7 won't boot. Last line on BIOS screen says "boot mgr missing". Drat!! Booted to Win 7 install...
Installation & Setup
Partition table messed up?
Im having some problems putting windows 7 on my iMac. At first, it worked fine. But i lost the reinstall disk so i made an image backup on my external hard drive. Before, i was triple booting Ubuntu, OS X, and Windows 7. I had a huge problem in windows so i restored from a backup. But now, my...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:27.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App