Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unique Windows 7 USB flash problem

05 Apr 2011   #1

Windows 7 Professional 64bit
Unique Windows 7 USB flash problem

Hi all,

I've a new computer at my work, it's an AMD Phenom II X4 965 @3.4 GHz with 8 GB of RAM and Windows 7 Professional 64 bit on it. I also have a flash drive (Corsair Voyager 4 GB), that has worked perfectly until now.

The problem:
The first time I plugged in my Corsair, it showed up and Win 7 prompted the usual "scan & fix", which I boldly ignored and proceeded to continue without scanning. What followed up was a blank screen and my PC rebooting. I was surprised, as this had never happened before, I presume my flash drive was not infected since I've been using it on different computers, my home computer and other work computers (all of which have antivirus software). Either way, after the reboot, the flash drive wouldn't show up as an accessible disk. It could be found as a device, it showed up in Disk Management with it's 4 GB, but it didn't allow any operations (no formatting, no volume deleting, no drive letter changing).

I tried it out on different PC's, both Win XP as well as Win 7, and it works perfectly on other computers. I formatted it on a different PC (as the one I'm running prohibits any actions with the flash drive) as FAT32 and still nothing. Tried formatting as NTFS and still nothing. Bear in mind that this PC still accepts any other flash drive and my Corsair Voyager still works on any other computer, so it's something in correlation between that flash drive (which has been formatted 3x now, to FAT32, to NTFS and back to FAT32) and this workstation.

Any help is appreciated. I'm tending to believe that this has got to do with me cancelling it's "scan & fix" prompt at the very first time I plugged it in, and Windows 7, perhaps, ID banning that flash drive? I'm only theorizing as I am no expert. Could this be reset by tinkering with the registry?

My System SpecsSystem Spec
05 Apr 2011   #2
Orbital Shark


Hi, welcome to the forums :)

You may want to try to Uninstall the device from Device Manager and rebooting the machine.
Note   Note
If you get the option, check the Delete the driver software for this device box as this will force Windows to completely re-install the device (including any Windows Update interaction)

If you have any data already on the device then I'd advise backing it up on another machine as the Scan & Fix may prompt you for a format.

My System SpecsSystem Spec
05 Apr 2011   #3

Windows 7 Professional 64bit

I believe our sysadmin tried that before, and I tried it again just now. It does install the drivers on reboot and it says that Corsair Voyager is now up and running, but it's not found on My Computer. As before, I can see the device itself and I can see the disk in Disk Management, but it's still not accessible for use.

We've tried pretty much anything here and I'm starting to think that Win 7 has set up an exception for this flash drive somewhere in it's registry or something similar...
My System SpecsSystem Spec

05 Apr 2011   #4
Orbital Shark


You could try the following...

1, Click and type Troubleshoot then click Troubleshooting
2, Click Hardware and Sound
3, Click Hardware and Devices

Follow the on-screen prompts to see if it detects anything out of the ordinary.

Also, have you used in in a machine with Windows 7 Ultimate/Enterprise that has BitLocker running? If so, you may want to see if it's been Encrypted by accident.
My System SpecsSystem Spec

 Unique Windows 7 USB flash problem

Thread Tools

Similar help and support threads
Thread Forum
I have a UNIQUE computer problem
My PC display in terms of Windows Xp and Windows 7 has the left side of my screen slanted/bent backwards a bit. Instead of the straight-across flawless display I am supposed to have. I've troubleshooted using different monitors, two CRT's and two LCD's, I've used different hard drives, moved the PC...
General Discussion
QuickCam won't download/Unique Problem
Greetings friends. When I first got my computer it had Vista as the O/S. At that time, Windows 7 was not on the market, but very close and because of that, I was promised a free upgrade to 7 after it came out. That happened. One of the first things I downloaded on the Vista was Logitech QuickCam...
Kind of unique HP OEM problem
Hi guys! First off, I kind of feel like a leech, just barging in here and asking questions, but I'm really stumped about what to do here. The story is this: Back in the pre-7 days, I bought an HP-laptop with a 64bit Vista OS. It qualified for the free upgrade to Windows 7, which I of course...
General Discussion
Unique problem
Hello... Im new here, as u can see! Im trying to fix, or at least detect my problem for quite some time now... I have spend hours and hours googling my problem, but i didnt find single thread on the forums or article about problem like mine... So, after many years of good service i...
Installation & Setup
A unique Fallout 3 problem
Hi guys. Just signed up. This seems like a good forum, and everywhere else I've tried has been unable to assist. I think I have a slightly unique problem with F3 to what most people seem to encounter in the threads I have read through - mostly because I cannot get into the game at all and I am...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:13.
Twitter Facebook Google+