Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Cannot Perform ChkDsk

10 Apr 2011   #1

Windows 7 Home Premium 64 bit
Cannot Perform ChkDsk

Hi there! I am new to the forum and could really use some advice. I hope this is the right forum to post in!

I have never run into this problem before and I am pretty computer savvy usually. I have an external hard drive that is a Western Digital 1 TB. Now the problem I have is that when I plug it into the USB into my Emachines notebook computer, it says it needs to perform a chkdsk and that it's recommended, or you can choose not to. Several times I have opted not to chkdsk it, but I have now realized that it really needs to be scanned for bad sectors. When I try to perform the chkdsk it basically freezes and then says it's in use and cannot perform it (after about 20 mins of being on the desktop. I have performed chkdsk's before on my computer's hard drive and it works right away usually. I have restarted it, scanned it for virus's, basically everything I can to try and fix this issue.

I noticed that when I plug my HD into my DVD player, nothing shows up under all of the folders I have on there which is why I realized the chkdsk needed to be done. Oh and also it takes FOREVER for anything to transfer onto it, when it didn't take very long before. Can someone please give me some insight as to what is wrong with my HD and how to fix it please?? I am at my wits end!! Thanks SO much!!

My System SpecsSystem Spec
10 Apr 2011   #2

Microsoft Community Contributor Award Recipient

Windows 7 x64

an external drive shouldn't be given you that behavior.

Things I can think of off the top of my head
1 - windows has activated system restore on it. (you sound like you would know how to disable that)
2 - your antivirus application is attempting to scan the new disc everytime it's connected.
3 - A third system process I haven't thought of is active on the drive (did you install any software it may have come with?)

Anyhow, removing these possibilities I think would clear it up for you and allow chkdsk to run.
My System SpecsSystem Spec
12 Apr 2011   #3

Windows 7 Home Premium 64 bit

Hi Maguscreed, thanks for the reply! I have tried these things that you mentioned above after you suggested them, and nothing worked! I am still unable to run chkdsk! Anything else you can recommend to do? Thanks!
My System SpecsSystem Spec

12 Apr 2011   #4

Windows 7

Mate are u able to access the data in the drive?

If yes copy all the data to another drive....and then via administrator panel...delete the drive...and reformat it.

if u dont know how

control panel>performance and maintainance>administrative tools>computer management>disk management>right click the drive and delete it>then quick format it>voilah you will never see that chckdisk again

source:my self ecperience

My System SpecsSystem Spec

 Cannot Perform ChkDsk

Thread Tools

Similar help and support threads
Thread Forum
Windows tries to perform chkdsk on every boot but fails
Hello everyone. Today my computer froze upon exiting Battlefield 3 and had to shut it down manually. After a lot of problem solving (I had to change the hdd port on the m/b) I am left with the problem displayed in the attached image and cannot figure out what to do. I have searched around and...
Performance & Maintenance
CHKDSK will not clear dirty tag after chkdsk c: /r ?
I have a 2 TB WD BLACK SATA drive in my computer. For a couple of days while I was gone I ran chkdsk c: /r Hoping to clear the dirty tag I get when I run ( fsutil dirty query c: ) When I came back the boot screen was up and I logged in .. the dirty tag is still there. I've run the WD utility...
Hardware & Devices
How to get a log from chkdsk after running chkdsk from the RE?
Hi there, Is there any way to get a chkdsk log from an unbootable computer after you run chkdsk from the Recovery Environment (RE) so it can be posted on a forum? Thank you, Donna :)
Hardware & Devices
Tools Chkdsk with no /f /r says errors, bootup chkdsk says none
AHCI disk. Running chkdsk from Properties Tools with no autofix says there are errors. Dismount the drive and reboot. Chkdsk reports no errors found. Properties Tools Chkdsk still syas there are errors. Auslogics Defrag also says there are errors.
Hardware & Devices
Could not perform this operation because
I just purchased and installed Windows 7 Home Premium on my Toshiba 64 bit computor. It had Vista on it and did not like it from the get go but Circuit City installed it. The problem I am having is when I click on the mail icon on the toolbar I get the following message: could not perform this...
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:40.
Twitter Facebook Google+