Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Lost RAM!!!

14 Apr 2011   #1
Hampshirehog

Windows 7 Home Premium 64 bit
 
 
Lost RAM!!!

Hi all, I have recently purchased my Medion PC and happy I am too apart from one thing. RAM!
The machine comes with 4Gb DDR3 RAM which in the grand scheme of things is not that much really, so I purchased 2x Corsair 4gb sticks too give it a boost, only to find to find that the PC could only see 4Gb.
Using my trusty friend, Google, I found that maybe the BIOS needed looking at, or they could be faulty.
Which brings me here. Anyone know what's going on?
Help would be much appreciated.

Regards
Hampshirehog


My System SpecsSystem Spec
.
14 Apr 2011   #2
andyparks

windows 7 home prem 64 bit
 
 

My System SpecsSystem Spec
14 Apr 2011   #3
jeepmann4x4

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by Hampshirehog View Post
Hi all, I have recently purchased my Medion PC and happy I am too apart from one thing. RAM!
The machine comes with 4Gb DDR3 RAM which in the grand scheme of things is not that much really, so I purchased 2x Corsair 4gb sticks too give it a boost, only to find to find that the PC could only see 4Gb.
Using my trusty friend, Google, I found that maybe the BIOS needed looking at, or they could be faulty.
Which brings me here. Anyone know what's going on?
Help would be much appreciated.

Regards
Hampshirehog

I don't know much about them nor could I find much more than "what on the box" specs..... I did come across a support web site HERE . Looks like you just need to enter your part/SN to get info, also had a downloadable manual (page 55 for bios).
good luck
My System SpecsSystem Spec
.

14 Apr 2011   #4
Xyphus

Windows 7 Pro 64bit, Ubuntu 10.10 64bit
 
 

Are you using a 32bit or 64bit OS? A 32bit OS can only address (up to) 4GB. You need a 64bit OS to address more than 4GB.


***EDIT***
Just saw your OS specs in your avatar area as 64bit... Hmmm... I guess the OS is not the problem...
My System SpecsSystem Spec
Reply

 Lost RAM!!!




Thread Tools




Similar help and support threads
Thread Forum
Lost Hyperlinks in Excel and a lost Internet Explorer 11
Dear Forum After constant stress with online software changing my PC settings (adobe one of many) I wanted to separate my main computer from the internet. This I tried. I turned off broadband. I then removed all my browsers, virus and malware protection and gave my hard-drive a bit of a...
General Discussion
how regain lost session lost favorite file due to currupt
my system window 7 IE 11 ;is set to reopen last open tabs after any reboot etc. this time due to freeze ; I ended task at task manager thereby all open tabs got lost ; were told the folder for them should be favorite htm ;how do I find it ??? saved to favorites file ,renamed and moved...
Browsers & Mail
Lost space on external drive - Lost 1TB of 2TB drive
I have a WD Red 2.0 TB drive (1.8 TB formatted) and have been watching it fill up (%used) for some time now. I have lost 1 TB to "unknown" according to WinDirStat. VSS is NOT RUNNING, which I read about in the tutorial here:...
Performance & Maintenance
Lost my HP Touchsmart LOGO since I lost resetted my BIOS (I guess)
Hi All I have a HP Touchsmart 300-1060a (Home Premium Windows 7 64 BIT) which I bought few years back. Now for the last 6 months or so I started getting issues with my machine was not displaying anything at all after turning it on. So I had to hard reset my power from the machine and then...
Hardware & Devices
Lost Dual Boot Screen?...Lost Windows 7
I have Vista Home Premium 64 bit and I downloaded 64 Bit RC Windows 7 and did a clean install on another partition of my hard drive. Dual boot was working for about 4 days then all of a sudden it doesnt come up any more. The partition is still there with Windows 7 installed on it but its not...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:48.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App