Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Western digital passport 500gb errors

05 May 2011   #11

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

Quote   Quote: Originally Posted by junpol3 View Post
Hi all,
I think we almost have the same problem. Although when I right click on my disk I have the option to change drive letter, format, delete volume, properties and help. But the moment that I clicked on change drive letter I will get the error "The operation failed to complete because the disk management console view is not up-to-date.
You can't change drive letters unless there is a file system on the partition. It's not possible to be a real Windows "drive letter" unless there is a file system.

Note that there is no "NTFS" in the cross-hatched partition on Disk1, whereas there IS an NTFS shown for your other partitions on Disk0.

Instead of trying to change the drive letter from the popup menu for the cross-hatched partition on Disk1, how about trying to FORMAT it first (since you say that option is not grayed out when you right-click). If that works, you should get a Windows drive letter assigned (or be able to assign it yourself... once the file system is installed on the partition).

Worst case, try my suggested Partition Wizard recipe in the post above yours. This will "delete all partitions" on Disk1, and then create new partition, and then FORMAT, and then drive letter. Hopefully.

Safest bet, with highest likelihood of success: boot using the standalone Partition Wizard CD.

I still think the reason everybody is seemingly having these problems is that these USB drives are coming pre-formatted not for Windows but for Mac's (and HFS). They can't be used in Windows unless they're formatted properly... either by the factory, or by manual steps you must take first in order to prepare the drive for Windows and NTFS.

I did a little research on this same type of problem on another thread (where an Iomega USB drive was involved. Here are my findings:


Doing a bit of research, it almost looks like Iomega USB drives ship formatted for Mac's, not for Windows:

"Some Iomega Hard Drives ship formatted Mac OS Extended (HFS+) for use with Mac OS and will not be recognized by Windows until they are reformatted NTFS or FAT32/exFAT. This includes most Iomega FireWire®/USB 2.0 Desktop Hard Drives, the MiniMax Hard Drive, the Iomega UltraMax Hard Drive, and some models of the Portable Hard Drive. If you are connecting one of these drives to a Windows PC, and you do not see the drive in 'My Computer' or Windows Explorer, follow the instructions below to format the drive to NTFS or FAT32. This will allow your computer to recognize the drive."

The procedure described on this Iomega support page describes the usual standard initialization for an MBR disk (under 2TB), as to how to re-prepare the drive for use with Windows. In particular this is the recommended solution if Windows does not assign a drive letter (sound familiar guys?).

NOTE: the DISKMGMT screenshots on that Iomega page look EXACTLY like the one we're puzzled about here, where there is a partition but no file system on it.

Again, strong evidence for why it looks like FORMAT to NTFS could solve the problem... if this is what's been the root problem all along.

I would think Partition Wizard's "initialize to MBR disk" function might accomplish the same result, although FORMAT to NTFS may also be needed afterwards.

Anyway, this is certainly an interesting new piece of information to consider.

My System SpecsSystem Spec
05 May 2011   #12

windows 7 professional 32 bit

Hey thanks man, i deleted the partition made and you were right, it had been setup for mac! was simple to sort out after that, took about 30 seconds :L thanks
My System SpecsSystem Spec
05 May 2011   #13

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

Quote   Quote: Originally Posted by jordanC View Post
Hey thanks man, i deleted the partition made and you were right, it had been setup for mac! was simple to sort out after that, took about 30 seconds :L thanks
Excellent! Glad I could help out.

Could you please post one final screenshot from Diskmgmt (maximized, columns spread so that we can see all text), so that we can see what you ended up with.

Did you delete the other two small partitions on either side of the 485GB partition as well? Did you end up with one large partition using all the available space? Of course, we'll have these answers from the screenshot.

Did you actually have to FORMAT after deleting and then creating? This is the one thing that's not going to be implied by the screenshot from Diskmgmt.

Did you use Partition Wizard, or just Diskmgmt?
My System SpecsSystem Spec

05 May 2011   #14

windows 7 professional 32 bit

There you go I did have to format it after by right clicking it and allocating it. (after unallocating it which is what got me confused) It came up with a formatting wizard and took about 30 seconds
And i just left the 2 smaller partitions on it.

Attached Thumbnails
Western digital passport 500gb errors-untitled.png  
My System SpecsSystem Spec
05 May 2011   #15

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

Quote   Quote: Originally Posted by jordanC View Post
And i just left the 2 smaller partitions on it.
From the screenshot it looks like you "absorbed" that original 128MB unallocated space which was to the right of the big 465.32GB partition which was causing you the problem.

When you deleted the 465.32 partition (making it unallocated) that other 128MB unallocated space to its right simply got combined into one contiguous unallocated space, now available for partitioning.

And then when you created the new partition (apparently specifying "use all available free space), that's how you ended up with 465.44GB (i.e. 465.32 + .128) in your new partition.

The key to success was, apparently, then FORMAT'ing it as NTFS, and you're now home. You've emerged victorious.

However you still left that small 200MB system partition to the left of the new 465GB partition. I don't know what that's for, nor how it got created if you didn't do it yourself.

Also, it's called "EFI System Partition", which I don't know what that means. Perhaps this has something to do with factory formatting for a MAC. It certainly means nothing for Windows, in my opinion. Your "active" partition is the C partition on Disk0. That's where your BIOS boots to.

You don't have the typical 100MB "system reserved" (and "active") partition generally seen on Win7 systems with only one OS, where the Win7 installer puts its boot manager files and which the BIOS boots to, along with the real Win7 system installed into a genuine C second partition.

Nevertheless, this odd 200MB "EFI System Partition" on Disk1 can't possibly be of any use in your environment, in my opinion. I'd like to know how it got created, but beyond that I would rate it of zero value.

Anyway, if you really wanted to do what I would do... I'd delete that 200MB partition, and then re-size the 465GB partition to include this final bit of 200MB on the drive. This would give you one big 465.64GB partition using all available space on the drive.

All very interesting.
My System SpecsSystem Spec

 Western digital passport 500gb errors

Thread Tools

Similar help and support threads
Thread Forum
Western Digital Passport, Password , and Windows PE not playing well.
Wasted quite a bit of time on this already. I called Western Digital , who was clueless. I'm using Macrium Reflect to backup to a WD Passport 2TB drive , with the drive password enabled. The problem is, when you use the Windows PE environment to restore, the "WD Drive Unlock.exe" ...
Backup and Restore
Yet another Western Digital My Passport driver problem
First off, let me just admit that this problem is wholly of my own making. It's my fault for futzing with a perfectly good working situation and screwing it up by messing with drivers. Yes, a cardinal sin in Windows world, I know. But just in case someone out there is an expert willing to help, I'd...
Hardware & Devices
Western Digital My Passport not deducting
Dear All,, Pls. help me any one to solve my problem, I am facing problem after entering my password the drive is not enabling. At the same time I am not able to view my files. Pls. help me how to recover my files from this HDD. S/N: WX41A3018986 Country: India. regards, Muthukumaran R.
Hardware & Devices
WD My Passport Essential 500GB External Keeps Disconnecting from USB3
Hi all, So today i brought a new External hard drive today and started copying files to it (as you do) from my PC (usb2) it worked fine, but then when i connect it to my latop (TOSHIBA satellite L840) it keeps disconnecting within 5 seconds of copying regardless of file size ONLY when its...
Hardware & Devices
Western Digital HDD USB 3.0
I have a question. As all you techies probably know, when you turn on a pc that has an external western digital HDD connected to it, the HDD turns on and off with the computer. Is there a way to prevent this from happening? Reason being, I only back up to it seldom, and I often play loud music;...
Hardware & Devices
Western Digital drives : SMART errors, disappears
Hi, I built a PC with Gigabyte MB and Athlon II X4 620 Processor, with 2x2GB DDR2 800 RAM (Drives: 120GB Fujitsu 5400RPM, 0.5TB WD Black, 1TB WD Green 1TB WD Black. I am facing the following issues 1. Firefox is not responding and slows down the PC for a few minutes, after every 10 mins of...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 14:21.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App