Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Motherboard Diagnostic

06 May 2011   #31
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

You won't find anything as Nvidia dropped all support for the NF4 back in 2008. This is the last driver set they put out for it,

NVIDIA DRIVERS 15.23 WHQL

Seeing as you have the second computer, have you tried any of the supposed bad drives on it? Would help to rule out if it is the drives themselves, or the controller on the motherboard is going.

Quote   Quote: Originally Posted by sygnus21 View Post
Those hard drives may be going, especially if he can't read the SMART info and SMART is enabled in the BIOS.
If I remember correctly that was the norm for the NF4 chipset when the SATA controllers were run in SATA mode and the Nvidia driver was used. I believe that if the default Windows driver was used, then SMART was available (been a while since my NF4 died, but don't remember getting SMART in Vista at least with the Nvidia driver installed).


My System SpecsSystem Spec
.
06 May 2011   #32
seekermeister

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

I just went into the BIOS and found that all 3 of the drives SMART was set at auto, so I changed them to enabled...just for good measure. However, DLG still says that SMART is not available on any of them. Since SpeedFan does have access to SMART data on all three of those drives, it tends to make me believe that this is more of a compatibility problem with the software, rather than hardware or drivers.

I had intended to move that new drive to my external case when I rebooted, but forgot, so that is next on the list.
My System SpecsSystem Spec
06 May 2011   #33
Hopalong X

Windows7 Pro 64bit SP-1; Windows XP Pro 32bit
 
 

Sorry I couldn't be more help.

I hope you get it sorted.
Mike
My System SpecsSystem Spec
.

06 May 2011   #34
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Think you will find that Speedfan can read it for the same reason that it gives those weird temperature readings when you first install it (how many have seen that ever popular -127C), it bypasses the drivers/bios completely and queries the hardware/sensor modules directly. Pretty sure that if you uninstalled the Nvidia SATA/IDE drivers and rolled back to the default Windows driver that SMART would then be able to be read by anything.
My System SpecsSystem Spec
06 May 2011   #35
seekermeister

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

I just moved the new drive to the external case, and it now shows normal SMART data. That seems to indicate that the problem is with the MB and/or drivers.

stormy13,

What are you referring to...the nForce driver?


Attached Thumbnails
Motherboard Diagnostic-dlg2.png  
My System SpecsSystem Spec
06 May 2011   #36
seekermeister

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

As can be seen in the screenshot, three of the items listed under controllers are using Windows drivers. Obviously, the other two are using nForce.


Attached Thumbnails
Motherboard Diagnostic-devman.png  
My System SpecsSystem Spec
06 May 2011   #37
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by seekermeister View Post
What are you referring to...the nForce driver?
Yes. No SMART readings in most programs is due to a combination of the Nforce SATA driver and the NF4 chipset itself. SMART will be read by just about any program as long as you only use the default Windows driver. Also why the you're not getting any readings for teh drives when connected internally, but do when connected externally.

Another thing with the NF4, ever noticed that it doesn't support AHCI or NCQ when run in SATA mode?

enable AHCI on nForce4 (A8N32-SLI Deluxe) with Vista x64 • nForcersHQ.com
My System SpecsSystem Spec
06 May 2011   #38
seekermeister

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

As an experiment, I disabled the first nForce controller (that option wasn't available for the second, probably because it was being used by Windows) and the Maxtor 680Y0MO disappeared in DLG. Therefore it appears that the other controllers with Windows drivers are not being used.
My System SpecsSystem Spec
06 May 2011   #39
seekermeister

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

Quote   Quote: Originally Posted by stormy13 View Post
Quote   Quote: Originally Posted by seekermeister View Post
What are you referring to...the nForce driver?
Yes. No SMART readings in most programs is due to a combination of the Nforce SATA driver and the NF4 chipset itself. SMART will be read by just about any program as long as you only use the default Windows driver. Also why the you're not getting any readings for teh drives when connected internally, but do when connected externally.

Another thing with the NF4, ever noticed that it doesn't support AHCI or NCQ when run in SATA mode?

enable AHCI on nForce4 (A8N32-SLI Deluxe) with Vista x64 • nForcersHQ.com
Correct me if I'm wrong, but the nForce driver is used for more than the hard drive controller, it is also used for the Network Adapters. Yes, I do have a Marvel Yukon controller in addition to the Nvidia one, but the last time that I tried using it, it didn't work. Therefore, unless it is possible to uninstall only the drive portion of nForce, which seems unlikely due to the experiment that I mentioned in my previous post, removing nForce altogether would cripple my system...wouldn't it?
My System SpecsSystem Spec
07 May 2011   #40
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Yes the driver package contains more than just the SATA/IDE driver as you mentioned. To uninstall select the Nvidia Drivers entry in Programs and Features and it will then open an windows where you can pick which or all of the driver components to uninstall.

If you try make sure to have at least a restore point made before you try, just in case Windows decides not to start after.
My System SpecsSystem Spec
Reply

 Motherboard Diagnostic




Thread Tools




Similar help and support threads
Thread Forum
SF Diagnostic Errors
Hi All I tried doing a SF Diagnostic but realized that the program screen has 2 extra buttons, namely DXDIAG and SYSTEM INFO. When I use the GRAB ALL button there is an err and it refuses to go further. I therefore click one button at a time. These are my issues: 1. When I click on DXDIAG,...
Performance & Maintenance
Diagnostic Errors Need Help!!!
I ran diagnostic test on my laptop. I need help with these service errors. 201 - Time : 9/7/2013 3:02:51 AM 1202 - Source : Windows Search Service 1203 - Description : The Windows Search Service has failed to create the new search index....
General Discussion
WMI Diagnostic Tool for 64-Bit
When I execute version 2.0 of the Microsoft's WMI Diagnostic Tool on my 64-bit Home Premium system, I get an 'Unsupported OS version or build #' error. Am I doing something wrong? If the tool doesn't work on 64-bit, is there a similar tool available which will? Thanks!
Software
Frequent BSODs etc. Motherboard at fault? SF diagnostic
Right now, my computer seems "stable" but for several days I was having incredible difficulty getting the computer to operate without BSOD or rejecting the BIOS settings etc I recently got a new graphics card, PSU, and memory. I memtested the memory and it's fine (this is my second set since the...
BSOD Help and Support
Need help with diagnostic and fix
Hi all, I've some weird things happening on my computer and I hope you can help me sort out things. I've a fairly new computer with Windows 7 ultimate X64 and a WD1001 Caviar black hard drive. I've had issues installing applications or drivers in the past (it was taking literally hours) but...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:22.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App