Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Hard drive has 5 parts to it in device manager

08 May 2011   #11
ezeht

 
 

Wait I am looking for the reg tweak now.


My System SpecsSystem Spec
.
08 May 2011   #12
ezeht

 
 

Here ya go. I think this is the right one..>

AHCI : Enable in Windows 7 / Vista

It is more easy than you think and save ya lots of time. I am still confused tho. Is this system running now the os drive is showing but the other drive is not? A format on the second drive should fix that.

AHCI is not really needed but is best and is for sata drives and so they run at their fastest speeds. If this system is running and you already have your second drive running. If you do want ahci support just do the reg tweak.

I think I would turn off my system first and disconnect power and sata cable to my second drive. then reboot and do reg tweak or if going to reinstall your os- just use 1 drive- do not connect the other drive until w7 is good to go and is running and what ever changes you are trying to make to it..
My System SpecsSystem Spec
08 May 2011   #13
ezeht

 
 

I do not know what to say or think now. Your first post said nothing about this being a lap top- I did not look at your system info either. I do not know this info is good for you or not.. Had I known it was a lap top I might not have tried to help- being I know nothing about them..

So I guess your second drive is an external drive [usb maybe]? If plugged in it should be same to format it as if it was an internal drive.

You can skip some info I posted. I did not know this is a lap top..

I hope you get it going like you need or want. Take care..
My System SpecsSystem Spec
.

08 May 2011   #14
seekermeister

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

Those channels are not your hard drive, it is controllers:

IDE/ATA Channels and Resource Usage
My System SpecsSystem Spec
08 May 2011   #15
hollyoaks777

windows 7
 
 

Quote   Quote: Originally Posted by ezeht View Post
I do not know what to say or think now. Your first post said nothing about this being a lap top- I did not look at your system info either. I do not know this info is good for you or not.. Had I known it was a lap top I might not have tried to help- being I know nothing about them..
it's much appreciated your answers mate basically i have only one hard drive intalled and windows 7 is running off it. What you could help me with is if i don't reinstall and format the hard drive will the hard drive cause problems if i don't format it please answer asap as it takes a while to get everything back on my laptop.
My System SpecsSystem Spec
08 May 2011   #16
ezeht

 
 

The os install will prompt you to partition and format during install. If it is running it is already done- unless you made it partition more than 1x?

So if it is running and has 1 partition- or you know the proper partition with the os on it- I think the reg tweak will be faster and should give ya no problems.. But if you have lil stuff programs etc on the os drive you can do a fresh os install that is up to you but will take longer..

I am not sure how this reg tweak will work if you have multi partitions on one drive. I guess the info for the reg tweak explains such things- I did not read it all?

Note in my second photo- system reserve is not really thought of as a second partition- My drive is set up as 1 partition- windows shows it like that- not that I have or on purpose set it up for 2 partitions..

The prob I was talking about before was- if you already installed the os and is in ide mode- you can not just change the bios to ahci and it work- It will not boot and say it can not find the drive or say the boot something or another is messed up.. You have to do it right- either before os install or follow the instructions for the reg tweak.. But even if you do mess up- it will not hurt the drive- you just need to reinstall the os and format and the propoer mode you want- ide or ahci..
My System SpecsSystem Spec
08 May 2011   #17
sygnus21

Windows 10 Pro
 
 

Quote   Quote: Originally Posted by seekermeister View Post
Those channels are not your hard drive, it is controllers:

IDE/ATA Channels and Resource Usage
Exactly +1

Hard drive has 5 parts to it in device manager-capture.jpg

BTW If I wasn't using AHCI in the BIOS I would also have more then two ATA channels shown.


My System SpecsSystem Spec
08 May 2011   #18
ezeht

 
 

Ya some of these other folks can better help ya. I said in my first post unless I am wrong- and can be.

Just trying to be helpful is all. You will get it figured out. I hope so any way..
My System SpecsSystem Spec
08 May 2011   #19
hollyoaks777

windows 7
 
 

I have just done reinstall and formatted my hard drive and its the same lol be up all night reinstalling my progams lol
My System SpecsSystem Spec
08 May 2011   #20
marsmimar

Microsoft Community Contributor Award Recipient

 
 

Quote   Quote: Originally Posted by hollyoaks777 View Post
I have just done reinstall and formatted my hard drive and its the same lol be up all night reinstalling my progams lol
If I may make a suggestion? In an effort to avoid similar problems in the future, once you have your 1545 configured the way you want with all programs, apps, etc installed, invest in a new external hard drive. Here in the Colonies they're selling 2TB drives for under $100 US.

Seagate ST320005EXA101 2TB Expansion External Drive - 2TB, USB 2.0 at TigerDirect.com

Make a system image of your computer and store it on the external HD. Leave the original system image intact and make a new image every week or so. If you ever have to reinstall everything again, restore from the system image of your choice and be back online in about 30 minutes. The original image can be your "master clean install" to avoid the dreaded up-all-night headache. You can use the built-in 7 backup utility or the free Macrium Reflect or Paragon. There are others (paid and free) but these are the ones I've used.

Backup Complete Computer - Create an Image Backup

Imaging with free Macrium

Free Backup Software: Paragon Backup & Recovery (Advanced) Free Edition - Overview
My System SpecsSystem Spec
Reply

 Hard drive has 5 parts to it in device manager




Thread Tools




Similar help and support threads
Thread Forum
WD SES Device USB Device driver not found from old internal hard drive
I have an old Western Digital drive that came with Dell Inspiron One 2305 and replaced it after 5 years. There are some files I need from it now and I'm trying to connect via usb to sata. The WD volume does not show up. I got to device manager and found it listed in in unknown devices and it needs...
Hardware & Devices
EEE pc windows 7 starter to many hard drive parts
hi i have i eee pc i have noticed that my C: drive is only 99.9 gb and the Recovery D: is 122gb and empty i know this is not right but how doi fix it i am running out of space on my C::cry: in disk manigment it says 232.88 gb with 4 diferent partitions only 2 named how can i fix this with no...
Hardware & Devices
Hard Drive shows in device manager, not My Computer
I've spent most of the night searching and cannot seem to find an answer to my problem so I registered with the hopes that someone here may be able to help. I have a NAS set up with two 2TB Samsung Spinpoint hard drives. The hard drives in the NAS were partitioned to have 300GB in a RAID 1 and...
Hardware & Devices
1TB WD USB hard drive failure - is in Device Manager, not initialized
Hi. I was normally using my computer, when I suddenly noticed one of my hard drives disappeared from My Computer. Checked the Device Manager, I get the following. Trying to initialize it throws up this error: http://img714.imageshack.us/img714/3049/ripb.png Seems to spin just fine. Trying...
Hardware & Devices
cant see hard drives in disk management or in device manager.
hi few days back i have completely formated my hard disk with the help of seagate seatool.Then i have installed windows xp sp3. i have made 4 partitions at that time ie. c,d,e,f. After that i have installed windows 7 now i cant see my hdd in disk management or in device manager. both device...
Hardware & Devices
Hard drive hidden in disk/device manager
Hi. I tryed to make a system back up but it keeps failing with error code0x80070002) (windows cant find a backup device) went into disk manager and found that my external hard drive that I had plugged in to make the backup on was present and working fine, the strange thing was that i couldnt see my...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:40.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App