Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Network card has a mind of its own

10 Jul 2011   #21
ha1o2surfer

Windows 7 Professinal x64
 
 

try this -

GO into your wireless router and set it to either G or B ONLY. and set a channel that is safe such as 1 or 11. also go into your wireless card settings in the device manager and set it to use the same channel (if possible) and band (usually possible with MOST wireless cards) as you did on your wireless router. see if that works.


My System SpecsSystem Spec
.
10 Jul 2011   #22
Swifty

Windows 7 x64 Professional
 
 

I had uninstalled my other software from my 5 year old wifi card and installed the new drivers that came on a disc with the D-link wifi card, but it kept having conflict with window's automatic internet connection tab at the right corner and it would disconnect, connect, disconnect so I decided I am not going to deal with this and took it back the next day, and Halo I cannot get access to the router as it is not mine and there are about 5 other computers/Laptops connected to the router I would not want to screw any ones connection.
My System SpecsSystem Spec
11 Jul 2011   #23
alphanumeric

Windows 10 Education 64 bit
 
 

OK, the D-Link setup must have glitched. On my XP PC the D-Link utility would turn the Windows Wireless Config off and install its own utility. I didn't like the D-Link utility much and figured out how to kill it and turn the windows service etc back on. I haven't used the D-Link utility since then. It sounds like the D-Link utility and the windows WIFI utility were both on at the same time and fighting for control. Not a good thing.
My System SpecsSystem Spec
.

11 Jul 2011   #24
Swifty

Windows 7 x64 Professional
 
 

No I kinda figured that was the problem but still I did not like the wifi card only having 1 antenna and it was Wireless N 150 I believe, which was not good for what I want to do with my computer.
My System SpecsSystem Spec
11 Jul 2011   #25
alphanumeric

Windows 10 Education 64 bit
 
 

You couldn't pay me to use any N-150 gear. If you are going to buy new you may as well get something that supports true N, not something crippled to run at half speed. Dual antennas are good too assuming your router supports MIMO. I'm running with 3 on my router and wireless card. Anyway if you are the only one having problems it not likely a router problem. I'll go back to my original suggestion, re-install windows and or buy a new WIFI adapter. If it is a windows glitch you might be able to fix it without a re-install, but if you add up the time you're spending trying to fix it it may be quicker to just start over with a clean slate. I can do a clean install in a couple of hours. YMMV
My System SpecsSystem Spec
12 Jul 2011   #26
Swifty

Windows 7 x64 Professional
 
 

Well I bought a new networking card the D-Link N300 Extreme I believe it is 3 antenna's it works so much better I can finally keep a connection, the utility sucked I uninstalled it from my computer, and now I can connect to my internet! thankfully!
My System SpecsSystem Spec
12 Jul 2011   #27
alphanumeric

Windows 10 Education 64 bit
 
 

My D-Link router and wifi card are 300 N extreme. I haven't had any problems to realy complain about in quit a while now. If you download the latest driver you should end up with a setup.exe file and a driver folder. If you manually install the driver and point windows to the driver folder you can skip installing the D-Link utility all together. I only even save the driver folder to my USB thumbdrive.
My System SpecsSystem Spec
12 Jul 2011   #28
Swifty

Windows 7 x64 Professional
 
 

yea I had to copy the disk to my thumb drive in order to get my internet because my cd/dvd drive won't work, but the utility messed up my connection, but now that I no longer have that utility it works perfect! thanks for the help as well Alpha! great to have a Canadian buddy here :P
My System SpecsSystem Spec
12 Jul 2011   #29
alphanumeric

Windows 10 Education 64 bit
 
 

My System SpecsSystem Spec
12 Jul 2011   #30
LiquidSnak

W7 Professional x64
 
 

I had the same problem with the Dlink 150, and switched to a different card. I just think they are low quality.
My System SpecsSystem Spec
Reply

 Network card has a mind of its own




Thread Tools




Similar help and support threads
Thread Forum
Inconsistent networking problems, unrelated to network or network card
Hi folks, This forum has been extremely helpful for me in the past, so I'm testing your awesomeness once again. I've had an unusual networking problem for about a year and a half. When browsing the web, certain requests will just never complete, on any browser. Downloads are often...
Network & Sharing
How to limit network traffic speeds with a network card?
I'm not sure if I'm trying to do the impossible but I'll explain the situation. I have this roommate that is excessively consuming the majority of the networks bandwidth. I've blocked all service ports except for 443, 80, and a few other ones used for every day task. The problem is that he is...
Network & Sharing
Will adding a 2nd network card improve local network transfer speed
This sounds really noobie of me but is it possible to improve local network transfer speed by adding a 2nd network card. I was planning to connect one exclusively for lan transfers and another one hooked to a separate wireless router. Right now only a maximum of 3 users can stream SD videos off...
Network & Sharing
Cannot Setup Wireless Network (Belkin N1 Network Card)
I'm trying (desperately) to set up my network on Windows 7, but have hit a bump in that it just cannot find my network. I checked Device Manager to see if the card was found - it was with a troubleshoot exclamation point on it. I removed the card, used the installation disc and am not able...
Network & Sharing
Mind boggling network problem -"Doesn't have a valid IP configuration"
Hi everyone I've run into a problem that I really don't understand and I was hoping somebody here could help me. First a little background so you can understand the situation. My set up is that I live in a two story house and have my cable modem and a D-Link ethernet switch in my den on the...
Network & Sharing
Network card name reporting incorrectly in wireless network list area
My rig uses a Centrino Advanced-N 6230 wireless mini half-card. It reports the correct name except within the wireless network list. Instead of 6230 it reports 6320. I searched the registry to see if I could find the error, but nothing found. It's only a nuisance, and a minor one at that. ...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

İ Designer Media Ltd

All times are GMT -5. The time now is 07:06.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App