Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB ports worked in XP not in 7

01 Jun 2011   #11
swarfendor437

Windows 7 Professional (upgrade) 32-bit
 
 

Quote   Quote: Originally Posted by James Colbert View Post
I've not heard of a Win7 flavor that must have be upgraded from a running XP install, but if that limitation is in place, might there not be others? The fact that the card also doesn't work makes me supicious. Have you investigated the possibility that there is also a USB port limitation?
Just to update - this machine that the USB PCI card works in is a lot older than the new one (Asus A7V333 with 2700 memory in it (2 sticks of 256 Mb and 1 stick of 512 Mb), Athlon 1700 (1.4/5 Ghz) 300W Power Supply, nVidia 5700LE card)


My System SpecsSystem Spec
.
01 Jun 2011   #12
swarfendor437

Windows 7 Professional (upgrade) 32-bit
 
 

Quote   Quote: Originally Posted by essenbe View Post
Quote   Quote: Originally Posted by swarfendor437 View Post
Quote   Quote: Originally Posted by James Colbert View Post
I've not heard of a Win7 flavor that must have be upgraded from a running XP install, but if that limitation is in place, might there not be others? The fact that the card also doesn't work makes me supicious. Have you investigated the possibility that there is also a USB port limitation?
Hi James,
Thanks for your post.
1. The software was from 'Software4students.co.uk' - both my children are in full-time education and they qualified for the upgrade to Windows 7 Professional 32-bit edition and the only way it will install is if Windows XP is present on the machine - you can't do a clean install - you can however afterward (as I did on this machine) remove XP then move the Win 7 partition to where the XP one was.
2. I cannot understand why there should be a USB limitation - there are 4 usb ports on the back and two at the front of the case - all active under XP not in Windows 7.

Quote   Quote: Originally Posted by essenbe View Post
Take a look at this tutorial Clean Install with a Upgrade Windows 7 Version also go to MSI website find your board and download the drivers for windows 7.
Hi esenbe,
Thanks for the link - I'll take a look later. Regarding MSI site - they have a forum I joined and all you get (like someone else who had a similar issue) was "They should just work"!!! As I stated in earlier post, MSI mobo CD - when you clicked on USB2 drivers it posts a link to the now defunct Windows XP Service Pack 1/1a which is no longer valid (as now upto SP3/4).
Trust me, I am quite aware of the MSI forums. But, on the msi website you should be able to find your board and download drivers by OS. I would try to find it for you if I knew the model# of your board.
Hi essenbe,

Been a while since I checked out the MSI site which is now new - found this page:

http://www.msi.com/product/mb/K8T-Ne...&os=Vista%2032

They only appear to have produced drivers for Vista - I know some Vista drivers run on 7 (which is Vista 6.1 really!) - so should I be ok with installing these do you think? I have downloaded all of the drivers for consistency (VIA4in1, via raid (though RAID will not be used as such but SATA connectors will - just had to order a new hard drive as armature 'clunking' on file selection of XP partition) and Gigabit ethernet driver (though not in use).
My System SpecsSystem Spec
01 Jun 2011   #13
essenbe

Windows 10 Pro/ Windows 10 Pro Insider
 
 

Quote   Quote: Originally Posted by swarfendor437 View Post
Hi essenbe,

Been struggling to locate the mobo manual but dug out the box the mobo came in in the attic - its an MSI K8T Neo2-F Motherboard (came with Athlon 64 2.4GHz with 1 Mb cahe processor - bundle). Hope this helps.
Go to this page- see if this is your MB.
If not, you should be able to find it on this page.
My System SpecsSystem Spec
.

01 Jun 2011   #14
essenbe

Windows 10 Pro/ Windows 10 Pro Insider
 
 

I wpuld suggest either trying the Vista drivers or getting in touch with tech support to see what they say.Some vista drivers will work on windows 7.
My System SpecsSystem Spec
01 Jun 2011   #15
1Bowtie

Windows 7 Home Premium 64 bit
 
 

This is true, but you have to put them in useing compatibility mode.
My System SpecsSystem Spec
01 Jun 2011   #16
swarfendor437

Windows 7 Professional (upgrade) 32-bit
 
 

Thanks guys, will try in compatibility mode as bowtie has suggested. Will let you know in due course - probably wait til new drive fitted tomorrow. Thanks again - I hate being stumped!
My System SpecsSystem Spec
01 Jun 2011   #17
SlasherIT

Ubuntu 12.10
 
 

You generally do not need to put Vista drivers in Compatibility mode to work, try it without compatibility mode first, and if that fails, then use it with compatibility mode. You are lucky you are even getting Vista drivers for your motherboard, which is quite of date, you can't really complain to them for a Windows 7 driver, unless they are extremely nice, they won't do/make it. Also, you should try DriverMax DriverMax - free driver updates. It can detect possible missing drivers and latest (official or unofficial) drivers. It is really useful and helped me install Windows 7 over a Windows XP laptop, which is around 9 years old, and runs great!
My System SpecsSystem Spec
03 Jun 2011   #18
swarfendor437

Windows 7 Professional (upgrade) 32-bit
 
 

Hi guys, updated the mobo drivers but still no joy on the bottom 2 ports at the rear of the 4 available; repositioned the USB PCI-Express 4/5 port USB card in bottom slot and picked up by Windows 7 automatically this time! So problem mainly solved - thanks for all your inputs!
My System SpecsSystem Spec
Reply

 USB ports worked in XP not in 7




Thread Tools




Similar help and support threads
Thread Forum
Autocad worked Ok in XP why not in W7?
I've been using AutoCad 2004 in Wxp for years. But it wont work in W7. I've tried installing Oracle virtual box but it still wont run. I'm at the end of what I know can anyone help. Thanks
Software
Front USB ports not working, but rear USB ports work…
This is a brand new custom built PC for web browsing for a motel lobby. Win7 Home Premium AMD A4-3300 Llano MSI A55M-P33 FM1 Rosewill FBM-02 MicroATX Mini Tower Running latest BIOS and latest drivers downloaded directly from manufacturer's website. I tried switching between all 3...
Hardware & Devices
How come this worked? Launch app from image.
I am wondering why something I did today worked and its implications. I am in the middle of upgrading to a new PC so many of the apps I use on a regular basis are on my new Win 7 PC and some of my apps are on my old XP PC. I had removed most of the apps that had been installed on the new PC...
General Discussion
USB 3.0 ports refuse to work as USB 3.0 ports
A few days ago I installed a USB 3.0 card (to be precise, this one: 2-Port USB 3.0 SuperSpeed PCI-E Controller Card - Free Shipping - DealExtreme). It uses the very common NEC µPD720200 USB 3.0 controller. I installed the required drivers for Windows 7, and the card worked fine for the first...
Hardware & Devices
Windows 7 would not boot and tried everything (worked for me!!)
So the other night, I was working on a PS3 problem and had several tabs open on my windows 7 computer, but had not touched anything for a while. I was taking a hard drive out of my laptop and installing in my other laptop (again not touching my desktop) when it suddenly shut down without warning. ...
BSOD Help and Support
Games that Worked ok for me
Games that Worked ok for me: 1) NFS MW (1.3) 2) NFS Carbon (1.4) 3) Psi-Ops 4) Mass Effect
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:49.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App