Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB3 doesn't seem to be operational

03 Jul 2011   #21
wellsy888

Windows 7 Home Premium
 
 

Thanks for the quick response. Went to Freecom site, no drivers but after reviewing their manual again, they indicate the following re: driver:

Under Windows XP / Vista and Windows 7 a separate Freecom driver is not required. The drivers will be installed automatically by the operating system after plugging in the Freecom Hard Drive XS 3.0 into the USB port of the computer.


I then partitioned/formatted through Disk Management as per their instructions (through USB2 connection) and then reconnected to USB3 card.

Now I don't get anything, it is not showing up in Explorer or Disk Management unless it is plugged in to USB2.

I have noticed on several forums that the USB3 should be enabled in Bios but there is nothing showing anywhere in the BIOS to Enable USB3. Could this be the root of the problem?


My System SpecsSystem Spec
.
03 Jul 2011   #22
essenbe

Windows 10 Pro/ Windows 10 Pro Insider
 
 

I don't believe there is a bios entry for USB 3 as it is not part of your system board, it is an addon. Check in device manager under disk drives and universal serial bus controllers.
My System SpecsSystem Spec
03 Jul 2011   #23
essenbe

Windows 10 Pro/ Windows 10 Pro Insider
 
 

The maker of the pcie card should have provided you with a driver disk. You have to have a USB3.0 driver for USB 3 to work. If no disk, go to the manufacturers web site and get the latest driver for that card. Without a USB 3.0 driver you cannot use usb 3.0.
My System SpecsSystem Spec
.

03 Jul 2011   #24
wellsy888

Windows 7 Home Premium
 
 

Hi essenbe, ok, that makes sense. since last posting, when plugged in to the USB3 port, under disk management, devices, it keeps flashing on and off, as if it recognises it then doesn't but still not reflecting the same under My Computer. I thought that as the hard drive has its own power source, it may be reacting to the cards power source so disconnected the power from the card. still did the same thing.

I then tried again in USB2 port, shows up in Device Manager but not in My Computer/Explorer.

I am also getting the Info message when I plug into USB2 that "This device can perform faster by plugging into USB3 superspeed port"

I have tried in my lapotop (USB2) to check the device is working and it is fine.

So now many comflicts and no step closer...
My System SpecsSystem Spec
03 Jul 2011   #25
wellsy888

Windows 7 Home Premium
 
 

I have the latest driver for the pcie card: Renesas Electronics USB 3.0 Host Controller 2.0.4.0
My System SpecsSystem Spec
03 Jul 2011   #26
essenbe

Windows 10 Pro/ Windows 10 Pro Insider
 
 

Hopefully that will solve your problem. Also, the hard drive gets its power from the card, usually.
My System SpecsSystem Spec
03 Jul 2011   #27
wellsy888

Windows 7 Home Premium
 
 

The driver has always been installed, this was the first thing I checked so this has not fixed it.
My System SpecsSystem Spec
03 Jul 2011   #28
essenbe

Windows 10 Pro/ Windows 10 Pro Insider
 
 

Quote   Quote: Originally Posted by wellsy888 View Post
The driver has always been installed, this was the first thing I checked so this has not fixed it.
I don't think I have any answers for you. Maybe contact technical support at the pcie company. I have the same thing on an old Dell computer. It worked fine as soon as I installed the USB 3.0 driver. Does device manager show any errors for it?
My System SpecsSystem Spec
03 Jul 2011   #29
wellsy888

Windows 7 Home Premium
 
 

Thanks for your continued support essenbe, drivers are working fine according to device manager. hopefully someone else may come in on the thread who has the same experience. I'll also look at the pcie suport as well.
My System SpecsSystem Spec
03 Jul 2011   #30
essenbe

Windows 10 Pro/ Windows 10 Pro Insider
 
 

Quote   Quote: Originally Posted by wellsy888 View Post
Thanks for your continued support essenbe, drivers are working fine according to device manager. hopefully someone else may come in on the thread who has the same experience. I'll also look at the pcie suport as well.
Sorry, but I don't know what else to try. Windows recognizes it as USB 3.0 because you get that message when plugging into a 2.0 port. The next suspect would be the hard drive itself, but it works fine with 2.0. Device manager says it should be working, so I'm at a loss of what else to try. Was it recognized by windows when you installed it? Try plugging the HD into the USB 3.0 port and restart the computer.
My System SpecsSystem Spec
Reply

 USB3 doesn't seem to be operational




Thread Tools




Similar help and support threads
Thread Forum
Reinstalled Win7 but now PC doesn't 'see' my USB3 stick
Hi. I built my PC a few months ago, all was working fine but, for reasons I won't bore you with, I had to reinstall Win7. The PC case has 2 USB3 slots (the blue ones) on the front but when I insert my USB3 memory stick, nothing happens. Yet the old card reader which I took off my old PC case (USB2)...
Hardware & Devices
ASUS M4A89GTD Pro/USB3: USB3 driver issues
Hello and thanks for any help you can provide. I have been having issues with my ASUS motherbord, I recently cleaned and re-formatted my main HDD, after doing this i re installed windows and all my normal drivers, motherboard, cpu, gpu, etc. But for some reason every time I install my USB3...
Drivers
HTPC doesn't see my external USB3 HDD
Finished my HTPC build today and plugged my external HDD in and it doesn't show in My Computer. I clicked on "show hidden" and it just shows my card reader. Specs: MB: MSI H87M-G43 CPU: Intel i3 Memory: 8GB Corsair Dominator PSU: Corsair RM550
Hardware & Devices
Server is not Operational?
Folk's the problem i am facing is quite weird. When i try to login from a client to server using administrator password i got login perfectly but when i try to change the user rights for some clients it gives me error that the server is not operational able. I got this error from 3 clients of my...
Network & Sharing
Why doesn't Microsoft support USB3.0?
G'day, We all know that in order to use USB3.0 ports, we need to install 3rd party drivers (e.g. Etron, NEC etc.). Sometimes this can be a real pain in the bum. With the increasing popularity of cheap USB3 storage devices, it seems logical to me that Microsoft would write and support their own...
Drivers
How do you confirm USB3 is operational
G'Day All, I have an fairly new ASUS laptop that has a USB 3 port onboard. In preparation for buying a WD passport USB 3 drive I decided to downloaded the latest USB 3 driver from the ASUS website. When I tried to install it the installation ceased and gave an error code. I rang ASUS tech...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:51.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App