Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Code 32 - Windows will not see ANY storage device

22 Jul 2011   #1

WIN7 64
Code 32 - Windows will not see ANY storage device


I am having a proving to be very difficult issue and getting virtually no viable support from MS so I come to you guys for help. Let me start with specs then I will get into my issue.

WIN7 64 Pro
12GB Crucial Balistiks DDR 1600
c:\ 300GB WD Raptor
5 1TB WD Caviar Blacks
ATI Radeon 4870 Dark Knight
Creative Sound Blaster Fataility
Asus P6X58D-E
Intel i7 930
Corsair 950 PSU
Obsidian 800D with 5 Hot swapable sata drive bays



After a MS update I noticed that one of my SATA drives dropped off as if it went bad, the indication for this was that it became inaccesable. I connected the drive via USB and still could not get into the drive. I connected it to my XP OS and presto it was back and fine. When I rebooted I noticed another drive formed a yellow BANG<!> sign, then another and another until all my drives besides the drive that contained my OS droped off.

After pulling my hair out for hours I was able to determin that without a doubt it was not my hardware as everything worked on my XP OS. I rebooted into WIN764 and I downloaded all the service packs and all available updates. After getting the updates and rebooting all my SATA drivesshowed back up which was an improvement but I was still not able to access my flash drives even though the DEVMAN could see them just fine. I could not and still cannot access any external drives, air card or phone that contains a SD card or mass storage.

The operating system sees all on the machine but in the device manager it has the following error message.

"A driver (service) for this device has been disabled. An alternate driver may be providing this functionality. (Code 32)"

Code 32 - Windows will not see ANY storage device-devman.jpg

Code 32 - Windows will not see ANY storage device-troubleshooter.jpg

So, I have done everything I can think of and have spent at least 11 hours with MS
teir 1 tech support and they cant fix it either. We have been down every road I can think of. I will not do a system restore as it will take me back to April and I do not want to reformat. I want to pin point this issue and resolve it, not sweep it under the rug.

Also, another interesting fact to this issue is: I have 5 hot swapable bays on my rig, all is well until I pull one out. When I pull one out and then scan for new hardware it removes it from the list in DEVMAN and when I put it back in and re-scan it sees it just fine but give the old ERROR 32 again and what was once an accesable drive now becomes inaccesable. It takes a reboot to get them back.

Here are a few errors I found in my event log:

The driver \Driver\snapman failed to load for the device STORAGE\Volume\{9a59136f-04dc-11e0-959f-806e6f6e6963}#0000000000007E00.

The driver \Driver\snapman failed to load for the device STORAGE\Volume\{02d5794b-04f2-11e0-92fe-806e6f6e6963}#0000000006500000.

The driver \Driver\snapman failed to load for the device STORAGE\Volume\{9a331575-9085-11e0-96bc-806e6f6e6963}#000000AA606B0800.

The driver \Driver\snapman failed to load for the device STORAGE\Volume\{02d5794b-04f2-11e0-92fe-806e6f6e6963}#0000000000100000.

The driver \Driver\snapman failed to load for the device SCSI\Disk&Ven_WDC_WD64&Prod_00AAKS-00A7B0&Rev_01.0\5&22bede4e&0&000000.

The driver \Driver\snapman failed to load for the device IDE\DiskWDC_WD1002FAEX-00Z3A0___________________05.01D05\5&5c6cfd6&0&1.1.0.

The driver \Driver\snapman failed to load for the device IDE\DiskWDC_WD1001FALS-40U9B0___________________20.04F20\5&2ea7e938&0&0.1.0.

{This is my OS drive}

The driver \Driver\snapman failed to load for the device IDE\DiskWDC_WD3000HLFS-01G6U4___________________04.04V06\5&2ea7e938&0&0.0.0.

Please help me.

My System SpecsSystem Spec
23 Jul 2011   #2

XP, Vista, W7 64bit Home Premium

Have you installed the latest chipset drivers for your motherboard? You can find them here -

Update the bios to improve hardware compatibility:

You could have a look at this usb fix if the bios update doesn't fix your problem - USB Driver - General Fix for Problems

Here's another fix -
My System SpecsSystem Spec
23 Jul 2011   #3

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

Hello TouchyFeely. Welcome to the Forum.

Device Manager error codes that show up on known working devices are usually caused by changes to device drivers or changes to the Windows Registry.

If an update made system registry changes that caused these problems then you have your "why". You then just need to correct the changes.

A normal solution to bad driver installs or Registry corruption is System Restore. You should not discount this solution out of hand. An even better solution is a System Image - which you would have taken yourself before - that you would restore.

Yes, this undoes everything you've done on the OS since April, or the date of the image, but that is normally less time than trying to change each and every registry key and driver needed manually.

Also: "Snapman" looks to be a component of Acronis True Image Server Enterprise. Have you explored the possibility that this software is the issue? Check the program settings or uninstall/reinstall to see if there is some conflict in the program caused by the update.

Hope that helps.
My System SpecsSystem Spec


 Code 32 - Windows will not see ANY storage device

Thread Tools

Similar help and support threads
Thread Forum
BSOD every time connect USB storage device to Windows 7 PC
I have a Dell Studio XPS 8000 running Windows 7 Home Premium 64 bit. In March the PC started to BSOD every time a USB storage device was connected to it. Other USB devices like mouse or keyboard did not cause this problem. It happens with two different external hard drives and 7 different USB...
BSOD Help and Support
USB Mass Storage Device/Unknown Device
In Device Manager, there is a USB Mass Storage Device or an Unknown Device, even when there isn't anything plugged in. This is occurring on a Dell Dimension 5100. This is not the pc in my system specs. How do I fix this? Here are some Device Manager screenshots:
Hardware & Devices
Device Manager Code 19 Error for HP CDDVDW TS-H653T ATA Device
I am having an issue where my DVD/CD RW has a code 19 error in device manager. The drive still works as I used it to boot a Windows CD and run a startup repair to see if that found anything. I tried uninstalling the drive and then scanning and it failed to install the drive. I also tried...
Windows cannot initialize the device driver for this hardware. Code 37
Long story short, I tested a friends graphics card in my homebuilt computer to see if it worked. I took my Ati Radeon 9800 Pro out, and put in this other card, and then replaced the other card back with my Ati Radeon 9800 Pro. Since then, I cannot get the drivers to work again for my 9800. ...
Graphic Cards
Mass Storage Device error code 10. Drivers failing to install.
I keep getting a message saying drivers failed to install correctly and a yellow exclamation mark next to the USB mass storage device (error code 10) when I look in Device Manager... I've don't really know where to start with any of this but I am thankfully quite good at following instructions...
Fix Windows 7 SP1 USB Storage Device Access Failures
Fix Windows 7 SP1 USB Storage Device Access Failures - Softpedia

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:27.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App