Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: HDD is Missing

22 Jul 2009   #1
vinny993

Windows 7
 
 
HDD is Missing

Hi all,
I have a missing hdd(1 Tera WD), I can see it in the device manager and BIOS but it does not show up in Computer or Disk Management. In the device manager it says its working fine, I tried changing the drive letters of my other drive(but not my c as i think it is unwise to do it) and the cd drive but no difference.
I also tried swapping the SATA cable and updating the BIOS and motherboard drivers but to no avail, if anyone can help i would be forever grateful. Thanks


My System SpecsSystem Spec
.
22 Jul 2009   #2
zigzag3143

Win 8 Release candidate 8400
 
 
hd

Quote   Quote: Originally Posted by vinny993 View Post
Hi all,
I have a missing hdd(1 Tera WD), I can see it in the device manager and BIOS but it does not show up in Computer or Disk Management. In the device manager it says its working fine, I tried changing the drive letters of my other drive(but not my c as i think it is unwise to do it) and the cd drive but no difference.
I also tried swapping the SATA cable and updating the BIOS and motherboard drivers but to no avail, if anyone can help i would be forever grateful. Thanks
Whats the 'label' and drive letter of it as seen in disk mgmnt? Is it formated (in ntfs)?

thanks

Ken
My System SpecsSystem Spec
22 Jul 2009   #3
vinny993

Windows 7
 
 

Thanks for the reply ken,
It does not show up at all in Disk Management Just in Device manager and the bios. I had the hdd working with xp and it worked fine. I just upgraded to Windows 7 today and thats when the problem came up.
My System SpecsSystem Spec
.

22 Jul 2009   #4
Zidane24

Windows 7 Home Premium x64 - Mac OS X 10.6.4 x64
 
 

Quote   Quote: Originally Posted by vinny993 View Post
Thanks for the reply ken,
It does not show up at all in Disk Management Just in Device manager and the bios. I had the hdd working with xp and it worked fine. I just upgraded to Windows 7 today and thats when the problem came up.
It seems like a controller issue...have you installed the most current chipset drivers for your computer?
My System SpecsSystem Spec
22 Jul 2009   #5
vinny993

Windows 7
 
 

yes I did that also, its a weird one.
My System SpecsSystem Spec
22 Jul 2009   #6
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by vinny993 View Post
Thanks for the reply ken,
It does not show up at all in Disk Management Just in Device manager and the bios. I had the hdd working with xp and it worked fine. I just upgraded to Windows 7 today and thats when the problem came up.
Is it an internal drive? have you upgraded the usb drivers, the bios, the chipset, etc

Ken
My System SpecsSystem Spec
22 Jul 2009   #7
vinny993

Windows 7
 
 

yes it's internal, and yes to all the updates too.
My System SpecsSystem Spec
22 Jul 2009   #8
Zidane24

Windows 7 Home Premium x64 - Mac OS X 10.6.4 x64
 
 

Hm...try this.
Disconnect the HD that isn't being detected...
Shutdown
Restart
Shutdown when it gets to the desktop
plug back in the HD that isn't being detected
Restart and see if Windows detects it
LOL do step two before step one
My System SpecsSystem Spec
22 Jul 2009   #9
vinny993

Windows 7
 
 

ok Ken I'll give it a go, I'll let you know asap.
My System SpecsSystem Spec
22 Jul 2009   #10
Zidane24

Windows 7 Home Premium x64 - Mac OS X 10.6.4 x64
 
 

Quote   Quote: Originally Posted by vinny993 View Post
ok Ken I'll give it a go, I'll let you know asap.
Zidane? LOL I hope that works...

PS You might have been speaking to Ken...if so ignore the first part of my post
My System SpecsSystem Spec
Reply

 HDD is Missing




Thread Tools




Similar help and support threads
Thread Forum
Missing files, missing "user" folder, can't access local drive
Hello to all! I'm new to this forum and obviously i'm not sure if this is the right place for starting and posting this thread. Since i'm pritty desperate i'm going to explain the best i can what is really happening and how it all started: since a few days ago i was noticing that a few...
General Discussion
Bootmgr.exe missing... mpio.sys missing or corrupted. Unable to boot
I just got a computer for free, a Dell Studio 1555. When I got it, it would try to boot, then come to a screen that said that bootmgr.exe was missing. Sometimes I got a message that said something like mpio.sys was corrupted or missing. I have a Win 7 disk, so I put it in and tried to repair the...
General Discussion
Missing MBR and missing OS after sleep problem
My setup had an MBR issue a few days ago after installing Skyrim. I was unable to repair it using the windows 7 instal disc. I tried the automatic fix as well as bootrec.exe. After giving up and reinstalling a fresh windows 7, my rig has not been starting up properly. It insists on waking up from...
BSOD Help and Support
Pictures missing suddenly and backgroung picture missing
i got on the pc this morning and noticed that where i have the picture saved on the desktop it was just black so i went into where my pictures are saved and there missing ?? but when i double click on one it will show any ideas please im lost on this ??
General Discussion
Win Explorer arrows missing, cursor spinning, libraries missing
New laptop (Lenovo W510), but I swapped boot disk for an SSD and reinstalled Win 7 64bit from recovery disks. I moved My Documents to D: and when I open Windows Explorer all looks fine. When I click on an arrow beside My Documents (or Music or anything), the arrow selected disappears, folder...
General Discussion
Missing boot menu and missing data partition
Hi there, I'm still very happy with my XP Pro, but I thought I'd set up a dual boot with Win7 ultima 64 and check it out. So I popped in another hdd that was sitting idly in a drawer and installed 7 on it. I fully expected that Win7 would be able to see there's an XP installation and create a...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:17.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App