Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Weird problem when installing wireless adapter

01 Aug 2011   #1

Windows 7 Home Premium 64-bit
Weird problem when installing wireless adapter

I have recently moved my desk to a new spot and can no longer use a hardline for Internet. I bought a Belkin N300 wireless adapter for my WIndows 7 Home Premium 64-bit system but it wouldn't install. I returned it to WalMart and bought a Cisco/Linksys AE1000 but it also wouldn't install

The errors are very similar. Essentially, the install files never seem to work. It will add the adapter to the device manager and say it's working fine... but when I try to enable the wireless connection, it gets stuck at "Enabling" forever.

Whenever I try to install the drivers (downloaded from the cisco site specifically for Windows 7), it gets stuck at "installing device drivers".

Anyone have any experience getting a Linksys AE1000 to link-up with their Windows 7 64-bit machine?


My System SpecsSystem Spec
01 Aug 2011   #2

XP Professional, 7 Professional

I'm pretty sure that the model is new enough that it should have installed the drivers automatically. Did it go through the wizard? I assume yes, since you say it shows up in your devices.

My only suggestion without being there to see your setup is to disable your firewall or antivirus and try again. If that doesn't work, you might try manually configuring it.
My System SpecsSystem Spec
01 Aug 2011   #3

Windows 7 Home Premium 64-bit

Niether of the installers completed. They both would get stuck at some spot. The AE1000, for example, asks me to plug-in the adapter... I do that and it says "Please wait".... then after a few minutes it asks me to plug it in again, even though it's already plugged in.

I disabled the firewall and antivirus (I don't even have antivirus installed since it's a recently formatted machine) and it still didn't work.
My System SpecsSystem Spec

01 Aug 2011   #4

Windows 7 Home Premium 64-bit

I just re-started my PC. When I go into the adapter settings, the wireless connection appears as disabled. I right-click it and choose Enable... then the dialogue box says its been enabled but it still remains greyed out. I can do this forever and it will never actually enable the connection.
My System SpecsSystem Spec
02 Aug 2011   #5

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

Some Network adapters require you to install the driver package first, then you shut down, install the card in the PC, and restart. Check the website to see if this is the case.

To try this you could uninstall it from Device Manager and then shutdown and remove the NIC and then try and use System Restore to take you back to a point before you first tried to install any card. Then attempt to install the driver then card "fresh".
My System SpecsSystem Spec
07 Nov 2011   #6

Windows 7 Pro 64bit
Same exact problem with AE1000

Just curious if you managed to resolve this issue? I am having the same problem to the detail.

Any ideas?
My System SpecsSystem Spec

 Weird problem when installing wireless adapter

Thread Tools

Similar help and support threads
Thread Forum
No sound after installing PCI wireless adapter.
Hello :cry: Yesterday I've encountered a very strange problem, after inserting my old wireless adapter into pci slot and restarting pc I have noticed that my computer can't make any sounds anymore. What's even more weird is the fact, that everything looks completely fine (the green bar in mixer...
Sound & Audio
BSOD installing USB wireless adapter driver
I plugged in my NetGear N300 Wireless USB Adapter and it failed to install the drivers automatically. I installed them manually from their website, but got a message from device manager that it was unsigned and would not allow it to work. Therefore I tried installing it again after disabling driver...
BSOD Help and Support
Installing new wireless adapter, hardware switch won't turn it on.
Aight. I've been having a lot of issues installing my new wireless adapter because Acer is retarded. I just got a new Intel AC-7260 wifi adapter with bluetooth, and I promptly installed it onto my computer. -I have all the correct drivers installed -Launch manager is installed -The hardware...
Network & Sharing
BSOD after installing pci wireless adapter
i have been having problems with my computer. installed a usb wireless adapter first and it would work for a while then freeze. tried another usb adapter then it wouldn't work and would say no connections vailable. then i installed a pci wireless adapter. well it kept saying that there were no...
BSOD Help and Support
Weird wireless adapter problem
Hello, I am having a weird wireless adapter problem. First of all the model of wireless adapter is TP- LINK ( TL-WN722N 150MBPS ) and i am connected to TP-LINK router ( TL-WR740N ). So for the problem it's whenever i am surfing internet the wireless adapter just turns off.. it's either it's stuck...
Network & Sharing
BSOD after installing Medialink Wireless-N USB adapter
This is Model No: MWN-USB150N. I just installed the software that came with this USB adapter and I've about 3 BSOD's in a weeks time, previously I have been using this computer for around 9 months with zero BSOD's, so I'm assuming it's something to do with the adapter. I'm sorry I wasn't able to...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:57.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App