Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: External HDD: Works in WIN7, Doesn't work in XP

02 Sep 2011   #1

Ubuntu 11.04 x86, Windows XP Pro x86, Windows 7 Ultimate x86
External HDD: Works in WIN7, Doesn't work in XP

I was hoping for some help.

I have a seagate 2 TB external HDD. It has 1 FAT32 partition. Everything works as expected in Windows Vista/7 and even in Ubuntu.

When connecting the external HDD to any XP machine (tested 3 computers with XP), the device will not show up under My Computer.

It is visible in Device Manager.

Under Disk Management, the drive shows up without any labelling and has improper file system and partitioning! It's as though the partition table is messed up, however, the drive works perfectly on any Vista/WIN7/Linux pc.

More info:
WIN7 Sees 1.86 TB, 1 partition:Fat32
XP Sees 3 TB (yes, three terabytes!), 4 partitions. 2 partitions show as UNALLOCATED, 1 partition UNKNOWN, and 1 partition (OS/2 Boot).

Not only is the capacity incorrect, but darn well everything else about the drive shows up incorrect under Disk Management. This happens with all XP PCs. Hate to sound redundant, but works well under any other OS.

Also, I ran a SFC /SCANNOW with one XP machine in the event the FAT32 drivers or DLLs were corrupted and no resolve. I reinstalled XP on the same machine and the results were identical.

Thank you for your time and hopefully, with your help, we can resolve this quickly.


My System SpecsSystem Spec
02 Sep 2011   #2

Windows 10 Pro. EFI boot partition, full EFI boot

Did you format it with a GUID Partition table instead of a master boot record? 32 bit XP doesn't recognize GPT. I doubt it is that though because there is supposed to be a protective MBR inside the GPT that would make the disk look like a 2TB partition of unknown type and no free space to 32 bit XP.
My System SpecsSystem Spec
03 Sep 2011   #3

Ubuntu 11.04 x86, Windows XP Pro x86, Windows 7 Ultimate x86

I'm not certain, but I do know that I used TOKIWA's FAT32Formatter to format several external hard drives. I have two 2TB drives (one seagate, one Lacie) that are displaying the same results on different XP PCs.

I first noted the issue two weeks ago after lending my spare external drive to a friend and it wouldn't display on either of his XP machines. I assumed, ignorantly, that the USB ports or some drivers had gone corrupt since both machines were running in poor states. But I just set up a triple boot Ubuntu-XP-Win7 machine and two other XP re-installs for some clients, each separate legitimate copies from their purchase or through my company. All machines so far with XP failed to see the externals properly, but always the same partition table, file system, and exaggerated capacity issues

For the last year I've used it for music and such on all my gaming systems (PS3, Wii, and Xbox which requires drives to be fat32) and for my files. I suppose I just haven't ever plugged any of the externals that I've formatted into an XP machine before these last few weeks and I'm just noticing that XP has no clue what it's looking at.

I can still use my external on my xbox and other pc's, however, the 5 XP machines I've recently imaged or at my friends will not take to either drive.
My System SpecsSystem Spec

03 Sep 2011   #4

Ubuntu 11.04 x86, Windows XP Pro x86, Windows 7 Ultimate x86

Oh, my spare was LaCie.

I've noticed, too, the volume sizes for the unallocated partitions equal that of the free space remaining on the drives. I'm wondering what caused this.


Just formatted another External (Samsung 1 TB) with the same tool from Windows 7. This drive is capable of being read as expected in Windows XP. Why then, I wonder, do the LaCie and Seagate drives not work in XP?

A mystery is afoot, people. I don't like mysteries..
My System SpecsSystem Spec

 External HDD: Works in WIN7, Doesn't work in XP

Thread Tools

Similar help and support threads
Thread Forum
Using bridged mode works but pppoe doesn't work
First of all, I am new to the forums, and really don't know if i can ask this question because it might not be related to W7.( I posted it here becase at anytime this forum is visited by over 10000 people) Anyways: I have a router tp link td 8840t. It is a small modem which i got from my isp and...
Network & Sharing
Wireless Internet Works, Wired Connection Doesn't Work
Hi. I formatted both my laptop and desktop computer. When i did with my laptop, everything was great. Wireless still worked. Of course i have my linksys router connected to get the wireless. I then formatted my desktop. Its a dell. When i did this, everything seemed great. However, i...
Network & Sharing
WIFI Internet - Internal works, external doesn't
Morning all I've googled this and found heaps of people having the same issue, but nothing that actually resolves it. I'm using a laptop with internal wifi but I also have an external wifi dongle as I connect to my neighbours internet (I have permission and the passwords, etc). Both the...
Network & Sharing
Wireless doesn't work in my room in my new computer but works on my ip
I purchased a dell 15r (N5010), and have had it for about 3 days. It is a core i3 2.27Ghz, 4Gb RAM. I did a clean install of the OS to get rid of all the bloatware. I then downloaded the respective drivers from the dell website and the resource CD that came with the laptop. After the clean OS...
Network & Sharing
Downloaded W7 now Microsoft Works Doesn't Work
Downloaded W7 now Microsoft Works Doesn't Work :( MESSAGE RECEIVED: Microsoft works cannot access one or more files it needs to run. The files may have been renamed, deleted, or moved. If anyone can help i'd appreciate. Thanks
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:37.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App