Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 not allowing me to use my USB

07 Sep 2011   #1

Win 7 64x
Windows 7 not allowing me to use my USB

There are certain things on my HP that I am having trouble with now that Windows 7 has been installed once again and I hope that someone reading this has some suggestions.

For about a year before yesterday morning I had Windows 7 installed on my 64x HP PC and all was fine. But yesterday morning I got my old P4 out of the closet and decided to wipe 7 and install Windows Server 08 with my old P4 as the client running XP. Then I was offered another PC that is significantly better than this P4 so I put Win 7 back on the HP with intentions of replacing the P4 with the new AMD box.

These "things" are device recognizancian.
- First, there are camera card readers built into the front of the HP box. They showed in "Computer". But they are not there now.
-Second, I have a USB HD. I store all of my data on it. When I plug it in now the computer makes those beeps as it does when it recognizes a new USB device but it won't show up in "Computer" either.

Anyway, that's the background. Thank you , in advance, to anyone who has ideas of what I can do to resolve this.

My System SpecsSystem Spec
07 Sep 2011   #2

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86

By camera card readers you probably mean SD card readers. HP usually uses Ricoh card reader drivers, you can google for those or try the driver linked on this page.

Clean Install Windows 7 Ultimate x64 on dv9502tx driver prob... - HP Support Forum

or here

Laptop Drivers: HP

As for the usb HD, the drivers should be installed as part of the chipset driver. If you have an Intel chipset, you can download and use their chipset identification utility, then download and install the appropriate driver.

On second thoughts if you tell us the make and model, somebody will help locate the model specific drivers.
My System SpecsSystem Spec
07 Sep 2011   #3

Windows 7 Enterprise X64/Windows 10 Enterprise X64/Windows 10 Pro X64/Linux Mint

Also, check in disk managemet for the USB drive. It may just need a drive letter to be seen in computer.
My System SpecsSystem Spec


 Windows 7 not allowing me to use my USB

Thread Tools

Similar help and support threads
Thread Forum
Standard Account Windows 7 Is Allowing Installations: Why?
Hi Everyone, My father has a small office and recently I changed his 1998 Packard Bell desktop running Windows 1998 to a Windows 7 HP desktop. Since changing it he realized that his secretary has installed a lot of junk and has been doing a lot of things she ought not to be doing on the...
General Discussion
Windows 7 not allowing keyboards to work
Hello. A few days ago, I was chatting when suddenly my computer went to sleep on its own. After i turned it on, the keyboard wasn't working at all. I have tried a lot of things, and none worked. I have tried 3 different wireless keyboards that all worked on other computers but not on mine (I don't...
Hardware & Devices
Windows not allowing client side web launch?
Ive been having an issue for several weeks now where windows will not allow programs to launch web based items, ie: Acrobat opening links in Pdf's, Any program trying to open help tabs or 'about' pages, Loader screens for games not allowing to open website links for accounts, forums, downloads...
General Discussion
Windows 7 only allowing 1 stick of RAM
I was having problems installing Windows 7 64-bit for a couple days. It was crashing and taking ridiculously long. After some research I removed all but 1 stick of RAM and everything went fine. After getting 7 installed I tried putting my remaining RAM in and the system freezes at the starting...
BSOD Help and Support
Windows not allowing access to shared files
I have a Win7 PC and a Linux machine on a home network. I can see and access Linux machine's shared folders from the WIN7 machine; but cannot access windows PC shared files from the Linux box. I have SAMBA on Linux. Both machines see each other. Windows machine sees Linux shared files and...
Network & Sharing
Windows 7 x64 Not allowing SKU choice?
Hi Guys, I went in and deleted the ei.cfg file from the /sources folder on my TechNet downloaded Windows 7 Enterprise x64 disc, and it isn't asking me to choose an SKU. Any ideas? Cheers, Jack
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:07.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App