Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB 3.0 host controller not found

15 Sep 2011   #1

Windows 7 Home Premium x64
USB 3.0 host controller not found

Yesterday, my usb 3.0 host controller seems to have stopped working. I have tried enabling/disabling controller from BIOS, reinstalling drivers, finding different drivers, and reinstalling my mobo CD, but to no avail. (Yes, i already tried searching).

It does not show up in windows device manager at all, but when i plug my mouse into the ports, the LEDs light up, but the system does not detect it (nothing happens, no chime or anything).

How would i go about fixing this issue?
Thanks in advance

My System SpecsSystem Spec
15 Sep 2011   #2

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

Hello joffua. Welcome to the forum.

I have to assume this controller is on the motherboard? What brand and model is it?

If it were mine I would be checking out the MB manufacturer's forums about the board to see if others were having the same issue.

If you fill out your "My System Specs" under your Profile then others here could look too!
My System SpecsSystem Spec
15 Sep 2011   #3

Microsoft Community Contributor Award Recipient

Windows 7 Ultimate 64

TVeblen brings up a good point, more info is needed and most mobo mfrs will also support you with email or phone-in support. If they can't work through the issue they should on such a new product RMA the board to test, repair or replace.
My System SpecsSystem Spec

15 Sep 2011   #4

Windows 7 Home Premium x64

Its a gigabyte GA-X58a-UD3R rev. 2
I already searched the manufacturers forums and found nothing.
And yes, it is an integrated controller.
Thanks for the replies.
My System SpecsSystem Spec
15 Sep 2011   #5

Windows 10 Pro/ Windows 10 Pro Insider

The last driver listed on the Gigabyte page. Just select your OS.
My System SpecsSystem Spec

 USB 3.0 host controller not found

Thread Tools

Similar help and support threads
Thread Forum
The Asmedia USB host controller was not found
Hello all, I have an Asus Z97 pro wifi ac and have been having issues with USB 3. I tried to install the usb drivers from the Asus website but I get an error "The Asmedia USB host controller was not found". Can someone please help me with this issue. Im running windows 7 64bit. Thanks
USB 3.0 host utility controller not found
Hi, I think I have accidentally uninstalled my Reneas USB 3.0 controller as the usb ports are not working and I'm getting the not found error. I have tried installing the driver from the reneas website and restarting my laptop but I get the same problem. Also usb 3.0 doesn't show up in the driver...
USB 3.0 Host Controller Not Found
I know this is a well documented situation and I have seen and read a lot of information about the problems others have had with the USB 3.0 Host controller. My situation is that I have followed several different solutions only to wind up with USB's on the 3.0 hub not working after reboot. I have...
USB 3.0 Host Controller not found
Today I got a WD usb 3.0 PCI-e card. WDBFJ0000NNC I installed the software on the CD it came with. Then I put the card into a free PCI-e slot. When I restarted the computer, windows gives a message that the device driver was not successfully installed. Specifically the "NEC Electronic USB...
Hardware & Devices
USB 3.0 Host Controller Not Found
I've just recently upgraded my pc but i'm having issues trying to install and setup the drivers for the usb3.0 ports and updating the firmware. I'm running on Windows 7 x64 My motherboard is the P8P67 PRO Rev. 3.0 - New P67 B3 Revision I have tried the drivers and firmware from here without...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:57.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App