Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to read SSD

24 Sep 2011   #1

Windows 7 Ultimate x64
Unable to read SSD

So I turned my computer off last night, everything was working fine. Then when I woke up today, I turned it on and BAM, could no longer read my SSD (Vertex 2) and would get a message telling me to insert my windows install disk.

So I decided to humour it, and tried putting the disk in, checked the recovery options and was unable to find the SSD to perform recovery on. I carried on a few more steps to install a fresh copy and it wasn't listed there either.

I spent about a hour fiddling around with the hardware, swapping around wires and harddrives to check if it was the wires messing me about, turns out everything worked fine.

I then reset my BIOS and then checked the boot settings, but my SSD wasn't even displayed on the list.

So I was stumped.

On the POST screen, when the SSD was not plugged in, nothing would show up in that slot, however when the SSD is plugged in it says 'None'

(SSD currently plugged into C1 Master)

This problem has been bugging me all day, and I was hoping someone might know what it going on ?


My System SpecsSystem Spec
24 Sep 2011   #2

Windows 7 Ultimate x64 Service Pack 1

Have you tried to plug the SSD into another SATA slot on your board? If that dosen't work, try and connect a spare Hard Drive to the cable your SSD is currently connected to - just to rule out whether it's actually the SSD or a problem with a SATA port on the motherboard.
My System SpecsSystem Spec
24 Sep 2011   #3

Windows 7 Ultimate x64

I tried loads of different combinations of cables, slots and hard drives. Nothing seemed to work.

I can't see why it would stop so spontaneously. I had turned it off and on several times the night before and it was fine. Then I turn it off for the night and it's gone

I'm hoping it hasn't packed up entirely. Going back to a regular hard drive is insanity ... the slowness
My System SpecsSystem Spec

24 Sep 2011   #4

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64, Windows 10 Pro x64

What firmware version on your SSD?
Did you shut the computer down or put it to sleep or hibernate?
Is there a green or red LED lit next to the SATA connector on the SSD?
My System SpecsSystem Spec

 Unable to read SSD

Thread Tools

Similar help and support threads
Thread Forum
Unable to read contents of folder
This is a recent occurrence, maybe related to a new windows update item. Clicking on (say) the Documents folder will not open the folder. Instead the system puts the item on the task bar. Clicking on the task bar item does nothing, it simply sits there. Can anyone shed some light on this problem...
General Discussion
Unable to read my external HDD WD 1TB, need help please
Hi, i've been using my WD HDD for 8months but today got an error 'do you want to format the disk now?'. i've tried doing the DLDIAG from WD and getting fail. i've done the testdisk,reboot the machine but still it can't read the drive. under dskmgmt, the drive can be seen from there,also changed...
Hardware & Devices
Unable to remove Read only attribute
I am a photographer. I use Adobe Lightroom 4 to manage my photos. I had to reload my photos the other day. Today I was making changes in the data in my photos, when I finshed and saved the data I recevied a message that the photo was Read Only. I have tried several remidies posted here and other...
Music, Pictures & Video
Unable to read word document
since upgrading my Desk Top and transferring my documents I now find that I am unable to read the word document. The document was created using Microsoft office 2001. Ihave downloaded the trial Microft Offine 2010 Home and Student, butd got no Joy andy help would be appreciated - Gerry

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:55.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App