Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: HP 6310 printer shows up as Unspecified

12 Oct 2011   #11

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

!!!!Bluetooth mouse!!!!

Could you tell me what that laptop has listed in the Device Manager for Network Adapters?
I'm guessing there are 2 - One Atheros 802.11b/g/n Wireless Network Connection, and one Bluetooth adapter of some sort.

My System SpecsSystem Spec
12 Oct 2011   #12

Windows 7 Professional 64

There are 6 things listed under Network adapters. That seems like a lot.
- Atheros AR9285 Wireless Network Adapter
- Bluetooth Device (Personal Area Network) #2
- Bluetooth Device (RFCOMM Protocol TDI) #2
- Marvell Yukon 88E8057 PCI-E Gigabit Ethernet Controller
- Microsoft Virtual WiFi Miniport Adapter
- Virtual Passage SSLDrv Adapter

Do you think the bluetooth mouse is causing problems?
My System SpecsSystem Spec
13 Oct 2011   #13

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

Yes, I'm thinking that the Bluetooth adapter is causing it, triggered by the mouse somehow. But I am only speculating now - I don't play with Bluetooth devices.

But I think a good experiment would be to disable the unused devices in Device Manager and then try installing the printer (after cleaning up the OS from previous installs, of course).

The Marvell Yukon 88E8057 PCI-E Gigabit Ethernet Controller is your wired LAN controller - keep it.
The Atheros AR9285 Wireless Network Adapter is your wireless adapter - and the one the printer would use.

All the other adapters could be disabled to test. I'm guessing that the printer is "confused" over which wireless adapter to use.

You will, of course, need a standard USB mouse to do this, or just use the touchpad.

If the printer does install you could enable the devices again and test, or if you don't have any use for them - leave them disabled.
If you Remove these devices they will most likely just reinstall on the next startup, so unless you can disable them from the BIOS settings it would be best to just disable them. You may have a use one day.

EDIT: More info-
Microsoft Virtual WiFi Miniport Adapter
Your call.
My System SpecsSystem Spec


 HP 6310 printer shows up as Unspecified

Thread Tools

Similar help and support threads
Thread Forum
Networked Printer always shows up as offline have to select other
so I have a hp a910 printer connected directly via ethernet to my router. The printer shows up in my Devices & Printers, as a HP a910 network, and I have it set as my default printer. However if i go to print lets say from Word or really any application, and I print to my default it won't print, as...
Hardware & Devices
(ask) how to change my resolution game ?? AMD HD 6310
Hi All, I use asus 14 inch along with windows 7. recently i have installed the sims 3. but when i cannot play this game with full screen. i get black bars on each side of the screen.. its very irritating.. please help.. i use AMD ATI RADEON 6310 (or maybe ver 11.4) :)
Unspecified error
I downloaded the .exe for 7 Home Premium from the UK Ultimate Steal site. It says it's preparing, but eventually it gives me an error message saying "Unspecified Error". The .iso is equally annoying, I burned it to a DVD and tried to get my laptop to boot from the DVD drive. It waited...
Installation & Setup
Problems Installing Officejet 6310 Windows 7 driver
I am trying to install the Windows 7 driver and software for my Officejet 6310. Whenever I attempt to install, the files extract normally, but the installation crashes immediately after. The message I get is a Runtime Error. C++ Visual Runtime Library: The C++ runtime has requested this program to...
Hardware & Devices
printer shows up as Unspecified device??
hi all, just installed win 7 on the new HD. epson printer installed fine. my okidata, using the latest downloaded 64 bit driver, shows up in the "unspecified" devices category instead of in printers. unusable as it will not show when i try to print. tried multiple install/uninstalls. how to get...
Hardware & Devices
network wireless printer shows as computer
On a laptop I just added to the home workgroup, I see the wireless printer in the folder area under network as a computer. But when I go tro Devices and printer and ask to add a new printer it searches and does not find it.. So how come it shows as a computer & not a printer? How do I get it to...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:29.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App