Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: External HDD Suddenly Stops Working (Well, Sort Of)...................

08 Oct 2011   #1

Windows 7 Enterprise x64 (Will be upgrading to Windows 8 upon release)
External HDD Suddenly Stops Working (Well, Sort Of)...................

ok, i'll make this short, my friend accidently unplugged my external Western Digital 1TB HDD drive from my laptop while I was using it, as well as knocking out the power cord simultaneously. i dont recall actually using anything on the drive or transferring files to/from at the time this happened. But in any case, i plugged it back in and it just wouldnt let me read from it anymore in Computer. The drive's icon was still there but wouldnt let me open it in either Explorer, Total Commander, or Directory Opus. Explorer froze up several times and i had to kill the process. and a few other apps i started attempted to access something on the drive and froze when they couldnt do so. I then removed the drive when Safe Eject failed to work. after plugging it back in the drive's icon disapeared from Explorer entirely. I also noticed that the driver for the drive disappeared from Device Manager, whereas it was there before.

I have tried plugging it into several other PCs, with varying results. In any case I can sometimes view the folders/files in this situation, and can sometimes open them. But at other times i cant. and even when i can the drive takes an unusually long time to respond.

I have also tried booting into a Live Linux distribution from USB key and then plugging in the drive, and then attempting to copy them over to another external HDD that i also have plugged in. But the drive access is extremely slow and it often freezes up in the middle of trying to copy. This is unusual of Linux, as stable of an OS as it is, i often use it to fix problems that i cant fix in Windows, like virus/spyware/malware removal. this leads me to believe that the problem lies with the drive.

I'm just trying to recover the files without having to format, as i have alot of important data on it i cant afford to lose. i basically want to copy over the data to another HDD so i can format it (after the fact) as NTFS, hopefully then it will work properly. Also, can i do a file scan check of some kind on the HDD? i know there is an option for that if i go to the drive's properties, but i cant seem to access it from either my laptop or any other PC without Explorer crashing.

Thanks for any help!

My System SpecsSystem Spec
08 Oct 2011   #2

Windows 7 Professional SP1 32-bit

Did the drive itself suffer any physical shock during the accident? Did it fall off the table?

Obviously it might be failing, but I could imagine that there was somehow physical damage to the USB cable or socket on the drive's enclosure, possibly even the AC adapter (unlikely if the drive is spinning and getting power just fine).

I'm not sure what to suggest that you haven't tried already, but perhaps a run with TestDisk will shed more light on things: Regain a lost drive using Test Disk - An Illustrated Guide
My System SpecsSystem Spec
08 Oct 2011   #3

Windows 7 Enterprise x64 (Will be upgrading to Windows 8 upon release)

No the drive didnt fall off the table at all, it didnt even move so far as i could tell. and the power cord he knocked out was for my laptop itself, the HDD does not need to be externally powered, it's USB only, thank God. And it was brand new so i doubt it failed, just bought it at Target 3 weeks ago. nothing on the drive's external shell appears to be damaged. my usb port also looks fine. have also tried a different cable connector (even though the old one is fine), same results.

In the meantime, i'll try the Test Disk thing and report back.

If anyone else has any suggestions, please post!
My System SpecsSystem Spec

09 Oct 2011   #4

Windows 7 Enterprise x64 (Will be upgrading to Windows 8 upon release)

The problem just got bigger.

TestDisk didnt work AT ALL, in fact i think it made the problem worse. it scanned the drive and asked if i wanted to recover the partition (as a bootable partition i think, but all the files on there are just data storage stuff, nothing bootable). when TestDisk was done it asked me to reboot. so i did. but now the drive doesnt even show in Disk Management or Computer. i didnt tell TD to format the drive, only to recover the partition. And now i have no way of knowing if the data is even on the drive since it wont show up anywhere, on any computer that i've tried (2 so far). have also tried accessing it from the Live Linux USB key, it acts as if it's trying to access the drive but after 10 mins of activity nothing shows up, but still shows me that it's mounted. it wont let me view the drive contents, only that it's mounted and about 60% full, which sounds about right since i had occupied a little less than 600 gigs of data on it. is this drive a goner, or this there a chance that i can at least recover the data before throwing the HDD away, short of taking it to a data recovery pro? i wont be storing anything else important on it even if i'm able to fix it, dont think i can trust it. when he knocked the cord out i check the usb port to see if it was damaged, it doesnt seem to be, and all other devices plugged into that port operate fine. i even took it to a friend (the laptop) and he thoroughly tested the port with software and many devices, final conclusion is it's not damaged. as for the hdd, nothing showed for him either, he says theres a 50/50 chance he can recover the large majority of the data at no cost to me, and also a chance that nothing will work. so i've left it with him for now. have also tried plugging the drive into the other ports, now nothing. any advice?
My System SpecsSystem Spec
09 Oct 2011   #5

Windows 7 Home Premium 32 bit

Sorry to learn that Test Disk did not help you.

Just about fifteen hours ago I put a Part 2 in this post Regain a lost drive using Test Disk - An Illustrated Guide wherein I had deleted the partition table in my Maxtor external drive and ran Test Disk to fix it. It did it successfully.

Test Disk does not format your drive. So you need not worry that you could have lost your data.

The other point I would like to clarify is that there is always a first boot sector on the external drive which will contain the partition table - even if your drive is a single partition. If Test Disk cannot find the partition table the window will announce "No Partition is bootable" (refer to my post). In the case of another user it just indicated "Partition Read error " and didn't help him further.

At this point it is not clear to me what exactly you did after this message appeared and and what other Windows appeared in your case. If it had succeeded in showing a partition, you could have tried to copy the files in it by hitting P or List. But even if you had specifically given a write command what all it does is write the partition table into the first sector (if it had found the partition).Without a specific write command it wouldn't have wriiten anything to the disk.
My System SpecsSystem Spec
09 Oct 2011   #6

Windows 7 Enterprise x64 (Will be upgrading to Windows 8 upon release)

Jumanji: the drive im trying to recover is purely data files, nothing bootable whatsoever. is TD meant to be used only on drives that have bootable data? perhaps so, maybe it was the wrong tool for me to try. but all said and done, its too late now, since i now have a hdd that cant be accessed from any pc at all.

i just read your most recent post about TD. interesting but nothing i can do now, unless a breakthrough materializes out of the mists of nowhere. i just dont see how a drive that is physically undamaged seemingly cant be accessed by any means, especially since i just bought it brand new 3 weeks ago. sure, all drives fail eventually, but after 3 weeks?! totally unbelievable...........

also, im fairly certain that there is/was only one partition on the disk, and im also certain that my data is still on there. but my question is, how to access/recover it?

TD did indeed find 1 and only 1 partition on the hdd, i told it to recover it as a bootable partition, since thats the only option i saw. after reboot it failed to appear in Disk Management, Device Manager, or Computer, and upon plugging it in it doesnt make the familiar sound Windows makes when it recognizes a device has been plugged in. i listened to the drive carefully against my ear for signs of disk failure, like clicking etc, all i heard was the normal but quiet spinning noise that all external hdd's make when plugged in, nothing out of the usual. so im fairly certain that its physically undamaged. i even manually installed the drivers from Western Digital website and plugged it back in, still nothing.

i did not know i could copy the files in the partition after it being listed in TD, if i had known i would have attempted to do so immediately.

also, my linux live bootable usb drives are now failing to recognize the drive at all, whereas they were at least seeing it before using TD. and the hdd isnt even showing up in the bios either, which basically means that no OS will be able to recognize it. any way to remedy this?

thanks in advance for any help, reply soon!
My System SpecsSystem Spec
10 Oct 2011   #7

Windows 7 Professional SP1 32-bit

This is a long shot, and I'm just throwing it out here as a possible explanation of what's going on.
Your drive might indeed be perfectly fine, but the controller board on the drive itself could have taken some kind of damage from being disconnected from power so unexpectedly, maybe some kind of surge. It would explain the failure of the drive to be seen at all now.
In that case, your data is probably still safe, but it will take a replacement of the entire controller board with an identical one to be able to access it again. People have done this themselves by buying an identical model drive off eBay and swapping the boards, but I imagine this isn't easy (never had to do it myself).
Let's see what your friend has to say about the drive...I hope he's the careful kind of guy. :)

On another note: whether a partition on a disk is bootable or just data, the disk always has an MBR (master boot record) and partition table on its first physical sector. When you told TestDisk to restore the partition as bootable, it probably didn't do much harm since the data contained within the partition still doesn't constitute a bootable system. It just didn't make much sense to do this, but it shouldn't really have messed anything up there's hope :)
My System SpecsSystem Spec
10 Oct 2011   #8

Windows 7 Enterprise x64 (Will be upgrading to Windows 8 upon release)

thanks for the reply Corazon, but i remove flash drives and other external HDDs without safe ejecting all the time, nothing bad ever happened until now. my friend is really just a computer repair guy, he's not a data recovery specialist. but he knows alot more about data recovery than me, so i'm going to give him a few days to work on it. in the meantime i just figured i'd post here on SevenForums to see if i cant solicit any other advice.

i'll bring up the idea of replacing the drive controller to him and see what he thinks. he'll probably say its not necessary. I'm more along the software side of things, i can take humpty dumpty apart but i damn sure cant put him back together again. i'm clumsy with my hands or whatever you wanna call it. software is what i'm good at.

if anyone else wants to pitch in their 2 cents' worth, feel free. thanks!
My System SpecsSystem Spec
10 Oct 2011   #9

Windows 7 Home Premium 32 bit

I entirely agree with what Corazon has said.

I feel you did everything right with Test Disk including the write command to write the partition table - though because of a misconception you state you chose the only available option "Recover as a boot partition". ( There is no such option as far as I know. )

If Test Disk had not written the partition table it may be because the drive could have taken its last breath by then. But you indeed missed a chance of trying to recover the data when it showed the partition though I doubt you would have retrieved any from the almost dead drive. Perhaps my Part 2 was a little too late for you to try the recovery. Sorry for that.

If the hardware has failed no software can do miracles to bring it back to life.

Since you say that your HDD is new, you should be able to get an identical drive, swap the board and try which your friend should be able to do. A transplant. I would balk at it if your drive was an old one. Here you have chances. ( I would still say chances )

Way to go, unless some one else could come up with any other suggestion..
My System SpecsSystem Spec
10 Oct 2011   #10

XP / Win7 x64 Pro

When you boot into Live Linux, the drive may still be readable even if it's not being mounted. What version of Linux are you using?
My System SpecsSystem Spec

 External HDD Suddenly Stops Working (Well, Sort Of)...................

Thread Tools

Similar help and support threads
Thread Forum
Audio suddenly stops working
So my audio suddenly stops while playing Rainbow Six Siege. This has happen before while playing siege and is fixed by restarting siege and Uplay and only effects the game and nothing else. This time, everything that involves audio just stops working. Everything has been fine up until now. I've...
Sound & Audio
Windows Sort of Stops Working From Time to Time
I previously started a thread about this at: But that's 9 days ago. I apologize if I should NOT start a new thread instead of adding to the old one. The issue is that from time to time,...
General Discussion
External Hard Drive stops working after 16GB
I have an external hard drive - ClickFree 527B3, 500GB. It doesn't have warranty. Whenever I try to write files to it it will stop working, and show up as empty, after 16GB have been written. I reformatted it and the same thing happened. I tried creating two (primary) NTFS partitions and only one...
Hardware & Devices
Mouse suddenly stops working!!!!!
Hi guys,everyday when I open my laptop my USB mouse works for a few mins then suddenly stops working:cry:Can anyone please tell me how to fix this?
Hardware & Devices
Internet suddenly stops working, problem with default gateway.
For the past few weeks I've been having this problem, the internet works fine and suddenly stops opening pages and disconnects me from any game I'm playing but it still says that it's connected. This happens maybe 10 times a day and when it does happen, I run the 'Diagnose' on LAN adapter and it...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:49.
Twitter Facebook