Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Trouble Installing USB Modem

19 Oct 2011   #1
Kabir

Windows 7 Ultimate 64 bit
 
 
Trouble Installing USB Modem

Hello, I recently bought a new desktop and it has windows 7 64-bit installed in it. Since than i am having serious trouble while trying to install my USB modem to connect to the internet. There isnt any issue with the modem as it works totally fine with other computers and the USB ports are also working all fine. When i plug the modem in the computer detects it but then instantly it goes to being undetected. It is being displayed as an unspecified device. Please help me out..


My System SpecsSystem Spec
.
19 Oct 2011   #2
seavixen32

Windows 7 Ultimate SP1 64-Bit
 
 

Welcome to Windows Seven Forums.

More information please.

Who manufactured your modem?

What model is it?

Have you tried installing 64-bit drivers for it?

Is it compatible with the Windows 7 64-bit operating system?

Have you checked the Windows 7 Compatibility Centre?

Windows 7 Compatibility: Software Programs & Hardware Devices: Find Updates, Drivers, & Downloads
My System SpecsSystem Spec
19 Oct 2011   #3
Corazon

Windows 7 Professional SP1 32-bit
 
 

Hello Kabir,

welcome to SevenForums :) I assume the USB stick is a 3G wireless broadband modem, rather than a wireless network adapter (what you would use to connect to a nearby router)?

I've had similar experiences with two such sticks on my Windows 7 laptop. As it turned out, Windows 7 just needed to install a whole bunch of drivers the first time I plugged the stick in, and as part of that install the device does indeed become "unplugged" but only for a few moments.

All I really had to do was...nothing. Have you tried plugging the stick in and just waiting for, say, a minute? Perhaps this is all that's needed in your case.
My System SpecsSystem Spec
.

19 Oct 2011   #4
Kabir

Windows 7 Ultimate 64 bit
 
 

Beceem Communications Pvt. Ltd is the manufacturer of this network adapter. The version is 5.2.137.0. I have talked to my network provider and they mentioned that the firmware installed should work in a 64 bit system. Also the device doesn't seem to have any problem as it worked fine when i tried it in a vista run computer.
I also kept the stick plugged in for a long time that too didn't provide any results.
My System SpecsSystem Spec
Reply

 Trouble Installing USB Modem




Thread Tools




Similar help and support threads
Thread Forum
Windows 7 stuck at welcome screen after installing VGA card + modem
Hi I have a desktop with motherboard G41, 8GB RAM, 1TB HD, Nvidia Geforce 4GB graphics card, and Agere dial up modem. When dial up modem is installed along with the Nvidia Geforece graphics card at the same time, Windows 7 64 bit won't go past welcome screen, but will load without a problem in...
Hardware & Devices
Problems installing a PCI HCF Modem
Hi All, Just joined the forum as I have been struggling for DAYS on this issue, internet researching and fiddling with Device Manager. I have a Rockwell HCF Data/Fax/Voice modem installed on PCI slot 2 with the RCV56HCF chipset on it. Yes I know its old and has sent faxes from Windows 95,...
Hardware & Devices
WMP 12 freezes after installing a new modem
Hi, I just installed a new Digilink Digisol broadband modem. The drivers were pre Windows 7 era :eek: But since I couldn't find any new ones had to install whatever came with the package. I checked for updated drivers with driver genius. But none could be found:shock: The internet is working...
Hardware & Devices
Drivers for Modem not Installing Properly
Hi guys, I've been having some trouble with my Win 7 64bit machine for a few months, and now its time to bring the giant down! Yesterday I bought a new 3G modem (Hauwei 1752) and this, just like previous modems, won't install properly on my system. It does install some of the drivers...
Drivers
trouble installing a 2nd IDE HDD
I bought a Gateway DX4822-01 with Windows 7 preinstalled. The motherboard lacks any IDE ports so I had to buy an IDE-SATA adapter for my old 250 GB Western Digital drive from my old PC. After plugging everything in, I powered up. With the device plugged in, Windows 7 takes longer to boot and...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:42.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App